Autore Topic: [RISOLTO] migrazione da 1.5.26 a 3.5.1 con J2XML: non importa tutti i dati  (Letto 1091 volte)

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
facendo seguito ad altro post, inerente la migrazione di un sito Joomla 1.5.2 a 3.5.1, ma con redMigrator, con cui sto avendo difficoltà d'installazione, ho voluto provare J2XML, la cui installazione è andata a buon fine  (http://forum.joomla.it/index.php/topic,259150.0.html)

creo i file xml di esportazione (che visti con editor di testo contengono "tutti" i dati) e procedo con l'importazione, e dopo qualche minuto di lavoro mi trovo con gli articoli importati

il problema è che gli articoli non sono tutti.....ne mancano circa 1000 (a vedere gli ID)
pubblicando una media di 5 articoli al giorno, mi fermo ai primi di dicembre 2015....mancano circa 5 mesi

c'è qualche impostazione da settare ??
« Ultima modifica: 20 Mag 2016, 15:58:31 da valtere »

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
Re: migrazione da 1.5.26 a 3.5.1 con J2XML: non importa tutti i dati
« Risposta #1 il: 20 Mag 2016, 10:49:23 »
forse scoperto perchè non aggiorna tutto:
lanciata l'importazione del "blocco1", che contiene gli articoli, il pc macina per un po, poi si ferma e il browser rimane fermo li

diversamente dalle altre importazioni (struttura e utenti), dove vedo un risultato finale, con l'importazione degli articoli rimane fermo li.....sembra bloccato

che ci  sia un limite di articoli e/o dimensioni file e/o di tempo per eseguire l'importazione ??


Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
Re: migrazione da 1.5.26 a 3.5.1 con J2XML: non importa tutti i dati
« Risposta #2 il: 20 Mag 2016, 11:08:11 »
finalmente ho trovato il log giusto, dove trovo questo:
[Fri May 20 08:00:26 2016] [error] [client 10.138.34.25] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /var/www/351/libraries/joomla/observer/updater.php on line 102, referer: http://10.138.34.25/351/administrator/index.php?option=com_j2xml&view=cpanel

sembra proprio un problema di "tempo"

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
era un problema di tempo !!!

editato php.ini (in /etc/php5/apache2)
modificato la stringa "max_execution_time = 60" portando il valore molto più alto

riavviato apache2 e rifatta l'operazione di importazione

dopo un po di lavoro, finalmente si ottiene il messaggio di operazione completata ed ora i dati importati sono nel nuovo joomla
« Ultima modifica: 20 Mag 2016, 11:49:33 da valtere »

 

Host

Torna su