Autore Topic: problema trasferimento da remoto in locale  (Letto 654 volte)

Offline claudioverga

  • Esploratore
  • **
  • Post: 103
    • Mostra profilo
problema trasferimento da remoto in locale
« il: 23 Apr 2017, 11:54:16 »

salve a tutti
avrei bisogno di un aiutino per capire questa cosa.
ho trasferito il mio sito joomla da remoto a locale> ho esportato il database da remoto> ho creato un nuovo database in locale> ho importato il database che avevo esportato da remoto> ho cambiato i nomi nel file configuration.php relativi ai dati del database:
public $host = '';
public $user = '';
public $password = '';
public $db = '';
come server locale uso easyphp.


quello che mi succede di strano è che se voglio aprire il sito in locale, con il browser chrome, mi porta sul sito in remoto, mentre se uso mozilla mi porta sul sito in locale ma non lo apre dandomi un errore. cosa manca per vedere il mio sito anche in locale?


saluti e grazie


Offline alexred

  • Fuori controllo
  • *
  • Post: 25672
  • Sesso: Maschio
  • Esperto in ozio relaxed
    • Mostra profilo
Re:problema trasferimento da remoto in locale
« Risposta #1 il: 23 Apr 2017, 12:04:50 »
Ciao claudioverga,
se hai il file .htaccess nella cartella principale del sito ti consiglio di eliminarlo.

public $live_site = '';     (controlla che sia così, vuoto)
public $sef = '0';      (su zero perchè abbiamo tolto il file .htaccess)
public $log_path = '.........??............/.......??......../logs';      (verifica che sia il path corretto dell'installazione locale e non ancora quello del server online)
public $tmp_path = '...........??........../........??......./tmp';   (verifica che sia il path corretto dell'installazione locale e non ancora quello del server online)

Offline claudioverga

  • Esploratore
  • **
  • Post: 103
    • Mostra profilo
Re:problema trasferimento da remoto in locale
« Risposta #2 il: 24 Apr 2017, 10:43:18 »
ciao
ti ringrazio per avermi risposto
purtroppo nemmeno con questa variazione ho risolto il problema, può darsi che c'è qualche anomalia nel sito in remoto.
comunque ho allegato il file php per capire se lo modificato bene; ho sostituito qualche dato (penso ininfluente per la mia causa) con dei trattini ---
saluti

Offline darkcloud

  • Nuovo arrivato
  • *
  • Post: 24
    • Mostra profilo
Re:problema trasferimento da remoto in locale
« Risposta #3 il: 05 Ott 2021, 11:06:48 »
Salve, non so se può esser ancora utile, io ho risolto questa procedura aggiungendo oltre alle informazioni già date del post, anche questi altri parametri che devono esser controllati:

public $force_ssl = '0'; (devi impostarlo a non forzare il SSL)
public $memcache_server_host = ''; (devi tenerlo vuoto)


saluti cordiali

 

Host

Torna su