Autore Topic: Trasformiamo il nostro sito Joomla in una Progressive Web Application  (Letto 863 volte)

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29928
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
In questa prima parte vediamo come far visualizzare il nostro sito Joomla come una app.

Link all'articolo: https://www.joomla.it/blog/8929-trasformiamo-il-nostro-sito-joomla-in-una-progressive-web-application.html
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Limma

  • Abituale
  • ****
  • Post: 1004
  • Sesso: Maschio
    • Mostra profilo
Grazie! Davvero molto interessante!

Offline marine

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 5006
  • Sesso: Maschio
    • Mostra profilo
Figata Pazzesca!

Offline blengyo

  • Nuovo arrivato
  • *
  • Post: 45
    • Mostra profilo
Trovo ora questo thread aperto, e ringrazio vivamente tomtomeight per la guida di questo interessante articolo. La procedura non sembra complicata, l'ho portata a termine ma con esito negativo: non mi risulta tramite console di Joomla che il file il ServiceWorker sia in esecuzione, anche se vedo correttamente i 2 file aggiunti nell'head del sito. Vedo invece dei "Service workers from other domains" attivi, tra cui dei sw.js di google o di youtube.


Grazie mille a chi saprà darmi una mano

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29928
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Ciao
Puoi postare il codice del serviceworker e il link al sito?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline blengyo

  • Nuovo arrivato
  • *
  • Post: 45
    • Mostra profilo
Si il link al sito è il seguente

LINK

il codice del sw.js è quello copiato dalla guida, a seguire:

Codice: [Seleziona]
self.addEventListener('install', e => {
  console.log('Installazione WorkService in corso');
    let timeStamp = Date.now();
    e.waitUntil(
    caches.open('asset').then(cache => {
       return cache.addAll([
    '/index.php'
  ])
 .then(() => self.skipWaiting());
    })
   )
});
self.addEventListener('activate', event => {
    console.log('Attivazione Service Worker della PWA in corso');
    event.waitUntil(self.clients.claim());
});
self.addEventListener('fetch', event => {
   event.respondWith(
    caches.match(event.request).then(response => {
     return response || fetch(event.request);
     })
  );
});
« Ultima modifica: 14 Dic 2018, 23:41:50 da blengyo »

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29928
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Ciao
Il tuo sito manca di un requisito come specificato nell'articolo che riporto:

Citazione
Ovviamente servono dei minimi requisiti: il sito deve avere un certificato https,
Inoltre ispezionando da chrome con altri strumenti -> strumenti per sviluppatori ->Application hai anche un errore nel manifest.json che riporto:
Citazione
Line 12, column 11, Dicyionary Keys must be quoted.
Inoltre non carica le icone come puoi vedere dalla immagine che allego
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline blengyo

  • Nuovo arrivato
  • *
  • Post: 45
    • Mostra profilo
ok grazie. Il manifest ora dovrebbe essere a posto (forse c'era una graffa in più), il certificato ssl era attivo ma ti ho linkato il sito senza https! Ecco il LINK giusto. Come svuoto la cache? Perchè ora dalla console di chrome mi sembra funzionare, ma devo aprire chrome in modalità in incognito. Mentre su mobile, neanche da incognito, mi propone di mettere la webapp sulla home!


Forse mi perdo ancora qualcosa.. anche se su modalità in incognito, tra gli errori leggo: "Site cannot be installed: the page is loaded in an incognito window"


grazie mille

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29928
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Sì la graffa iin più e un errore di copia dell'articolo che correggerò. Verifica con chrome  se presenta altri errori ed anche da mobile e sempre concchrome ddovrebbe apparire il messaggio di invito ad aggiungere la webapp.
Edit:  comunque io da tab e chrome sono riuscito ad aggiungere la tua app.


La aggiunge però mi da errore 404, devi verificare dove sbagli.
« Ultima modifica: 15 Dic 2018, 12:01:57 da tomtomeight »
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

 

Host

Torna su