Autore Topic: FORM richiesta di informazioni non funzionano nessuno  (Letto 426 volte)

Offline Irene93

  • Esploratore
  • **
  • Post: 155
  • Sesso: Femmina
    • Mostra profilo
Salve. HO installato tutti i moduli di richiesta informazioni nel mio sito ma non mi funzionano.
E non capisco il perchè! E' la prima volta che mi capita.
Inoltre ho provato da configurazione globale > server > impostazioni mail e quando seleziono invia email di prova mi da errore sia con php che send mail: Non è stato possibile inviare l'email.
Invece con SMTP mi dice: Si è verificato un errore durante il recupero dei dati JSON: codice di stato HTTP 503. Backend fetch failed
Voglio creare un semplice modulo in cui i clienti inseriscono nome, email, oggetto e messaggio.
Potete aiutarmi? Sto impazzendo.
Il sito è su One.com
« Ultima modifica: 19 Gen 2019, 23:20:30 da Irene93 »

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30472
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #1 il: 19 Gen 2019, 19:11:34 »
Tutti ma quali? Quindi nessun sito ha un modulo di richiesta informazioni? Prima di fare certe affermazioni bisognerebbe riflettere.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline druskus

  • Appassionato
  • ***
  • Post: 213
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #2 il: 19 Gen 2019, 19:52:09 »
Ciao irene Joomla di default ha una sua estensione nativa dove poter ricevere messaggi da parte degli utenti e fa quello che richiedi tu, prova a verificare, per l'email quel tipo di errore lo ricevi perchè non hai impostato correttamente la configurazione smtp se hai bisogno di ulteriori chiarimenti e/o aiuti siamo qui a disposizione.
« Ultima modifica: 19 Gen 2019, 20:04:35 da druskus »
Impero Web-Community Builder Italia https://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline Irene93

  • Esploratore
  • **
  • Post: 155
  • Sesso: Femmina
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #3 il: 19 Gen 2019, 23:19:29 »
tomtomeight: e prima di sentirsela bisogna imparare a leggere!
tutti i moduli di richiesta informazioni nel mio sito ma non mi funzionano.
E' la prima volta che mi capita.
Nessuno ha detto che sono i moduli che non funzionano. Ma che non funzionano nel mio sito!

Offline Irene93

  • Esploratore
  • **
  • Post: 155
  • Sesso: Femmina
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #4 il: 19 Gen 2019, 23:21:16 »
druskus grazie
Ma non so più cosa devo fare! potresti aiutarmi?

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30472
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #5 il: 20 Gen 2019, 08:22:11 »
Non voglio essere polemico nel titolo generalizzi tutti ma ancora non dici quali, non funziona vuol dire tutto e nulla se non specifichi se relativo a solo invio email o altro. Giusto per capire se sipende effettivamente da moduli o altro. Vedi capire la natura del problema aiuta ad aiutarti
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Irene93

  • Esploratore
  • **
  • Post: 155
  • Sesso: Femmina
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #6 il: 20 Gen 2019, 15:54:49 »
ho provato da configurazione globale > server > impostazioni mail e quando seleziono invia email di prova mi da errore sia con php che send mail: [/size][/size]Non è stato possibile inviare l'email.[/size]Invece con SMTP mi dice: [/color][/size]Si è verificato un errore durante il recupero dei dati JSON: codice di stato HTTP 503. [/color][/size]Backend fetch failed[/color]

Offline druskus

  • Appassionato
  • ***
  • Post: 213
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #7 il: 20 Gen 2019, 16:03:12 »
Non posso dare torto a Tom in effetti ho impiegato anche io a cercare di capire bene quale sia il problema, magari è facile fraintendersi in un contesto di testo e ti posso garantire che siamo qui tutti per aiutarci al meglio.


Per Capire meglio il tuo problema serve che anche capire:
Che Installazione hai di Joomla una nuova installazione o è un sito di produzione aggiornato?


Nel Caso fosse un sito antecedente alla versione 3.9.2 ed aggiornata all'ultima versione ti consiglierei come prima cosa di ripetere l'aggiornamento, magari c'è stato un qualche errore nella sovrascrittura dei file durante l'aggiornamento.


Nel caso in cui sia una nuova installazione ti consiglierei di vedere le opzioni di firewall del tuo host, oppure che la mail che utilizzi non sia contrassegnata come spam e magari blocca i messaggi.


Per L'invio Email utilizzi le email del tuo provider esempio @nomesito.it oppure utilizzi un provider email differente esempio gmail?


Se utilizzi gmail come prima cosa non partono le email in php, con sendmail dipende dal tuo hoster, di solito quasi tutti hanno funzionalità sendmail ma anche questo dipende dal livello di protezione imposto dal tuo hoster.


Per quanto riguarda Gmail per poter inviare le email dal sito web con le nuove impostazioni devi configurare nelle impostazioni di gmail la possibilità di collegarsi ed inviare email da siti esterni altrimenti non ti invia nulla.
Una volta impostate le configurazioni di Gmail come per qualsiasi altra email la configurazione smtp include:


ti porto esempio per Gmail da eseguire nelle configurazioni generali di Joomla nella scheda Server:


Host SMTP            : smtp.gmail.com
Porta SMTP           : 465
Auth SMTP            : si
Nome Utente SMTP: inserisci la tua email gmail
Password SMTP      : la password di accesso SMTP


Se hai ulteriori dubbi non esitare a chiedere.
Impero Web-Community Builder Italia https://communitybuilders.it Sito di Supporto per il Componente Community Builder

Offline Irene93

  • Esploratore
  • **
  • Post: 155
  • Sesso: Femmina
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #8 il: 20 Gen 2019, 19:14:35 »
Se già non mi invia l'email di prova ma mi da questo errore: Si è verificato un errore durante il recupero dei dati JSON: codice di stato HTTP 503. [/size]Backend fetch failed[/color] vuol dire che il problema sta nel sito, non nei moduli. Giusto?
Comunque utilizzo gmail. Riguardo il sito su one.com ho acquistato un quickstart della LT

Offline druskus

  • Appassionato
  • ***
  • Post: 213
  • Sesso: Maschio
  • www.imperoweb.it Community Builder Italia
    • Mostra profilo
Re:FORM richiesta di informazioni non funzionano nessuno
« Risposta #9 il: 20 Gen 2019, 19:25:14 »
prova a ricaricare l'aggiornamento di Joomla vedi se risolvi
Impero Web-Community Builder Italia https://communitybuilders.it Sito di Supporto per il Componente Community Builder

 

Host

Torna su