Autore Topic: [Risolto] Ottengo 404 not found su home con prefisso lingua  (Letto 492 volte)

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30579
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Buonasera

Nuovo sito multilingua appena installato (quindi 3.9.2) e solo con elementi demo;
lingue it ed en, lingua predefinita (per ora) it, rimuovi prefisso lingua predefinita sì.
sito: https://napleslanka.com
Con apertura sito da url e quindi senza prefisso lingua tutto ok, si apre pagina home it con articolo di prova, se clicco sulla bandierina en ottengo il 404 con url napleslanka.com/en mentre se invece prima clicco sull'articolo e poi sulla bandierina è tutto ok. Insomma se è presente il suffisso lingua da solo va in errore 404.
Uso server con nginx


« Ultima modifica: 27 Gen 2019, 18:14:52 da tomtomeight »
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30579
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Ottengo 404 not found su home con prefisso lingua
« Risposta #1 il: 27 Gen 2019, 11:06:59 »
Continuo ad avere questo errore nonostante abbia cambiato pure template con framework Gantry e verificato tutte le impostazioni, verificherò anche con una versione precedente per escludere sia dovuto alla 3.9.2
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline danielecr

  • Abituale
  • ****
  • Post: 1316
    • Mostra profilo
Re:Ottengo 404 not found su home con prefisso lingua
« Risposta #2 il: 27 Gen 2019, 15:33:32 »
Ho notato che https://napleslanka.com/en N.B. senza slash finale il sito è raggiungibile, magari può esserti di aiuto..nell'htaccess puoi mettere una regola.

Qui mi sembra si descriva il tuo stesso problema:
https://issues.joomla.org/tracker/joomla-cms/23209?lang=et-EE
« Ultima modifica: 27 Gen 2019, 16:04:18 da danielecr »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30579
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:[Risolto] Ottengo 404 not found su home con prefisso lingua
« Risposta #3 il: 27 Gen 2019, 18:23:48 »
Grazie danielecr

Apportando quelle modifiche ma solo al file default.php (modificando pure il languagefilter.php mi aggiungeva un suffisso en.html che ridava 404) ho risolto anche se non ho capito dipenda dalla mia particolare configurazione del server o proprio da joomla. Mi salvo li file modificato e staremo a vedere per le prossime versioni, intanto se qualcuno ha lo stesso problema e risolve allo stesso modo ci informi.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline danielecr

  • Abituale
  • ****
  • Post: 1316
    • Mostra profilo
Re:[Risolto] Ottengo 404 not found su home con prefisso lingua
« Risposta #4 il: 27 Gen 2019, 18:26:38 »
Credo 50%-50%.
Io su apache non ho errore 404 con lo slash dopo il codice lingua.

 

Host

Torna su