Autore Topic: Problema con apertura articoli dopo passaggio Joomla 3.9.2 oppure a php 7.1.26  (Letto 483 volte)

Offline trattino

  • Esploratore
  • **
  • Post: 175
  • Sesso: Maschio
    • Mostra profilo
Ciao dopo l'aggiornamento alla versione Joomla! 3.9.2 oppure col passaggio a php 7.1.26 i link anche quelli del menu portano alla pagina di Errore: 0 Using $this when not in object context
(ad es. in menu principale "ABOUT" link http://www.carpinofolkfestival.com/about/blog/about)
Ho ottimizzato le tabelle del database, effettuato il controllo globale, pulizia cache ed eliminato la cache scaduta. Ho ovviamente aggiornato il link, ma l'errore persiste.
Faccio notare che vale solo per i link ad altre pagine, invece tutto ok per i collegamenti ad altri componenti (vedi in menu principale "STAMPA" http://www.carpinofolkfestival.com/index.php/stampa).
Sapete cosa potrebbe essere il problema, grazie.
A seguito di tentativi ho in realtà compreso che non sono i link a non funzionare, ma non si aprono proprio le pagine degli articoli. Come potrete notare cliccando qui sotto.
http://www.carpinofolkfestival.com/index.php?option=com_content&view=article&id=73&Itemid=180

Quindi riformulo la domanda. Cosa può impedire la visualizzazione degli articoli con joomla 3.9.2 oppure com php 7.1.26?
« Ultima modifica: 10 Feb 2019, 09:17:46 da trattino »

Offline emerenziano

  • Esploratore
  • **
  • Post: 162
  • Sesso: Maschio
    • Mostra profilo
Se usi il modulo Random Image guarda se questo https://forum.joomla.org/viewtopic.php?t=962733 può esserti di aiuto.

Se non è questo il problema, prova a modificare la voce di menu da "Categoria blog" a "Lista di una singola categoria" e vedi se così funziona.
« Ultima modifica: 09 Feb 2019, 23:17:11 da emerenziano »

Offline trattino

  • Esploratore
  • **
  • Post: 175
  • Sesso: Maschio
    • Mostra profilo
CIao emerenziano. Non ho quel modulo e non ha sortito effetti il tuo suggerimento. Ma grazie a te ho capito che in realtà non sono i link a non funzionare, ma non si aprono proprio le pagine degli articoli. Come potrai notare cliccando qui sotto.
http://www.carpinofolkfestival.com/index.php?option=com_content&view=article&id=73&Itemid=180

Quindi riformulo la domanda. Cosa può impedire la visualizzazione degli articoli col joomla 3.9.2 oppure com php 7.1.26?

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30326
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
E' un errore di versione php, cosa usi per visualizzare gli articoli?
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline emerenziano

  • Esploratore
  • **
  • Post: 162
  • Sesso: Maschio
    • Mostra profilo
Al link  http://www.carpinofolkfestival.com/about/blog si vedono gli articoli. Il link da te indicato porta a http://www.carpinofolkfestival.com/about/blog/info-associazione articolo che non sembra esistere.
A questo punto vale il suggerimento dato di provare a cambiare la versione di PHP, se è nelle tue possibilità. Io proverei anche a mettere tutti "NO" nelle impostazioni SEO (in configuraione globale di Joomla) e vedere se cambia qualcosa.

Offline trattino

  • Esploratore
  • **
  • Post: 175
  • Sesso: Maschio
    • Mostra profilo
Ti ringrazio per la pazienza, ma non ho cavato un ragno dal buco.Tutti gli articoli sono visibili da http://www.carpinofolkfestival.com/about/blog/ compreso quello che tu dici che non esiste (é il primo della lista) il punto è che pure partendo da essi se clicchi sul titolo di ciascun articolo ti riporta all'errore. Quindi sono al punto di partenza.Ho fatto la prova di mettete tutti no al seo, ma non è quello.Altri suggerimenti?

Offline emerenziano

  • Esploratore
  • **
  • Post: 162
  • Sesso: Maschio
    • Mostra profilo
Mi pare che il problema lo hai con articoli in layout blog. Infatti "Contatti" e "News" funzionano. Io proverei a mettere il layout "Lista" anche agli articoli di "About" e "Festival". Basta che modifichi le voci di menu (Tipo voce menu --> Articoli --> Lista di singola categoria) e scegli, ovviamente la categoria. Al momento non mi viene altro, se non quella di vedere con altre versioni di PHP.

Offline trattino

  • Esploratore
  • **
  • Post: 175
  • Sesso: Maschio
    • Mostra profilo
Allora il problema riguarda la visualizzazione di un signolo articolo. Tutti i link che puntano ad un articolo portano all'errore 0. Se invece creo una categoria per ciascun articolo e il link punta alla categoria e non all'articolo l'errore scompare. Chiaro che non è la soluzione, quindi sarei curioso di altri suggerimenti.

 

Host

Torna su