Autore Topic: Impossibile installare Joomla 3  (Letto 395 volte)

Offline spino871

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
Impossibile installare Joomla 3
« il: 31 Mar 2019, 10:44:51 »
Salve a tutti,
Sul mio PC  Kubuntu 14.04 avevo fino a pochi giorni f installato una copia locale di un mio sito per prove.
Il sistema fornito di tutta la batteria necessaria (php, apache2, Mysql).
Il problema nato quando ho aggiornato il sistema a 18.04 il che ha comportato l'upgrading di php a 1:7.2 (non ricordo cosa era prima).
Quando sono andato ad installare un Back-up fatto con Akeeba, non ha funzionato. Allora per escludere Akeeba dal problema ho ripulito la directory ed ho tentato di installare Joomla da zero.
Quando, per, accedo con
Codice: [Seleziona]
http://127.0.0.1/appunti/installation/index.phpOttengo una pagina bianca con la scritta:
Codice: [Seleziona]
execute();Come controprova ho provato ad accedere con
Codice: [Seleziona]
127.0.0.1/mi viene la pagina di prova di Apache2 testimoniando che il sistema funziona.L'unica ipotesi che mi viene in mente che manchi qualche pacchetto, ma non so interpretare quello che succede.
« Ultima modifica: 31 Mar 2019, 10:59:14 da spino871 »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30241
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #1 il: 31 Mar 2019, 11:11:11 »
Ciao

Ti manca php
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline emerenziano

  • Esploratore
  • **
  • Post: 161
  • Sesso: Maschio
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #2 il: 31 Mar 2019, 11:50:09 »
Come suggerito probabile che PHP non funzioni. Probabilmente l'aggiornamento alla versione 7.2 non ha avuto buon fine ed rimasto qualche riferimento nel file php.ini alla versione precedente. Per essere certo che PHP funzioni, crea con un editor nella root di Apache un file "phpinfo.php" con il codice:
Codice: [Seleziona]
<?php
phpinfo
();
?>


Se PHP funziona apparir la pagina con le informazioni sullo stesso, estensioni, MySql, etc. Se non appare nulla l'unica cosa reinstallare PHP.


Offline spino871

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #3 il: 31 Mar 2019, 12:30:45 »
Ho creato il file come suggerito ma il risultato una pagina bianca.Allora ho reinstallato php ma ne risulta una serie di "worning":
Codice: [Seleziona]
(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.717: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.717: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.717: Theme parsing error: gtk.css:70:34: The style property GtkCheckButton:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.717: Theme parsing error: gtk.css:71:36: The style property GtkCheckMenuItem:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.718: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.718: Theme parsing error: gtk.css:76:30: The style property GtkExpander:expander-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27895): Gtk-WARNING **: 12:27:11.719: Theme parsing error: gtk.css:83:29: The style property GtkStatusbar:shadow-type is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.774: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.774: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.774: Theme parsing error: gtk.css:70:34: The style property GtkCheckButton:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.774: Theme parsing error: gtk.css:71:36: The style property GtkCheckMenuItem:indicator-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.774: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.774: Theme parsing error: gtk.css:76:30: The style property GtkExpander:expander-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(dpkg-preconfigure:27893): Gtk-WARNING **: 12:27:11.775: Theme parsing error: gtk.css:83:29: The style property GtkStatusbar:shadow-type is deprecated and shouldn't be used anymore. It will be removed in a future version
(Lettura del database... 296576 file e directory attualmente installati.)
Preparativi per estrarre .../php_1%3a7.2+60ubuntu1_all.deb...
Estrazione di php (1:7.2+60ubuntu1) su (1:7.2+60ubuntu1)...
Configurazione di php (1:7.2+60ubuntu1)...
che non so interpretare.


Offline emerenziano

  • Esploratore
  • **
  • Post: 161
  • Sesso: Maschio
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #4 il: 31 Mar 2019, 17:57:40 »
GTK sono i temi Gnome per il desktop di Ubuntu. Francamente non saprei come aiutarti, ma credo che il problema sia nell'installazione di Ubuntu o in successivo aggiornamento. Se phpinfo.php d una pagina bianca sicuramente qualcosa a livello di PHP o di Apache non va. Se non risolvi questi problemi non puoi certo installare Joomla.

Offline spino871

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #5 il: 04 Mag 2019, 11:36:26 »
Il problema si risolto da solo. Ad una prova rifatta oggi tutto funziona normalmente. Evidentemente c'era un bug in qualche aggiornamento che nel frattempo stato messo a posto.

Offline ilvanni

  • Global Moderator
  • Instancabile
  • ********
  • Post: 6983
  • Sesso: Maschio
  • Giovanni Vacca
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #6 il: 04 Giu 2019, 09:32:07 »
per piacere inserisci il risolto nel titolo del primo post, grazie

Offline spino871

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #7 il: 04 Giu 2019, 10:24:28 »
Chiedo scusa, ma non so come si fa. Non trovo un pulsante "modifica".

Offline ilvanni

  • Global Moderator
  • Instancabile
  • ********
  • Post: 6983
  • Sesso: Maschio
  • Giovanni Vacca
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #8 il: 07 Giu 2019, 08:38:52 »
c', c'... sulla destra del titolo ci sono delle voci (modifica, etc. ) che ti consentono di fare quello che ti serve
ti potr servire per il futuro per inserirlo su altri thread da te aperti e che hanno trovato soluzione, per far vedere subito a tutti i "naviganti" che per quel problema c' una soluzione scritta l, in uno dei post

Offline spino871

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
[Risolto]Re:Impossibile installare Joomla 3
« Risposta #9 il: 07 Giu 2019, 09:12:40 »
Salve a tutti,
Sul mio PC  Kubuntu 14.04 avevo fino a pochi giorni f installato una copia locale di un mio sito per prove.
Il sistema fornito di tutta la batteria necessaria (php, apache2, Mysql).
Il problema nato quando ho aggiornato il sistema a 18.04 il che ha comportato l'upgrading di php a 1:7.2 (non ricordo cosa era prima).
Quando sono andato ad installare un Back-up fatto con Akeeba, non ha funzionato. Allora per escludere Akeeba dal problema ho ripulito la directory ed ho tentato di installare Joomla da zero.
Quando, per, accedo con
Codice: [Seleziona]
http://127.0.0.1/appunti/installation/index.phpOttengo una pagina bianca con la scritta:
Codice: [Seleziona]
execute();Come controprova ho provato ad accedere con
Codice: [Seleziona]
127.0.0.1/mi viene la pagina di prova di Apache2 testimoniando che il sistema funziona.L'unica ipotesi che mi viene in mente che manchi qualche pacchetto, ma non so interpretare quello che succede.

Offline spino871

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
Re:[Risolto]Re:Impossibile installare Joomla 3
« Risposta #10 il: 07 Giu 2019, 09:23:12 »
una cosa che faccio sempre in tutti i forum dove partecipo, ma ti assicuro che il pulsante "modifica" non c'. Ti allego l'immagine della schermata.

Offline ilvanni

  • Global Moderator
  • Instancabile
  • ********
  • Post: 6983
  • Sesso: Maschio
  • Giovanni Vacca
    • Mostra profilo
Re:Impossibile installare Joomla 3
« Risposta #11 il: 07 Giu 2019, 11:37:38 »
devi essere loggato per farlo ovviamente
tra l'altro il tuo primo post stato gi da te editato e modificato quindi puoi farlo

 

Host

Torna su