Autore Topic: [RISOLTO] Themler, qualcuno lo usa? Non mi compaiono i moduli...  (Letto 201 volte)

Offline lucablue

  • Esploratore
  • **
  • Post: 163
    • Mostra profilo
Ciao a tutti,
mi succede una cosa strana con il template basato sul framework Themler che al momento neanche il loro supporto riesce a spiegare, magari non dipende dal tema ma da altro, vi spiego:
Ho caricato il template bianco ed ho iniziato a modificarlo, come al solito. Inserisco alcune joomla position, come hmenu per inserire il menu orizzontale, ed inserisco il menu con le varie voci.
Qual'è il problema? Tutti questi moduli, compreso il menu, appunto, nel front end non sono assolutamente visibili finche, come amministratore, entro nell'editor del template, dopodicché tutto si vede normalmente.
La cosa strana è che nel codice html (visualizzato con la funzione "ispeziona" dei browser firefox e chrome) è lo stesso, quindi il codice per far apparire il menu c'è, solo che se non accedo all'editor del tema non si vede.
Se entro nell'editor del tema e poi esco, nel front end continua ad essere mostrato il menu e gli altri moduli. Quindi per funzionare devo per forza entrare come admin nell'editor una prima volta con lo stesso browser.

Ecco il codice del front end quando entro nell'editor:
Codice: [Seleziona]
<div class="bd-horizontalmenu-48 bd-page-width  clearfix jmoddiv jmodinside" data-jmodediturl="https://www.dreamlifeonlus.org/core/index.php?option=com_config&amp;controller=config.display.modules&amp;id=59&amp;Itemid=373&amp;return=aHR0cHM6Ly93d3cuZHJlYW1saWZlb25sdXMub3JnL2NvcmUvcHJlc3MtYmxvZw%3D%3D" data-target="_self" data-jmodtip="<strong>Modifica modulo</strong>[br /]Menu principale - new[br /]Posizione: hmenu" data-jmenuedittip="<strong>Modifica voce di menu</strong>[br /]Id elemento: %s">
    <div class="bd-container-inner">
       
               
<ul class=" bd-menu-42 nav navbar-right nav-pills">
                       
        <li class=" bd-menuitem-22 bd-toplevel-item  item-101 " data-original-title="" title="">
<a href="/core/"><span>HOME</span>[/url]</li>                       
        <li class=" bd-menuitem-22 bd-toplevel-item  item-371 ">
<a href="/core/dreamlife-cosa-facciamo"><span>COSA FACCIAMO</span>[/url]</li>                       
        <li class=" bd-menuitem-22 bd-toplevel-item  item-372 ">
<a href="/core/blog"><span>BLOG</span>[/url]</li>                       
        <li class=" bd-menuitem-22 bd-toplevel-item  item-373  current">
<a class="  active" href="/core/press-blog"><span>PRESS</span>[/url]</li>                </ul>       
    </div>
</div>
Questo è quello che vedo quando non sono entrato nell'editor:
Codice: [Seleziona]
<nav class=" bd-hmenu-1 bd-page-width  bd-no-margins" data-responsive-menu="true" data-responsive-levels="expand on click" data-responsive-type="" data-offcanvas-delay="0ms" data-offcanvas-duration="700ms" data-offcanvas-timing-function="ease">
                       
                <div class=" bd-menuoverlay-11 bd-menu-overlay"></div>
                <div class=" bd-responsivemenu-11 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-10 ">
            <a data-toggle="collapse" data-target=".bd-hmenu-1 .collapse-button + .navbar-collapse" href="#" onclick="return false;">
                    <span>Menu</span>
            [/url]
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse ">
                            <div class="bd-menu-close-icon">
    <a href="#" class="bd-icon  bd-icon-38">[/url]
</div>
           
                </div>
                    </nav>
Qualcuno ha suggerimenti?
« Ultima modifica: 08 Apr 2019, 11:41:27 da lucablue »

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19653
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Ho provato ad usarlo, ma ho lasciato perdere, siti appesantiti e pagine duplicate a iosa.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline lucablue

  • Esploratore
  • **
  • Post: 163
    • Mostra profilo
Re:[RISOLTO] Themler, qualcuno lo usa? Non mi compaiono i moduli...
« Risposta #2 il: 08 Apr 2019, 11:44:07 »
Per chiunque avesse lo stesso problema ho trovato il perché di questo comportamento:
E' necessario attivare le opzioni "Suffisso URL" e "Alias Unicode" della configurazione globale di Joomla! per far visualizzare tutto correttamente.
PS Themler è lentino e pesante nell'editor, cioé nel backend per creare le pagine, poi in front end è veloce come qualsiasi altro template, ma la potenzialità di modifica e personalizzazione è davvero elevata.

 

Host

Torna su