Autore Topic: Evitare aggiornamento da 2.5 a 3 ...si può?  (Letto 167 volte)

Offline Utente42

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Evitare aggiornamento da 2.5 a 3 ...si può?
« il: 21 Mag 2019, 11:52:34 »
Sto avendo un sacco di problemi cercando di aggiornare un sito da 2.5.28 a 3.5.1
Ho fatto tre tentativi, seguendo guide leggermente diverse, ma niente. Ottengo sempre lo stesso errore.
Tra l'altro è un sito con davvero pochissime estensioni di terze parti (Akeeba, gk_News, un template custom e HD-OG che dovrebbe servire a gestire i metadata).
Non c'è verso di riuscire a fare questo aggiornamento.

Così ho pensato: non posso esportarmi dal db le tabelle relative agli aritcoli, alle immagini, ai banner (il sito è un portale di news), installarmi un Joomla 3 fresco sul server, e poi ripopolare il db manualmente?

Può funzionare, o è un'idea insensata?

In caso, che tabelle dovrei esportare? Dovrei operare dei cambi alla loro struttura per renderle compatibili con J3 ?

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30326
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Evitare aggiornamento da 2.5 a 3 ...si può?
« Risposta #1 il: 21 Mag 2019, 12:12:57 »
Esportare e importare a mano su versioni diverse non è possibile, tanto vale fare copia incolla. Esistono però utility che li fanno tipo j2xml.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline Utente42

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Re:Evitare aggiornamento da 2.5 a 3 ...si può?
« Risposta #2 il: 21 Mag 2019, 12:20:12 »
Stavo in effetti guardando se esistessero estensioni per farlo... Grazie!
« Ultima modifica: 21 Mag 2019, 12:30:36 da Utente42 »

 

Host

Torna su