Autore Topic: Menu nascosto categoria blog non mi mostra i contenuti relativi  (Letto 110 volte)

Offline danjde

  • Appassionato
  • ***
  • Post: 294
  • Sesso: Maschio
    • Mostra profilo
Salve Amici,
faccio una premessa:
1. sto cercando di realizzare una pagina con ordinamento alfabetico di alcuni contenuti.
2. Ho creato così una pagina html con lettere in ordine alfabetico dove ogni lettera dovrebbe puntare alla specifica categoria (nel mio caso "archivio A, archivio B, etc)....
3. Il menu di queste pagine non voglio che si aggiunga ai menu presenti così vado in "Opzioni Link" e disabilito "Visualizza nel Menu".
4. A questo punto vorrei ottenere il link da agganciare alle lettere alfabetiche, così vado nella finestra "Dettagli" della voce di menu specifica e copio il link e lo incollo nella pagina html (punto 2)

E qui sta il mistero (almeno per me): il link porta ad una pagina che mi avvisa:

Citazione
Non ci sono articoli in questa categoria. Se si visualizzano le sottocategorie, dovrebbero contenere degli articoli.

Se invece pubblico per un attimo la voce di menu e traggo da questo il link, tutto bene.

Sembra che il link in formato "index.php?option=com_content&view=category&layout=blog&id=" non venga gestito..

Dove sbaglio? :-)

Spero di essere stato chiaro..  :-[


Grazie infinite!

Davide

cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e

Offline danjde

  • Appassionato
  • ***
  • Post: 294
  • Sesso: Maschio
    • Mostra profilo
Re:Menu nascosto categoria blog non mi mostra i contenuti relativi
« Risposta #1 il: 05 Giu 2019, 12:52:43 »
..sto verificando in questo momento che esiste una relazione con i "tags".
Avevo creato infatti dei tags per ogni categoria, ora se assegno il relativo tags al contenuto questo viene mostrato (anche se rimosso dalla voce di categoria e dalla voce di menu), se tolgo il tag nascosto....


AGGIORNAMENTO

Ho provato ad assegnare un tag diverso all'articolo e questo scompare, ho provato a sospendere il tag e l'articolo scompare, ho provato a togliere ogni tag all'articolo e questo scompare.
In sostanza l'articolo di una specifica categoria appare solo se aggiungo il tag che avevo associato alla categoria in fase di creazione.

Ho provato anche a rimuovere ogni tag alla categoria e all'articolo ma non mi viene mostrato.

Prova ad aggiornare Joomla, attualmente uso la verisone "Joomla! 3.9.4"

Grazie
« Ultima modifica: 05 Giu 2019, 13:01:06 da danjde »
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e

Offline ilvanni

  • Global Moderator
  • Instancabile
  • ********
  • Post: 6985
  • Sesso: Maschio
  • Giovanni Vacca
    • Mostra profilo
Re:Menu nascosto categoria blog non mi mostra i contenuti relativi
« Risposta #2 il: 07 Giu 2019, 08:42:44 »
Prova ad aggiornare Joomla, attualmente uso la verisone "Joomla! 3.9.4"
certamente sì, al di là del tuo problema, cerca di tenere sempre aggiornato sia il cms che le estensioni/template

 

Host

Torna su