Autore Topic: 0 - Call to undefined function ereg_replace() se faccio upgrade php  (Letto 347 volte)

Offline dariot

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Salve a tutti, ho aggiornato joomla al'ultima versione, e anche tutte le estensioni che mi consigliava di aggiornare.I template sono aggiornati e compatibili con php7, ma quando faccio l'upgrade da 5.6 a 7 mi da l'errore in oggetto.
Ho provato a controllare se ci fosse qualche modulo o plugin obsoleto ma sono tutti all'ultima versione...
Come posso fare ulteriori controlli?
GrazieDario

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31205
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Quale php versione 7 hai upgradato? Ricorda che le versioni sono rappresentate da tre cifre. V. X.x.xx

Offline dariot

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Tutto 3 quelle disponibili dal mio pannello, 7.0. 33, 7.1.29, 7.2. 18, 7.3.5


Qualunque provo stesso errore, accede al backend ma se cerco di caricare il sito pagina con la scritta in oggetto...

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31205
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Evidentemente qualche estensione non pienamente compatibile, prova la pi bassa delle versioni 7. ed eventualmente se l'errore che riporti non proprio un errore ma piuttosto un warning metti al minimo la visualizzazione errori di joomla. Alternativa correggere la sintassi del codice nella estensione che provoca questo difetto. Su come correggere fai una bella ricerca e trovi le soluzioni da applicare.

Offline dariot

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Funziona solo con php5.6, se salgo si blocca e non riesco a trovare l'estensione che potrebbe non funzionare, le ho disabilitate tutte una per una ma nisba... Gli errori sono disabilitati, il sito non si carica... Jello il problema. Inoltre ho visto che uando scrivo l'indirizzo mi aggiunge automaticamente un /en come se facesse riferimento ad un sito in inglese ma non ho trovato informazioni a riguardo...


 

Host

Torna su