Autore Topic: Aggiornamento del php al 7.2.26 genera un errore  (Letto 136 volte)

Offline robertoseveri1974

  • Appassionato
  • ***
  • Post: 310
    • Mostra profilo
Aggiornamento del php al 7.2.26 genera un errore
« il: 28 Gen 2020, 17:46:19 »
Ho da pochissimo finito un sito web www.lecasediparma.it, in cui ho cambiato il php, dal 7.1 son passato al 7.2, come da segnalazione di joomla. ora però mi ritrovo questo errore:


Warning[/size]: count(): Parameter must be an array or an object that implements Countable in [/color][/size]/web/htdocs/www.lecasediparma.it/home/administrator/components/com_bt_property/tables/category.php[/color][/size] on line [/color][/size]104[/color]
[/size][/color]
[/size]ho aperto il file e alla riga 104 mi ritrovo: [/color]

Codice: [Seleziona]



if (!count($array['extra_fields'])) {
            $array['extra_fields'] = ",";
        }




io però di php non ne capisco nulla, qualcuno mi può aiutare?

Offline robertoseveri1974

  • Appassionato
  • ***
  • Post: 310
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #1 il: 28 Gen 2020, 17:49:22 »
per il momento mi sono limitato a togliere la visualizzazione, ma se posso, vorrei risolvere l'errore. Grazie in anticipo.

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19986
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #2 il: 28 Gen 2020, 18:11:08 »
il componente com_bt_property è compatibile con la versione di PHP 7.2.26?
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline robertoseveri1974

  • Appassionato
  • ***
  • Post: 310
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #3 il: 28 Gen 2020, 18:39:02 »
non lo aggiornano da almeno 3 anni (quindi direi di no), hanno un forum ma è da allora che non rispondono. è così complesso il discorso? pensavo che per chi conosce il php fosse una cosa rapida.....cioè pensavo bastasse correggere la sintassi....

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19986
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #4 il: 28 Gen 2020, 21:09:50 »
spesso il discorso è molto più complicato e sarebbe bellissimo risolvere modificando la stringa.

Ricorda che l'informatica è una catena di affetti:
“Vede architetto, è tutta una catena di affetti che né io e né lei possiamo spezzare. Lei ama mia moglie, mia moglie è affezionatissima a Birillo. Birillo adora le bambine. Le bambine sono attaccatissime alla governante…”.
“La governante?!”
“Tedesca, due anni di contratto, severissima, in uniforme. Insomma, chi si prende Donatella, deve prendersi per forza tutto il blocco”.

 ;)
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 30860
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #5 il: 28 Gen 2020, 21:31:25 »
...pensavo che per chi conosce il php fosse una cosa rapida.....cioè pensavo bastasse correggere la sintassi....


Pensavi sbagliato, forse nessuno che conosce il php e che frequenta questo forum è  mai incorso in questo errore. Visto che è capitato a te non credi sia ora di metterci un po di impegno e cominciare a imparare qualcosina di php? Io molte volte con l'aiuto di google ho risolto qualche errore di incompatibilità php e all'inizio anche per me il php era ostrogoto. Ma di necessità ho fatto virtù.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline robertoseveri1974

  • Appassionato
  • ***
  • Post: 310
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #6 il: 29 Gen 2020, 10:54:36 »
a dir la verità c'ho anche provato, ma oramai son troppo vecchio per imparare un linguaggio di programmazione (trovo più semplice fare una rianimazione ad esempio). che poi non mi sembra nemmeno così facile! io son rimasto al basic e al pascal......che poi non ho mai usato, perchè ho sempre fatto altro nella vita. se non è così semplice, pazienza, mi terrò l'errore, per ora. Tengo cmq monitorato il forum di bt property che magari qualcuno che ne sa risolve il problema.

Offline giusebos

  • Fuori controllo
  • *
  • Post: 19986
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #7 il: 29 Gen 2020, 13:55:48 »
Purtroppo con quella estensione viene fornita assistenza a pagamento, 59$ per 4 mesi
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline robertoseveri1974

  • Appassionato
  • ***
  • Post: 310
    • Mostra profilo
Re:Aggiornamento del php al 7.2.26 genera un errore
« Risposta #8 il: 29 Gen 2020, 15:56:08 »
a dir la verità manco a pagamento te la danno. io è circa un annetto che ci lavoro sopra e ho scandagliato più volte il loro forum. hanno proprio mollato lo sviluppo, peccato perchè era un'ottimo componente, molto versatile e facilmente adattabile a molte particolarità del settore immobiliare. Grazie lo stesso per la disponibilità, cercherò una soluzione pian piano e appena l'avrò trovata la posterò qui di seguito, magari a qualcuno serve.

 

Host

Torna su