Autore Topic: TOP HOST - Problemi con le Immagini  (Letto 6175 volte)

Offline ceramigli

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
TOP HOST - Problemi con le Immagini
« il: 10 Ago 2005, 00:18:40 »
Ciao a tutti. Ho installato Mambo su 4 domini presi con TOP-HOST. Premesso che sono molto contento del servizio in generale, devo però capire se i problemi che riscontro sono a causa mia, dei moduli, o di ******.

Ho installato i seguenti moduli:

ZoomGallery 2.5 fix3
(la versione aggiornata presa da questo forum)

RSGallery2

Hot or Not

Galleria 1.0

Con TUTTI ho problemi nella visualizzazione delle thumbnails... e credo che dipenda dal chmod.

Un esempio:

Installare il modulo RSgallery2... da subito un errore in installazione:

Warning! Created directory /home/mhd-03/www.tourvirtuali.com/htdocs/images/gallery, but could not set the correct permissions of '777'. Permissions are currently set at: 40751. Please rectify this if deemed necessary before using RSGallery.

Warning! Created directory /home/mhd-03/www.tourvirtuali.com/htdocs/images/gallery/thumbs, but could not set the correct permissions of '777'. Permissions are currently set at: 40751. Please rectify this if deemed necessary before using RSGallery.

il chmod della cartella segnalata non é 0777 come dovrebbe essere... tramite il programma WS_FT Ppro provo a impostare il chmod corretto ma senza successo... boh? ... non faccio altro poiché non vorrei incasinare nulla...

Qualcuno sa se c'é un qualcosa in comune con tutti questi moduli da impostare che mi sfugge?

Offline dariolx

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #1 il: 19 Ago 2005, 14:03:38 »
Anche io ho avuto gli stessi problemi con la versione zoommediagallery2.5.2b inglese. In pratica, dopo aver aperto 2 ticket di richiesta chiarimenti con ******, ho risolto da solo modificando il codice php di qualche file...

Riassumo brevemente quello che ho fatto, appena ho tempo pubblico le modifiche al codice di zoom media gallery se interessa a qualcuno.

Tutto il problema è causato dai permessi che non si possono modificare con l'FTP. Da codice php è invece possibile modificare il tutto senza problemi. Ho quindi impostato i permessi delle cartelle a 0777 e quelli delle immagini a 0644 durante la fase di creazione, visto che in questa configurazione mi funziona tutto.

Lo zoom media gallery originale impostava automaticamente i file immagine a 0640, impedendo quindi la visualizzazione al resto del mondo.

Se interessa pubblico i file modificati, però non ho avuto tempo di fare un lavoro serio, in quanto il mio fine era far funzionare il tutto in maniera decente nel minor tempo possibile.

Offline realtour

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #2 il: 19 Ago 2005, 16:06:53 »
Grazie per la risposta dario  :)

Se hai il modo di far funzionare la zoom gallery ben venga !!!! Io ho un ticket aperto kilometrico e ancora non se ne vede l'uscita...

Quindi se hai la soluzione é ben venuta   :D

Ciao e grazie ancora per la risposta.

Offline dariolx

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #3 il: 19 Ago 2005, 17:46:41 »
Allora, ti allego solo il file che ho modificato, dovrebbe funzionare tutto. In pratica ho aggiunto una riga che imposta i permessi delle thumbnails a 0644, cosi si possono visualizzare anche via http.

Il file è sotto com_zoom/classes, ovviamente prima ti consiglio di fare un backup. Se non funziona ti allego tutto.

Da adesso le nuove immagini che inserirai dovrebbero vedersi bene anche in miniatura. Per quelle vecchie bisognerebbe cambiare i diritti da php...

[allegato eliminato dall\'amministratore]

Offline realtour

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #4 il: 20 Ago 2005, 00:53:54 »
Grazie Dario, ho sostituito il file e... sembra funzionare correttamente !!!!

Sono molto felice... é già un 1° passo avanti !!! pensa che ho problemi con tutti i moduli che gestiscono immagini e nonostante non sia un programmatore sono convinto che dipenda dal CHMOD...

L'ho detto a ****** .... sembra che decidano di dare la possibilità di cambiare il CHMOD via FTP

Però é incredibile... penso che a ****** abbiano avuto lo stesso problema con tanti altri clienti... ZoomGallery é utilizzata anche dall'area demo di mamboserver.it.....  eppure non sono stati loro a risolvere la cosa (grande Dario !!!  :D)... 

Che siano tutti in ferie? in azienda da me, che forniamo servizi 24/24 c'é sempre qualcuno in grado di risolvere le cose... anche in agosto...   mah...

Comunque grazie ancora !!!

Offline dariolx

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #5 il: 20 Ago 2005, 13:27:07 »
Sono contento che funzioni tutto! Merito anche dell'opensource.

Comunque spero che i ragazzi di ****** diano la possibilità di modificare il CHMOD, oppure che forniscano un servizio di esplorazione risorse che non si basi su librerie FTP ma sulle funzioni PHP per i file, dato che queste funzionano benissimo.

Per gli altri componenti o moduli penso che tu abbia ragione con il discorso CHMOD, basterebbe modificarlo al momento della creazione del file. Se un giorno li installo e li modifico ti faccio un fischio.
Saluti!
Dario

PS: che servizi fornite?

Offline realtour

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #6 il: 20 Ago 2005, 22:52:07 »
Servizi Web orientati per il turismo... quindi in questi giorni si lavora... come del resto tutto l'anno...

E tu? che fai di bello?

Offline dariolx

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #7 il: 21 Ago 2005, 20:24:40 »
Studio ingegneria delle telecomunicazioni e faccio siti internet per diletto

Offline Chiantese

  • Esploratore
  • **
  • Post: 57
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #8 il: 29 Ago 2005, 20:59:58 »
Carissimi...aiutate anche me?
Io ho installato la versione aggiornata presa da mamboserver.it in italiano di zoom ....ho provato anche a cambiare il file che allegavi...ma niente.
Solito errore...
quandov ado a creare una nuova galleria mi dice che c'è un errore e non è possibile creare nuove gallerie.
Credo che sia un problema di accesso...

cosa fare?
hai per caso zoom aggiornato con le tue correzioni?
Per verificare....

si si...sono su un sito ospite in ****** (teatrourgente.it)

Fatemi sapere al più presto!!!

Offline realtour

  • Nuovo arrivato
  • *
  • Post: 22
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #9 il: 30 Ago 2005, 22:49:23 »
****** ignora i TICKET ... VERGOGNA !!!!

 >:( >:( >:( >:( >:(

Offline dariolx

  • Nuovo arrivato
  • *
  • Post: 6
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #10 il: 01 Set 2005, 14:02:01 »
Uhm... A me le cartelle le fa creare senza problemi. Il file che modificato è solo quello, e solo per quanto riguarda le thumbs.
Guarda che permessi ha la cartella /zoom dove vai a mettere i file. Hai attivo il safemode?

Offline lillop

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo
Re: TOP HOST - Problemi con le Immagini
« Risposta #11 il: 04 Set 2005, 11:50:50 »
Salve aiutatemi vi pregoooo

Quando ho aggiunto il componente zoom, mi ha dato questo problema:
zOOm Installation is trying to create the Images-directory "images/zoom" ... failed!

Io ho scompattato il zip di zoom aggiunto il file da dario (SEI GRANDE) ricompattato e uppato sul server.
Sono entrato poi nel sefmode ma mi dice qual'è il nome del server ftp mica lo devo inserire?


AIUTATEMI PLS

 

Host

Torna su