Autore Topic: Comportamento anomalo del Modulo Articoli Recenti  (Letto 803 volte)

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Comportamento anomalo del Modulo Articoli Recenti
« il: 06 Lug 2020, 13:02:29 »
Buongiorno.
Curo 2 siti di recensioni di ristoranti e hotel, in entrambi c'è un menu che elenca le ultime prove.

Il tipo di menu è: Articoli>Singolo Articolo  -  Nel singolo articolo con {loadposition ultimeprove} viene caricato il modulo "Articoli Recenti" che elenca automaticamente le ultime prove in ordine cronologico.

E fin qui tutto bene.
Siccome desidero che le ultime prove siano subito sott'occhio anche in Home Page, ho creato un secondo articolo che contiene {loadposition ultimeprove} e l'ho assegnato alla visualizzazione Blog Articoli in Evidenza in Home Page.
Perché non ho spuntato "Articoli in evidenza" direttamente nel primo articolo? Perché i 2 articoli hanno anche ulteriori contenuti, e avevo necessità che quello mostrato in Home Page fosse più snello.

Ora vengo al problema: le ultime prove sotto menu sono sempre aggiornate, quelle in Home Page no.
Per aggiornare la Home occorre svuotare la cronologia del Browser, ma è ovvio che non ho nessun controllo sul fatto che l'utente finale lo faccia, e anzi sono certo che non lo farà.

Da mesi provo ogni sorta di manipolazione della cache (i 2 siti sono entrambi impostati su no-cache, ma sono presenti a livello server sia Cloudflare sia Supercacher dell'hosting Siteground) senza nessun risultato: il mistero rimane.

In pratica parliamo di 2 articoli molto simili o quasi identici, che contengono lo stesso identico modulo, che però si comporta in maniera differente nelle 2 location, facendo egregiamente il suo lavoro nel primo caso e impiantandosi nel secondo caso...

Qualcuno sa darmi una suggestione o una traccia su cui lavorare?
« Ultima modifica: 06 Lug 2020, 13:09:06 da sgiobbio »

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #1 il: 12 Lug 2020, 11:43:06 »
Vedo che in tanti hanno letto ma nessuno ha risposto. A nessuno succede come a me di non riuscire a visualizzare contenuti aggiornati in Home Page?

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #2 il: 12 Lug 2020, 11:54:03 »
Buongiorno, hai fatto una ricerca nel forum? Senza andare troppo lontano, se scrolli la prima pagina di questa sezione credo tu possa trovare una discussione interessante in merito...  ;)
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

Online giusebos

  • Fuori controllo
  • *
  • Post: 20399
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #3 il: 12 Lug 2020, 14:40:46 »
scusa sgobbio, magari parlo solo per me, ma io non ho capito nulla del tuo problema.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31268
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #4 il: 12 Lug 2020, 15:48:31 »
È lo stesso problema di un precedente post in salsa diversa.

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #5 il: 12 Lug 2020, 16:21:22 »
Scusate Giusebos e tomtomeight, forse questa stranezza succede solo a me, forse sono troppo prolisso nel descriverla...
Riformulo:
Home Page mostra gli ultimi 4 articoli pubblicati:

 Rosso
 Verde
 Giallo
 Blu

Quando pubblico il nuovo articolo Marrone, mi aspetto di vedere così:

 Marrone
 Rosso
 Verde
 Giallo

Invece continuo a vedere così:
 
 Rosso
 Verde
 Giallo
 Blu

Di Marrone non c'è traccia.

Il modulo che mostra gli ultimi articoli pubblicati è: "Articoli Recenti" ed è visualizzato sia in Home page sia in un'altra pagina.
Per richiamarlo utilizzo in entrambi i casi loadposition, e il modulo è sempre lo stesso.

Nell'altra pagina si aggiorna, quindi vedo "Marrone".
In Home Page non si aggiorna, "Marrone" non c'è.

La Home Page è la visualizzazione Blog di alcuni articoli, tra cui c'è quello che non si aggiorna.
Come faccio a farlo aggiornare?
Se è un problema di cache, come si fa a impedire che determinati articoli vadano in cache?
« Ultima modifica: 12 Lug 2020, 16:28:00 da sgiobbio »

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #6 il: 12 Lug 2020, 17:32:20 »
Hai già testato se può esserti di aiuto questa estensione?
https://extensions.joomla.org/extension/cachecontrol/
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

Online giusebos

  • Fuori controllo
  • *
  • Post: 20399
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #7 il: 12 Lug 2020, 19:10:52 »
Hai già testato se può esserti di aiuto questa estensione?
https://extensions.joomla.org/extension/cachecontrol/

questi sono i suggerimenti che confondono ancora di più e non aiutano.
L'utente sente rumore di zoccoli, pensa ad un cavallo e tu ti precipiti ad indicargli il maniscalco.

Se vuoi aiutare, chiedi un link, indica di sostituire la home con la pagina che funziona, chiedi perchè usa loadposition anzichè usare la vista blog, chiedi che impostazioni ha la vista blog, se usa gli articoli in evidenza, di una o più categorie.

Purtroppo non siamo dentro il sito, perchè se io lo fossi avrei già risolto, andando a verificare tutte le impostazioni delle categorie, degli articoli e delle voci di menù.

Purtroppo bisogna lavorare di ipotesi per fare una corretta diagnosi , ipotesi che si formulano in base agli elementi riferiti da chi chiede aiuto, che se sono pochi, risolvere diventa un terno all'otto. Quindi caro barone, se vuoi aiutare, inizia ad insegnare o istruire gli utenti come chiedere aiuto, perchè è sempre stato questa la grossa PROBLEMATICA del forum.

CHI SA CHIEDERE AIUTO SI SALVA SEMPRE.

Sparare risposte inutili come la tua serve solo ad allungare il brodo

su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline baronepiovasco

  • Appassionato
  • ***
  • Post: 389
  • Sesso: Maschio
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #8 il: 12 Lug 2020, 19:54:01 »
Ho proposto non imposto, per quel che leggo l'utente sgiobbio non mi sembra proprio un neofita e credo sia in grado di capire se un'estensione possa fare al caso suo o no.

Mi piacerebbe avere certezze monolitiche ma vivo nel dubbio, quindi partecipo civilmente ad una discussione proponendo la mia opinione.

Se sgiobbio avrà la gentilezza di raccogliere il mio suggerimento magari potrà pronunciarsi in merito, si cresce così, confrontandosi.
Non ci si può mettere a far qualcosa senza che qualcos'altro non vada fatto prima. :-)

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31268
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #9 il: 12 Lug 2020, 19:56:25 »
Perché non aggiungi il loadposition direttamente nel primo articolo in home invece di creare un secondo articolo col solo il loadposition?

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #10 il: 12 Lug 2020, 20:02:16 »
Grazie Giusebos. Da quello che hai scritto temo che ci sia un equivoco, non è la home (in visualizzazione blog) a non essere aggiornata.
Quello che non si aggiorna è uno dei 5 articoli in evidenza mostrati in home.
Questo articolo deve mostrare un Elenco Testuale delle ultime prove: per farlo, contiene loadposition, cioè il modulo "Articoli Recenti" mostrati per Titolo in ordine cronologico.

Come in tutti i siti, anche nel mio c'è un menu, e una delle voci di menu è "Le Ultime Prove": anche qui mostro un articolo che contiene loadposition > Articoli Recenti. Questo si aggiorna senza problemi ogni volta che pubblico un articolo nuovo.

Perché l'articolo in Home Page non mostra anche lui le prove aggiornate? Eppure loadposition > modulo "articoli recenti" è lo stesso identico!

Per vedere in home l'elenco aggiornato devo svuotare la cache del MIO browser. Come posso pensare che lo faccia anche il visitatore?
Se ti va di darci un'occhiata il sito è www.convivium.club. Ma come faccio a riprodurti il problema? Dovrei pubblicare un articolo nuovo di prova e avvertirti che c'è...

Un'ultima cosa, probabilmente mi dirai: "Prova a mettere fra gli articoli in evidenza in Home quello che funziona": ma i due articoli sono in parte differenti, entrambi contengono loadposition con il modulo articoli recenti, ma quello per l'home page è più conciso, studiato proprio per l'home page...

PS, grazie anche a baronepiovasco, apprezzo il suggerimento ma se potessi evitare di aggiungere estensioni preferirei.

Mentre scrivevo ha scritto anche tomtomeight: per l'appunto non metto in home l'articolo che funziona perché abbonda di ulteriori contenuti non necessari alla Home
« Ultima modifica: 12 Lug 2020, 20:06:43 da sgiobbio »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31268
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #11 il: 12 Lug 2020, 20:44:06 »
Non dicebo di mettere lo stesdo articolo in home ma di inserire il loadposition nell'articolo principale della home e non di creare un secondo articolo col solo loadposition sempre on home.

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #12 il: 12 Lug 2020, 21:39:35 »
tomtomeight
ma il loadposition è in un articolo principale della Home.
Esattamente nel secondo articolo: il primo è una presentazione, il secondo è l'elenco delle ultime prove.
Il loadposition nella home (o meglio, il modulo articoli recenti da questo richiamato) non si aggiorna quando c'è un articolo recente nuovo.
Il loadposition non in home (lo stesso identico loadposition con lo stesso identico modulo) si aggiorna ad ogni articolo nuovo.
Io ho il sospetto che l'intera Home Page venga cachata dal browser stesso, ma perché solo la home e non una pagina normale?
E se così fosse, come diavolo potrei fare per non farla cachare?
Tieni conto che ho già inserito le "eccezioni no-cache" per index.php sia in Cloudflare sia in SGCache di Siteground che è il mio hosting.

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31268
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #13 il: 13 Lug 2020, 00:47:50 »
Io proverri con un unico articplo richiamato una volta come singolo r in home da categoria specifica.

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #14 il: 13 Lug 2020, 12:36:24 »
Scusa tomtomeight ma non ho capito.
L'articolo attualmente in home (quello che contiene attraverso loadposition il modulo "articoli recenti" che non si aggiorna con gli articoli nuovi se non dopo avere svuotato la cache del Browser) è un articolo singolo settato "in evidenza" e appartiene a una categoria specifica.
Gli articoli mostrati in Home Page sono gli articoli in evidenza di tutte le categorie.

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31268
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #15 il: 13 Lug 2020, 14:08:49 »
Puoi richiamare in home lo stesso articolo che hai nella altra voce menù.

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #16 il: 13 Lug 2020, 15:10:39 »
tomtomeight OK, posso provare...
Però lo stesso problema mi capita su un secondo sito, che ha la medesima struttura.
Anche lì, modulo articoli recenti inserito in un articolo sotto menu funziona correttamente, inserito in un articolo in evidenza in home page non mostra più l'ultimo articolo pubblicato.
Ma non sarà che il modulo articoli recenti, se inserito in un articolo in evidenza, entra a far parte di una qualche cache?

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #17 il: 21 Lug 2020, 11:40:23 »
Dopo altri giorni di inutili prove, credo di avere appurato che l'intera home page - fatta di 5 articoli in evidenza - è sottoposta a cache su cui non riesco ad avere alcun controllo.

Il modulo che mostra titolo e link degli ultimi 12 articoli pubblicati, in home page non si aggiorna se sopravviene un articolo nuovo.

L'aggiornamento avviene soltanto se svuoto la cache del mio browser: ho provato con tutti i browser (Chrome, Firefox, Edge, Safari, Opera, Maxthon).

Siccome non  posso "istruire" il browser dei lettori a svuotare la cache, non so proprio più che cosa fare.

Questo problema, secondo me non è un problema da poco: è come se in un notiziario on line non fosse possibile mostrare una Ultima Ora aggiornata.
« Ultima modifica: 21 Lug 2020, 11:46:50 da sgiobbio »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31268
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #18 il: 21 Lug 2020, 15:56:45 »
Credo sia solo un tuo problema, a me non succede, vediamo se è capitato ad altri.

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #19 il: 03 Ago 2020, 15:00:47 »
Giusto per aggiornamento, ho fatto altre prove, anche con un secondo Sito, e ho appurato che:

- nessun articolo in evidenza in home page si aggiorna con qualsiasi modifica apportata
- per vedere le modifiche non basta il refresh ma bisogna svuotare la cache del browser

Per risolvere il problema degli ultimi articoli pubblicati, al posto del modulo Articoli Recenti sono stato costretto a inserire un pulsante con il link alla pagina interna (funzionante) che li mostra.

L'intera Home Page in Cache - e l'impossibilità di impostare un NO-CACHE - è una assurdità di cui non mi capacito.
Se a qualcuno dovesse venire in mente qualche possibile soluzione, gli sarò grato.
 

Offline renzo973

  • Appassionato
  • ***
  • Post: 294
  • Sesso: Maschio
  • Cogito ergo sum !!!
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #20 il: 06 Set 2020, 07:28:47 »
io mi son letto tutta la discussione, ma ho fatto una "discreta fatica" a capire ... magari dico una stupidaggine, ma proverei a vedere pure i settaggi delle opzioni dei contenuti in generale e le opzioni di visualizzazione della home page.
« Ultima modifica: 06 Set 2020, 07:53:37 da renzo973 »
Dicono che dio ci ha fatti tutti uguali, ma poi, appena fuori dall'utero, ha iniziato coi favoritismi

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #21 il: 11 Set 2020, 16:00:11 »
ringrazio renzo973 per il contributo, fa sempre piacere trovare chi si ingegna per aiutare.

Purtroppo nei settaggi delle opzioni dei contenuti in generale non mi sembra che ci sia nessuna opzione che riguardi la cache.
Idem nelle opzioni per "articoli in evidenza"

Offline renzo973

  • Appassionato
  • ***
  • Post: 294
  • Sesso: Maschio
  • Cogito ergo sum !!!
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #22 il: 12 Set 2020, 08:14:12 »
la mia era un' idea, perchè magari settando in maniera diversa le opzioni degli articoli e quelli della home in evidenza, Joomla! andava in crisi.
La cache in Configurazione globale -> Sistema come è setttata? Io normalmente la lascio come la configura Joomla! al termine dell' installazione

Dicono che dio ci ha fatti tutti uguali, ma poi, appena fuori dall'utero, ha iniziato coi favoritismi

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #23 il: 12 Set 2020, 13:12:39 »
renzo973
La cache in Configurazione globale -> Sistema è settata su "NO - Cache disabilitata".
Esattamente come nel tuo screenshot...

Ho letto che hai avuto difficoltà a capire la spiegazione del problema.
Fai una prova: nella home page del sito in oggetto (www.convivium.club) sotto al titolo "Convivium, reportage fotografici di cucine eccellenti" ci sono 4 immagini, che dovrebbero cambiare ad ogni refresh perchè derivano da moduli "immagine casuale".
Vedi se cambiano facendo un refresh. A me cambiano soltanto se svuoto la cache del mio browser...

Questo succede soltanto in Home Page.
Per questo motivo, per quanto riguarda l'elenco delle "Ultime Prove" (modulo articoli recenti), ci ho rinunciato, trasferendolo in una pagina interna.
« Ultima modifica: 12 Set 2020, 13:18:21 da sgiobbio »

Offline renzo973

  • Appassionato
  • ***
  • Post: 294
  • Sesso: Maschio
  • Cogito ergo sum !!!
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #24 il: 14 Set 2020, 08:36:48 »
Nonostante abbia usato browser diversi e anche computer diversi, le 4 immagini sono sempre le stesse (vedo che sono in due cartelle diverse). Prova a far pescare le immagini da un' unica cartella
Dicono che dio ci ha fatti tutti uguali, ma poi, appena fuori dall'utero, ha iniziato coi favoritismi

Offline sgiobbio

  • Esploratore
  • **
  • Post: 191
    • Mostra profilo
Re:Comportamento anomalo del Modulo Articoli Recenti
« Risposta #25 il: 14 Set 2020, 18:00:14 »
renzo973
Non cambierebbe nulla anche se le immagini casuali fossero pescate da una sola cartella. Ho fatto anche questa prova...

Come hai potuto appurare anche tu, c'è qualcosa che impedisce che cambino: evidentemente è Cache!

La stessa identica cosa succedeva con l'elenco delle ultime prove, che derivava dal modulo "articoli recenti": rimanevano sempre le stesse, e non si aggiornavano mai, a meno di svuotare la cache del browser! Per questo ho dovuto spostare quell'elenco in una pagina interna, perché questa cosa succede soltanto in Home Page.

Visto che è sicuramente un problema di Cache, le ho provate tutte, ma proprio tutte: sono intervenuto su .htaccess, ho disabilitato tutto quello che si poteva disabilitare anche da cPanel (cache di Siteground, che è il mio hosting provider, e cache di CloudFlare che fa parte del pacchetto di Siteground), ma la Cache della Home Page è diventata una sorta di Maledizione che non si può sconfiggere.

Per la cronaca, il medesimo sito in locale che gira su WampServer non da alcun problema e la sua Home Page si aggiorna ad ogni refresh.

 

Host

Torna su