Autore Topic: Problemi nella migrazione da 3.10 a 4.7  (Letto 381 volte)

Offline Massimo Rossi

  • Esploratore
  • **
  • Post: 61
    • Mostra profilo
Problemi nella migrazione da 3.10 a 4.7
« il: 27 Feb 2021, 17:18:42 »
Buonasera a tutti, sto cercando di effettuare in locale la migrazione del mio sito dall'attuale versione stabile alla versione 4.6.
I passaggi mi sembrano piuttosto semplici, aggiorno alla 3.10, verifico il sito ed tutto a posto; successivamente aggiorno alla 4.6, e mi restituisce un errore 500, di cui allego una schermata (non amo il termine screenshot). Provo e riprovo, ma sempre la stessa cosa.
Xamp aggiornato all'ultima versione.
Ho giusto un plugin non compatibile, advanced module manager, non voglio credere che possa essere quello il problema, e il template che Helix 3 ultimate.
Qualcuno ha qualche idea in proposito, ormai sono gi a una ventina di tentativi.


Grazie mille.
« Ultima modifica: 27 Feb 2021, 19:03:29 da Massimo Rossi »
Tempio Zen Ten Shin  www.tenshin.it

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 31508
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.6
« Risposta #1 il: 27 Feb 2021, 18:27:34 »
Non mi pare che sia possibile fare la migrazione direttamente dalla 3.9.x credo che bisogner prima aspettare una versione 3.10.x

Offline Massimo Rossi

  • Esploratore
  • **
  • Post: 61
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.6
« Risposta #2 il: 27 Feb 2021, 18:36:24 »

Prima di installare la 4.7 (ho sbagliato nel post precedente), ho installato la 3.10 Alpha4, poi direttamente la 4.7.Sono io che ho compreso male quello che c' scritto sul sito di joomla.it?
Ti posto il link.
https://www.joomla.it/notizie/9071-joomla-4-beta-6-e-joomla-3-10-alpha-4-sono-disponibili-testale-subito.html


Oppure devo fare l'upgrade alla 4, e poi successivamente alla 4.7?
Dall'articolo non si comprende tanto.


Intanto sto provando a ripartire da zero con la 4.7 pulita, ma un dramma rifare tutto il sito da capo.


Grazie.
Tempio Zen Ten Shin  www.tenshin.it

Offline Limma

  • Abituale
  • ****
  • Post: 1161
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.6
« Risposta #3 il: 27 Feb 2021, 18:50:53 »
Buonasera a tutti, sto cercando di effettuare in locale la migrazione del mio sito dall'attuale versione stabile alla versione 4.6.
Qui mi sono perso... Intendi Joomla 4 Beta 6? (Anche se ora disponinbile la Beta 7).
Ho giusto un plugin non compatibile, advanced module manager, non voglio credere che possa essere quello il problema, e il template che Helix 3 ultimate.
Giusto per la precisione, non esiste un Helix 3 Ultimate, ma solo Helix Ultimate.
In ogni caso Helix Ultimate (all'ultima release 1.1.2) non compatibile con Joomla 4.
La versione compatibile con Joomla 4 la 2.0, attualmente all'Alpha 5 e quindi assolutamente da utilizzare solo per test.

Offline Massimo Rossi

  • Esploratore
  • **
  • Post: 61
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.6
« Risposta #4 il: 27 Feb 2021, 18:58:29 »
Si, Limma, ho sbagliato e ho specificato nel post successivo che intendevo la 4.7.
Per Helix, avrei installato la 2.0 alpha 5, gi scaricata.


Grazie.


Il problema resta sempre l'errore.
Tempio Zen Ten Shin  www.tenshin.it

Offline Limma

  • Abituale
  • ****
  • Post: 1161
  • Sesso: Maschio
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.7
« Risposta #5 il: 27 Feb 2021, 19:18:23 »
..Ho di recente fatto un'installazione di prova con Joomla 4 Beta 7 e Helix Ultimate 2.0 Alpha 5 e tutto funziona, naturalmente a parte qualche bug di qua e di l...
Non ho quindi tentato l'aggiornamento di un sito, e me ne guardo bene finch non si arriva alle versioni stabili.
N Joomla 4, n tantomeno HU sono pronti per siti di produzione.

Offline Massimo Rossi

  • Esploratore
  • **
  • Post: 61
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.7
« Risposta #6 il: 27 Feb 2021, 19:31:09 »
Eppure dall'articolo su Joomla.it pare si possa fare.
Tempio Zen Ten Shin  www.tenshin.it

Offline renzo973

  • Appassionato
  • ***
  • Post: 330
  • Sesso: Maschio
  • Cogito ergo sum !!!
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.7
« Risposta #7 il: 28 Feb 2021, 08:10:45 »
mettendo Cassiopea come template predefinito hai sempre l'errore?
Dicono che dio ci ha fatti tutti uguali, ma poi, appena fuori dall'utero, ha iniziato coi favoritismi

Offline Massimo Rossi

  • Esploratore
  • **
  • Post: 61
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.7
« Risposta #8 il: 28 Feb 2021, 16:21:54 »
Si, sempre l'errore.
Anzi nel frattempo cambiato. Me ne d uno nuovo, forse si stufato del vecchio dati i miei molteplici tentativi.


Nel frattempo, ho fatto un'installazione pulita di J4.7 e sto cercando di verificare cosa accade se passo tutti i dati tramite db, installando gli stessi componenti, moduli, ecc.

Tempio Zen Ten Shin  www.tenshin.it

Offline sgiobbio

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.7
« Risposta #9 il: 06 Mar 2021, 19:12:59 »
a me non sembra che joomla 4 beta abbia grossi bug, almeno io non ne ho riscontrati.
Ho testato pi volte la "migrazione" passando da 3.10 alfa, e il database risultante corretto.
Ovviamente non ci sono ancora componenti aggiuntivi pronti per la 4, ma alcuni "compatibili 3" funzionano egregiamente anche sulla 4, come per esempio PDF embed e google_maps plugin.
Anche per quanto riguarda i Template, meglio affidarsi esclusivamente a Cassiopeia, che comunque ottimo.
Il mio sito joomla3 (multilingua) gi pronto anche su joomla 4 e gira perfettamente.
« Ultima modifica: 07 Mar 2021, 14:37:52 da sgiobbio »

Offline giusebos

  • Fuori controllo
  • *
  • Post: 20675
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Problemi nella migrazione da 3.10 a 4.7
« Risposta #10 il: 06 Mar 2021, 23:47:46 »
joomla 4 ha piccoli bug, niente di strutturale,
ma se si pretende di aggiornare una vecchia versione con varie estensioni e template e versioni di php e versioni di mysql......

si puo fare ma devi essere un attimino aggiornato su tutto quello che che successo dall'antica versione alla versione beta, altrimenti sono solo tentativi tipo roulette russa.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

 

Host

Torna su