Autore Topic: Il modulo contatti non invia più la mail  (Letto 604 volte)

Offline infermieriattivi

  • Appassionato
  • ***
  • Post: 283
  • Sesso: Maschio
    • Mostra profilo
Il modulo contatti non invia più la mail
« il: 19 Apr 2022, 17:09:19 »
Salve
Il componente contatti consente di attivare un modulo con un form per l'invio della mail.
Purtroppo perde l'oggetto e il messaggio.
Quella che mi arriva nella mail è:
Questa è una mail di contatto dal sito %s inviata da:
Non so come fare

Offline mcom

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Re:Il modulo contatti non invia più la mail
« Risposta #1 il: 13 Set 2022, 00:03:27 »

Ciao Infermieriattivi

anche a me il modulo contatti non invia più email dal sito web; il test di invio invece funziona correttamente e l'email del test arriva.


Come hai risolto il problema ?


Grazie


Mauro

Offline mcom

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Re:Il modulo contatti non invia più la mail
« Risposta #2 il: 13 Set 2022, 23:16:49 »

Ho risolto il problema è causato da LiteSpeed Cache Plugin ... quando lo disabilito tutto funziona correttamente (modulo di contatto sia in italiano che in inglese).
L'ho risolto verificando la differenza tra il sito live joomla 4.2.2 e un sito locale joomla 4.1.5 (una versione precedente del sito che funzionava - lì non ho installato LiteSpeed Cache Plugin).


Ora devo capire come LiteSpeed Cache Plugin potrebbe funzionare correttamente con Joomla Contacts senza bloccarmi il tutto.


Se qualcuno ha suggerimenti gliene sono grato.

Offline marine

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 6151
  • Sesso: Maschio
    • Mostra profilo
Re:Il modulo contatti non invia più la mail
« Risposta #3 il: 14 Set 2022, 09:15:18 »
Solitamente i plugin di cache hanno nelle impostazioni la possibilità di escludere delle pagine dall'essere messe in cache.
Nello specifico non conosco LiteSpeed Cache Plugin, prova a vedere nelle impostazioni del plugin se c'è questa possibilità.

Offline marine

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 6151
  • Sesso: Maschio
    • Mostra profilo
Re:Il modulo contatti non invia più la mail
« Risposta #4 il: 14 Set 2022, 09:23:59 »
P.S. @mcom
Solitamente, come da regolamento, in questo forum si risponde ai quesiti aperti da altri utenti per fornire la risposta al quesito dell'utente stesso e non per "accodarsi" avendo un problema che può sembrare simile al suo.
Quando incontri un problema con il tuo sito e vuoi discuterne qui nel forum ti consiglio di aprire sempre un tuo nuovo post.
Aprendo per ogni quesito un nuovo post si hanno maggiori vantaggi, nello specifico:
  • non  "sporchi" la discussione dell'altro utente
  • ottieni solo risposte pertinenti al tuo quesito
  • (forse la più importante) si mantiene il forum ordinato e pulito, un forum ordinato e pulito è più facile nella consultazione e nella ricerca da parte di tutti.
Certo della tua comprensione ti ringrazio per la futura collaborazione.

Offline infermieriattivi

  • Appassionato
  • ***
  • Post: 283
  • Sesso: Maschio
    • Mostra profilo
Re:Il modulo contatti non invia più la mail
« Risposta #5 il: 24 Set 2022, 08:45:57 »
Ciao mcom
Per esperienza quando ho qualcosa che non va in joomla di solito o sono errori di joomla (rarissimi) o ci sono conflitti fra installazioni o in alternativa sono io che pasticcio, il miglior hacker del mio sito sono io.


Adesso mi funziona tutto, anche nel modulo contatti.
Sicuramente gli ultimi aggiornamenti sono stati utili.

Io ho disinstallato admin tool che mi segnalava di non essere certo del funzionamento delle modifiche dell'htaccess.
Quindi ho messo l'htaccess di default di joomla che ha il commento su #Options +FollowSymlinks.


Adesso è da diversi giorni che con litespeed attivo è tutto ok e non ho risorse che toccano il 100%.
Il modulo contatti mi invia la mail benissimo.

(essendo un post vecchio non riesco a mettere [risolto])
« Ultima modifica: 24 Set 2022, 11:26:51 da infermieriattivi »

 

Host

Torna su