Autore Topic: [RISOLTO] PHP 8 o 8.1 da errore, aruba dice che Joomla forse non supporta PHP 8  (Letto 378 volte)

Offline Alistair

  • Appassionato
  • ***
  • Post: 337
    • Mostra profilo
Se passo da PHP 7.4 a PHP 8 o PHP 8.1 ottengo queto errore Autoloader. Niente funziona né backend né frontend, quindi non riesco neanche a far andare il comando fpa-en.php, appena torno a PHP 7.4 tutto va benone. Non ho installato sh404sef. Avete suggerimenti?
Error   An error has occurred. > 0 spl_autoload_unregister(): Argument #1 ($callback) must be a valid callback, function "__autoload" not found or invalid function name
« Ultima modifica: 20 Mag 2022, 16:14:04 da xplosion »

Offline xplosion

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3989
  • Sesso: Maschio
    • Mostra profilo
Joomla supporta PHP 8.0 ed e anche raccomandato, vedi qui Technical Requirements.
L'errore che te lo da potrebbe essere da un componente/plugin incompatibile con la versione 8 di PHP. Puoi disabilitare uno per uno e verificare l'esito.
Gantry 5.5 per Joomla 4 - Documentazione e Guide  in italiano per creare Template Joomla! professionali! www.tanase.it

Offline Alistair

  • Appassionato
  • ***
  • Post: 337
    • Mostra profilo
Si ho capito da come hanno risposto che non sapevano cosa consigliare allora hanno detto che Joomla! non è compatibile, quando non è così.
Un modo più rapido per capire quale componente/plugin/template sia incompatibile non ci sarebbe? Ho chiesto direttamente ai programmatori di alcuni plugin (quelli più vecchi) che ho installato e mi han risposto che sono compatibili, mi sempra strano che quelli incompatibli siano i più recenti. Il problema potrebbe essere dato anche da un template giusto? Ed in quel caso è normale che neanche il back-end funziona se un template è incompatibile?
 

Offline giusebos

  • Fuori controllo
  • *
  • Post: 21235
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
attiva il debug su MAX  e scoprirai quale delle estensioni installate ti crea il problema.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline xplosion

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3989
  • Sesso: Maschio
    • Mostra profilo
Il problema potrebbe essere dato anche da un template giusto? Ed in quel caso è normale che neanche il back-end funziona se un template è incompatibile?
Giusto ! e comunque la prima cosa da fare, come ti ha suggerito giusebos, è di attivare il debug su massimo.
Gantry 5.5 per Joomla 4 - Documentazione e Guide  in italiano per creare Template Joomla! professionali! www.tanase.it

Offline Alistair

  • Appassionato
  • ***
  • Post: 337
    • Mostra profilo
attiva il debug su MAX  e scoprirai quale delle estensioni installate ti crea il problema.
Grazie. Avrei dovuto pernsarci prima, questo piccolo accorgimento mi ha permesso di trovare il colpevole, un plugin AMP che avevo installato e che non ricordavo neanche di avere. C'è stato un momento in cui AMP si pensava fosse il futuro della snellezza di navigazione ma ora mi pare non sia più così..

Offline sgiobbio

  • Appassionato
  • ***
  • Post: 273
    • Mostra profilo
quello che ti è successo mi dà lo spunto per una considerazione: riempirsi di plugin, template e componenti di terze parti non fa che aumentare alla lunga il lavoro, crea intoppi a non finire invece che snellezza e risulta quasi sempre poco utile. Ridurli all'osso se non sono assolutamente indispensabili, joomla funziona benissimo nudo e crudo

Offline Alistair

  • Appassionato
  • ***
  • Post: 337
    • Mostra profilo
Si concordo, sicuramente qualcosa di probabilmente superfluo potrei togliere. Nello specifico riguardo a questo errore diciamo che 3 anni fa avere le pagine AMP sembrava fosse un must e temevo non averle penalizzasse il SEO, la risposta non la so, ma vedo che delle accelerated mobile pages non ne parla più nessuno.

 

Host

Torna su