Autore Topic: Migrazione da Joomla 3.10 - Virtue Mart 3.8.8 a Joomla 4.1.5 - VirtueMart 4.0  (Letto 649 volte)

Offline Massimo Pietropaoli

  • Nuovo arrivato
  • *
  • Post: 19
  • Sesso: Maschio
    • Mostra profilo
Buongiorno a tutti.
Premetto che non sono un esperto di programmazione.
Ho un sito di E-commerce basato su VirtueMart con le versioni che ho scritto nell'oggetto del topic.
Sto provando , approfittando della pausa estiva della mia attività , a migrare , in locale, alle nuove versioni che ho scritto in oggetto. Nel controllo pre-aggiornamento , compaiono alcuni Plugin e template facilmente eliminabili come "potenziale problema di aggiornamento" . Poi , nella sezione delle informazioni sull'aggiornamento non disponibili compaiono molti Plugin di VM.
Infine è consigliato , prima di aggiornare Joomla , di effettuare aggiornamento di VirtueMart e Virtuemart AIO.
Come provo ad aggiornare VM mi da subito errore . Ho provato comunque ad aggiornare Joomla e va tutto liscio .
Naturalmente virtuemart poi non funziona. Mi domando se sia ancora presto per effettuare questa migrazione oppure , in ogni caso , è una operazione talmente complicata da richiedere l'intervento di un esperto?
Attendo se qualcuno vorrà consigliarmi
PS aggiungo che attualmente è in uso un Template (Jf_Krom ) non compatibile con la versione 4 di Joomla

« Ultima modifica: 13 Ago 2022, 12:47:36 da Massimo Pietropaoli »

Offline Babyjoomla

  • Esploratore
  • **
  • Post: 185
  • Nuovo in joomla!
    • Mostra profilo
Ciao, solitamente queste sono migrazioni che hanno bisogno di tempo per essere progettate ed eseguite.


Prova a vedere sul sito di VirtueMart se hanno una versione per Joomla 4 o una guida alla migrazione (come altre estensioni).

]Per il template c0è poco da fare, installando però una nuovo compatibile (es: Hellium, che puoi vedere o Hydrogen di Gantry o uno, anche free basati sul T4 di Joomlart, di cui ci dovrebbe essere almeno uno gratuito) questa parte è facilmente risolvibile (ovviamente dovrai sistemarlo secondo le tue necessità).

Ciao.

Offline giusebos

  • Fuori controllo
  • *
  • Post: 21435
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Sono molti gli aspetti che vanno considerati in una migrazione, e difficilmente non si avranno problemi da risolvere, quindi nessuno ha la risposta magica.
Quello che occorre è una buon background di come lavora joomla unita all'esperienza che si ha con esso.
Pensa che nemmeno un esperto come me ha tanta fortuna da premere un tasto e ritrovarsi un sito avanzato di versione belle che funzionante.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline Massimo Pietropaoli

  • Nuovo arrivato
  • *
  • Post: 19
  • Sesso: Maschio
    • Mostra profilo
Ciao a tutti,
Sto ancora facendo tentativi per migrare a joomla 4 . Ne frattempo ora compare un avviso sulla scadenza a Novembre del supporto a PHP 7. Provando a passare alla versione 8 Virtuemart non funziona più. Ho provato ad installare VM4 sul PHP 8 e questa volta lo installa senza errori ma poi continua a dare problemi dal lato amministratore. Mi chiedo : ma possibile che chi ha creato la nuova versione di VM non abbia previsto questi problemi? E inoltre: è mai possibile che la versione 7 di PHP diventi obsoleta con  Virtue mart 4  ancora così instabile? Avete per caso qualche consiglio da darmi?
Ve ne sarei grato

 

Host

Torna su