Autore Topic: Aggiornamento sito  (Letto 495 volte)

Offline jugy78

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Aggiornamento sito
« il: 14 Ott 2022, 08:11:56 »
Ciao


un mio amico, ha un vecchio sito fatto con Joomla 3.8.6, non più aggiornato ed ora vorrebbe aggiornarlo, il sistema gli consiglia di passare alla 3.10.11, mi ha chiesto consiglio ed io ho preferito chiedere a qualcuno più esperto di me, mi consigliate di aggiornare, versione per versione, o far fare direttamente un unico aggiornamento. Attendo consigli e suggerimenti, grazie.

Offline xplosion

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4022
  • Sesso: Maschio
    • Mostra profilo
Re:Aggiornamento sito
« Risposta #1 il: 14 Ott 2022, 08:39:50 »
Il passaggio da 3.8.x a 3.10.x, in teoria dovrebbe essere indolore.
Il fatto è che successivamente è bene di valutare il passaggio alla 4.2.x. E qui il discorso e diverso.
Se non ha dimestichezza con Joomla ti consiglio di suggerirli un professionista.

Offline jugy78

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Re:Aggiornamento sito
« Risposta #2 il: 14 Ott 2022, 08:45:29 »
la nostra intenzione era di scaricare di volta in volta il singolo pacchetto, per passare alla versione successiva, il dubbio è quale pacchetto prendere per passare dalla 3.8.x alla 3.9, e successivamente dalla 3.9 alla 3.10.
Per quanto riguarda il passaggio alla 4.2 vedremo più avanti, attualmente sul sito è impostata la versione php 7.4 quale versione dovrei abilitare l'ultima versione del 3.10 in modo che non mi dia problemi. Ciao e grazie ancora

Offline marine

  • Moderator
  • Instancabile
  • *****
  • Post: 6165
  • Sesso: Maschio
    • Mostra profilo
Re:Aggiornamento sito
« Risposta #3 il: 14 Ott 2022, 10:10:42 »
la nostra intenzione era di scaricare di volta in volta il singolo pacchetto, per passare alla versione successiva
Come detto prima puoi passare direttamente da 3.8 a 3.10, fare una versione alla volta allunga i tempi e aumenta la probabilità che qualcosa vada storto

attualmente sul sito è impostata la versione php 7.4 quale versione dovrei abilitare l'ultima versione del 3.10
Puoi mantenere la 7.4, considera che Joomla 3.10 funziona anche con PHP 8.x ma devi verificare la compatibilità con le estensioni che hai installato.

 

Host

Torna su