Back to top

Autore Topic: [RISOLTO] Pacchetto lingua italiana chiede continuamente di essere installato  (Letto 1457 volte)

Offline eliasambo

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo

Salve a tutti,


in locale, dopo aver aggiornato Joomla alla versione 4.2.6, viene evidenziato di aggiornare anche il pacchetto della lingua italiana:


Italian
https://update.joomla.org/language/details4/it-IT_details.xml
versione 4.2.6.1


pur ricevendo il messaggio "pacchetto installato correttamente", se clicco su "Cerca aggiornamenti" ricompare lo stesso pacchetto, come se non fosse stato installato. Provato varie volte ma il risultato non cambia


Grazie per qualsiasi aiuto!
« Ultima modifica: 23 Dic 2022, 12:16:37 da eliasambo »

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 32042
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
Hai pulito cache?

Offline eliasambo

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo
Grazie per la risposta.


Si, cancellata la cache sul sito e anche del browser.
Anche se la voce "_media_version" rimane sempre visibile, anche dopo la cancellazione.

Offline Northwestrekking

  • Esploratore
  • **
  • Post: 78
    • Mostra profilo
Succede anche a me ma con il sito live. La cosa strana è che non viene indicata la versione installata e non indica la data della versione. Ho provato a installare manualmente il pacchetto lingua ma nulla.
Ho pulito cache sito, browser, ho controllato il sito di aggiornamento nulla
Può esserci qualche problema legato al database che non memorizza la versione corrente?
Non so dove andare a correggere il problema

Offline eliasambo

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo

Dallo screen sotto si può vedere che non viene indicata la versione installata.


Se scopri qualcosa in merito o trovi la soluzione ti chiedo la cortesia di avvisarmi   :D

Offline Northwestrekking

  • Esploratore
  • **
  • Post: 78
    • Mostra profilo
Il problema risiede nel fatto che non trova la tabella lingue.
Se vado su installa lingue mi appare questo messaggio:
La tabella di aggiornamento non è aggiornata. Ripristina la tua tabella dei server di aggiornamento
Non so come fare, ho cercato in giro ma non trovo risposte.
Ho provato a reinstallare l'aggiornamento di Joomla ma nulla

Offline eliasambo

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo

Nel mio caso se vado su "lingue installate" appare la lingua italiana ma non viene specificata la versione.
Se vado su "installa lingue" la lingua italiana risulta correttamente installata con specificata la versione 4.2.6.1.


Ciò nonostante su "Aggiornamenti disponibili" il pacchetto lingua 4.2.6.1. risulta sempre da installare. Se lo installo appare il messaggio installazione riuscita. Poi però il sistema ripropone l'installazione dello stesso pacchetto


Non compaiono altri messaggi o allert

Offline Northwestrekking

  • Esploratore
  • **
  • Post: 78
    • Mostra profilo
Credo siano due cause differenti. Vediamo se qualcuno di più esperto ci può consigliare

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 5350
  • "Bastard Inside"
    • Mostra profilo
Ciao, se parlate della versione 4.2.6 penso di aver individuato il problema che si trova nel file xml del pacchetto, non riporta la versione, c'è solo la chiusura del codice version e manca apertura versione e chiusura
versione 4.2.5 corretta
Codice: [Seleziona]
<?xml version="1.0" encoding="UTF-8"?>
<extension type="package" method="upgrade">
    <name>Italian (it-IT) Language Pack</name>
    <packagename>it-IT</packagename>
    <version>4.2.5.1</version>
    <creationDate>Ottobre 2022</creationDate>
    <author>Progetto Joomla!</author>        ...........................
versione 4.2.6 "errata"
Codice: [Seleziona]
<?xml version="1.0" encoding="UTF-8"?>
<extension type="package" method="upgrade">
    <name>Italian (it-IT) Language Pack</name>
    <packagename>it-IT</packagename>
    <version/>
    <creationDate/>
    <author>Progetto Joomla!</author>
    .......................
come potete vedere la parte evidenziata è dove manca la versione. vi allego un pacchetto "corretto" da me provate ad installarlo

Offline eliasambo

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo

Perfetto, ha funzionato! Adesso tutte le estensioni risultano aggiornate. Sull'elenco delle lingue installate non compare la versione ma probabilmente si sistemerà con uno dei prossimi aggiornamenti.


GRAZIE PER L'AIUTO!


Siccome il thread l'ho aperto io, considero il problema risolto e quindi aggiungerò RISOLTO sul titolo. Riguardo l'utente Northwestrekking monitorerò comunque il thread in caso di novità.
« Ultima modifica: 23 Dic 2022, 12:20:36 da eliasambo »

Offline $Red

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 5350
  • "Bastard Inside"
    • Mostra profilo
hanno rilasciato gli aggiornamanti di lingua vers. 3 penso che sia tutto risolto ora, se non lo avete fatto aggiornate buon vigilia a tutti  :)

Offline eliasambo

  • Esploratore
  • **
  • Post: 94
    • Mostra profilo
Perfetto, grazie per averci aggiornato. Buona vigilia anche a te  :)

 



Web Design Bolzano Kreatif