Autore Topic: [RISOLTO] Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli  (Letto 364 volte)

Offline sscarcel

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Buon giorno
Ho problemi nell'apertura articoli passando alla 4.3.0 ed anche alla 4.3.1.
Dal precedente backup ho ripristinato la 4.2.9 e funziona.
Uso EdJCE - 2.9.36  e  Editors-Switcher 4.0.9
e mi sono accorto - su un sito di prova (PHP 8.2.3)- che se disabilito entrambi i plugin e tengo abilitato solo TinyMCE funziona la nuova versione ed invece se li abilito mi da` appunto questi errori:
Abilitando JCE e usando TinyMCE come predefinito mi da`:

Deprecated: Creation of dynamic property JFormFieldMediaJce::$mediatype is deprecated in /membri/sscarcel/j4alt1/libraries/src/Form/FormField.php on line 591
Deprecated Creation of dynamic property JFormFieldMediaJce: $mediatype is deprecated in
........./libraries/src/Form/FormField.php on line 591
(ripetuto 2 volte)
Deprecated: Creation of dynamic property JFormFieldMediaJce::$mediatype is deprecated in /membri/sscarcel/j4alt1/libraries/src/Form/FormField.php on line 591 - ripetuto 2 volte
Se abilito anche Editors-Switcher Mi da`:
Si e` verificato un errore
0 Call to a member Function get() on a string

Ci sono problemi con l'Edito JCE ?
Grazie in anticipo per qualche chiarimento/consiglio.
Salvatore
« Ultima modifica: 11 Mag 2023, 15:56:43 da sscarcel »

Offline mariarosaria

  • Appassionato
  • ***
  • Post: 445
  • Sesso: Femmina
  • Comincio a capire...
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #1 il: 05 Mag 2023, 20:28:09 »
Non sono esperta, ma se guardi i requisiti viene raccomandato php 8.0.
Prova a scalare di versione php. Io ho aggiornato e non ho problemi con 8.0 e jce

Offline gioso

  • Appassionato
  • ***
  • Post: 246
  • Sesso: Maschio
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #2 il: 05 Mag 2023, 20:38:18 »
Concordo con mariarosaria, come da discussione su altro post di questo forum. anche vero che sul mio sito uso la stessa versione di JCE con PHP 8.2 senza avere lo stesso problema, ma potrebbero essere in gioco altre variabili...

Offline sscarcel

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #3 il: 06 Mag 2023, 16:51:36 »
Per ora utilizzo il sito di prova che e` su un server diverso da quello ufficiale e ho scalato PhP alla versione precedente cioe` dalla 8.2 alla 8. (8.026 in informazioni di sistema -> info PhP) ed e` OK se scelgo JCE come editor predefinito. Il problema rimane (Call to a member function......) se come predefinito scelgo Switch-Editors. Questo mi era molto utile se aperto l'articolo voglio passare velocemente da JCE a CODEMIRROR e quindi salvare l'articolo in formato html.
Il sito ufficiale e` su un server diverso (PhP 8.0 - 8.024 in info,,,) e dato che e` pubblicizzato un evento importante per domani, faro` delle prove da lunedi`.
Il problema per me` e` per ora sospeso.
Grazie
« Ultima modifica: 06 Mag 2023, 16:59:05 da sscarcel »

Offline sscarcel

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #4 il: 08 Mag 2023, 16:26:59 »
Ho verificato sul server ufficiale (unica versione con PhP 8.0 e` la 8.1.11). Ed e` il plugin Editors Switcher che da` l'errore di cui sopra.
Nella verifica aggiornamenti mi avverte che e` uno dei plugin su cui Joomla non puo` fare verifiche. Quindi per ora usero` JCE e se voglio l'html vado nell'articolo editato su "Codice".
Ciao.




Offline mariarosaria

  • Appassionato
  • ***
  • Post: 445
  • Sesso: Femmina
  • Comincio a capire...
    • Mostra profilo
Re:[RISOLTO] Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #5 il: 08 Mag 2023, 19:01:59 »
Premetto che non capisco questa frase
Citazione
Ho verificato sul server ufficiale (unica versione con PhP 8.0 e` la 8.1.11)

ma comunque, giusto per completezza se qualcun altro legge questa discussione, io ho joomla 4.3.1, editor switcher appena installato con l'ultima versione (4.3.0) e php 8.0 e funziona tutto alla perfezione.
Quindi a mio parere non possiamo generalizzare dicendo che il problema sia editor switcher.

Offline sscarcel

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:[RISOLTO] Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #6 il: 09 Mag 2023, 18:30:13 »
mariarosaria - mi spiego.
Sul server  c'e` una lista di versioni che si possono scegliere come current. Le ultime 3 sono: 7.4,8.0,8.1.
La 7.4 e` deprecated. Le altre 2 (che come PhP information sono 8.0.24,8.1.11) mi danno errore su Editors-Switcher. Se hai messo come editor predefinito in 'Configurazione Globale' questo editor allora ho qualche altra cosa che non va`. Tra l'altro una volta che si blocca in 'Controllo Globale' devo andare a sbloccare la tabella sbv0_content del database.

Offline giusebos

  • Fuori controllo
  • *
  • Post: 21636
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:[RISOLTO] Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #7 il: 10 Mag 2023, 00:05:38 »
Attiva il debug su errori max e vedi esattamente cosa che genera l'errore.
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline sscarcel

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #8 il: 10 Mag 2023, 16:29:19 »
In Config Globale -> Server -> Rapporto Errori : Massimo e sul server in PHP Options ho spuntato display_errors (prima era default).
se provo ad aprire un articolo (nuovo o gia` esistente) viene:
Si verificato un errore.
0 Call to a member function get() on string
Torna al Pannello di controllo
Ho aggiunto un allegato
« Ultima modifica: 10 Mag 2023, 18:05:58 da sscarcel »

Offline giusebos

  • Fuori controllo
  • *
  • Post: 21636
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #9 il: 11 Mag 2023, 11:49:01 »
prova ad usare la versione 8.1 di php e ricordati di cancellare/disattivare  eventuali cache del sito e anche compressione GZIP
su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

Offline sscarcel

  • Nuovo arrivato
  • *
  • Post: 25
    • Mostra profilo
Re:Da J 4.2.9 a 4.3.0 e/o 4.3.1 errore apertura articoli
« Risposta #10 il: 11 Mag 2023, 15:56:13 »
Mi scuso profondamente - ho risolto il problema disinstallando la 4.0.9 ed installando l'ultima versione 4.3.0 di Editor Switcher ed e` tornato tutto a posto.
Grazie a tutti

 

Host

Torna su