Back to top

Autore Topic: Joomla 5  (Letto 1462 volte)

Offline saliinvetta

  • Appassionato
  • ***
  • Post: 506
  • Sesso: Maschio
    • Mostra profilo
Joomla 5
« il: 19 Ott 2023, 10:17:59 »
Buongiorno
Volevo raccogliere qualche parere e confronto


Qualcuno di voi ha installato Joomla 5?
Io volevo passare prima alla 4.4 e poi alla 5.


È una versione stabile ma conviene comunque aspettare? Oppure aggiorniamo tutto alla grande?


Ho sentito che sostanzialmente non si tratta di una vera e propria migrazione
Solo di un grosso aggiornamento


Grazie

Offline sechifabio

  • Nuovo arrivato
  • *
  • Post: 18
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #1 il: 19 Ott 2023, 23:50:22 »
ciaovai nella sezione Notizie e trovi tutti i dettagli su Joomla 5
siccome Joomla 4.4 sarà ancora assistito per un paio d'anni non c'è fretta per questo importante aggiornamento. Inoltre intanto preparati con l'ultima versione 4.4 che ti predispone alla 5.0.https://www.joomla.it/notizie/rilasci-joomla/9113-notizie-sulla-pubblicazione-joomla-5-0-e-joomla-4-4-sono-qui.html
Ciao

Offline saliinvetta

  • Appassionato
  • ***
  • Post: 506
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #2 il: 20 Ott 2023, 14:12:52 »
Buongiorno
Grazie mille per il messaggio


Ho fatto su una sottodirectory di prova un aggiornamento prima dei componenti (zero errori), poi di Joomla 4.4 e infine di Joomla 5 scaricando il relativo pacchetto di aggiornamento


Una volta terminata l'installazione di Joomla 4.4 ho ricevuto questo errore:




Una volta terminato l'aggiornamento a Joomla 5 ho ricevuto lo stesso indentico errore:




Premetto che il sito andava tutto perfettamente, sia con Joomla 4.4 che con la 5 !

A che cosa possono essere ricondotti questi errori ?
a me sembrano errori di Cache, quindi trascurabili.......
Voi cosa dite ?

Grazie mille
« Ultima modifica: 20 Ott 2023, 14:18:33 da saliinvetta »

Offline infermieriattivi

  • Appassionato
  • ***
  • Post: 304
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #3 il: 21 Ott 2023, 08:07:35 »
Ciao
Se sono errori di cache, se la cancelli e poi provi su un altro browser il sito dovrebbe funzionare bene.


Io aspetto a passare a joomla 5 ho visto che chiede una versione del database mariadb 10.4 ma il mio hosting ha 10.3.


Controlla anche la versione php che stai usando, i requisiti di j5 sono al link




Offline Alistair

  • Appassionato
  • ***
  • Post: 340
    • Mostra profilo
Re:Joomla 5
« Risposta #4 il: 23 Ott 2023, 09:06:58 »
Il mio hosting, OVH, manco è compatibile per il passaggio a Joomla!5 "le confermo che la versione MySQL attuale dei database inclusi negli hosting è 5.7 e non c'è una data prevista per passare alla 8"...

Offline saliinvetta

  • Appassionato
  • ***
  • Post: 506
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #5 il: 23 Ott 2023, 17:31:58 »
Sul mio host tramite richiesta mi è possibile mettere Mysql 8
Unica cosa, se dovessi già attivarlo secondo voi il sito potrebbe dare problemi con questa versione?
Ora ho Joomla 4.3.4

Offline infermieriattivi

  • Appassionato
  • ***
  • Post: 304
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #6 il: 24 Ott 2023, 09:31:39 »
Il mio hosting, OVH, manco è compatibile per il passaggio a Joomla!5 "le confermo che la versione MySQL attuale dei database inclusi negli hosting è 5.7 e non c'è una data prevista per passare alla 8"...
Se ci guardi OVH ha sicuramente un database a pagamento, con la versione 8 di mysql.


Io per adesso ho mariadb 10.34 e ho chiesto all'hosting se fanno un upgrade.
In una versione di prova ho messo joomla5 senza altre estensioni e funziona, ma è come dire che l'auto si è accesa, ma poi se  parto e ci sono dei problemi, resto a piedi, non va bene.
Io attendo.

Offline saliinvetta

  • Appassionato
  • ***
  • Post: 506
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #7 il: 24 Ott 2023, 11:19:00 »
Tu hai installato la 4.40 Invece ?
Stai usando quella ?
Grazie

Offline Alistair

  • Appassionato
  • ***
  • Post: 340
    • Mostra profilo
Re:Joomla 5
« Risposta #8 il: 26 Ott 2023, 14:46:43 »
Io 4.4.0

Offline infermieriattivi

  • Appassionato
  • ***
  • Post: 304
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #9 il: 28 Ott 2023, 17:14:14 »
Anch'io 4.4 pronto per il 5.

Offline mastino

  • Appassionato
  • ***
  • Post: 230
  • Sesso: Maschio
    • Mostra profilo
Re:Joomla 5
« Risposta #10 il: 05 Nov 2023, 11:16:28 »
Ho installato J5 su un paio di siti web (molto semplici, 10 pagine circa) e non ho avuto alcun problema o disservizio. Esperienza completamente positiva per me.
L'unico dettaglio che mi preoccupa un pochino è l'assenza della traduzione italiana. Normalmente chi se ne è occupato era sempre super veloce nel produrla e renderla disponibile.
Questa volta mi pare che ci siano problemi o intoppi. Spero che venga rilasciata al più presto, ma non ho notizie fresche
Ciao

Offline arteebotanica

  • Appassionato
  • ***
  • Post: 288
  • Sesso: Maschio
  • un grazie a tutti per l'impegno
    • Mostra profilo
Re:Joomla 5
« Risposta #11 il: 21 Dic 2023, 22:30:29 »
io sono passato alla 5 su un sito di prova e va tutto bene, ho prima richiesto di passare dal database mysql 5.x alla versione 8.x e non mi hanno fatto alcun problema ad aggiornarmi il database, funziona bene anche la versione 4 sul database versione 8
ciao
Lorenzo stocco
www.arteebotanica.org

Offline giusebos

  • Fuori controllo
  • *
  • Post: 21746
  • Sesso: Maschio
  • Giuseppe Serbelloni Mazzanti Viendalmare
    • Mostra profilo
Re:Joomla 5
« Risposta #12 il: 27 Dic 2023, 11:21:38 »
Ho fatto quelche test con la versione 5 di joomla ed ho tratto delle conclusioni:

  • la versione 5 si differenzia dalla versione 4 in quanto è stata ripulita di tutto quel codice inutile e deprecato che si portava dietro fin dalla versione 3
  • Joomla versione 5 non è compatibile con le estensioni di J4 a meno che non si attivi il plug in specifico per la retrocompatibiltà, perdendo tutti i vantaggi della versione 5.....
  • J5 non ha una traduzione in italiano, anche se accetta il file della traduzione in italiano disponibile per J4
  • J5 richiede una versione di mariaDB o Mysql molto aggiornata, specifica difficile da trovare visto che i provider sono restii a fare operazioni di aggiornamento su server condivisi dove vi sono una miriade di siti relaizzati con le più svariate combinazioni di tecnologie varie

Quindi a questo punto mi chiedo se è veramente opportuno precipitarsi ad aggiornare, considerando che la versione 4 di joomla sarà supportata ancora per un paio di anni almeno?

Inoltre considerando che non vi è quasi nessuna estensione specifica per j5 che benefici ne avremmo usandola in modalità compatibilità con J4?

fatevi 2 conti e vedete voi se è il caso di aspettare ancora un pò oppure farsi dei film mentali perchè il passaggio da j4 a J5 è ancora costellato da una serie di problemi?

J5 è nato solo per dare tempo agli sviluppatori di realizzare le proprie estensioni per quella versione molto  simile a J4 ma senza tutto il vecchio codice retrocompatibile con classi e librerie che arrivano dal passato.

Abbiate pazienza e aggiornate i vostri siti con tutta la calma del caso, nessuno vi rincorre.

su www.icagenda.it guide e tutorial con esempi di chronoforms e chronoconnectivity

 



Web Design Bolzano Kreatif