Back to top

Autore Topic: Si può cambiare la versione dell'API JavaScript di Maps sul sito?  (Letto 176 volte)

Offline enrico62

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Salve a tutti, a fine Giugno Google mi aveva inviato questa mail riguardo un sito immobiliare (Joomla 3 e PHP 8.1):

"Rivedi quali delle tue risorse API JavaScript di Maps hanno un utilizzo incompatibile. Cambia la tua applicazione per evitare un'interruzione nel tuo servizio. Ciao cliente di Google Maps, ti scriviamo per informarti che l'API JavaScript di Maps non sarà disponibile per le applicazioni che utilizzano librerie non conformi, dall'API JavaScript di Maps versione 3.54, rilasciata sul canale settimanale nell'agosto 2023.
Che devo sapere?
Alcune librerie di terze parti emulano le funzionalità JavaScript più recenti, per i browser che potrebbero non supportarle in modo nativo. L'API JavaScript di Maps inizierà a utilizzare alcune funzionalità più recenti nello standard ECMAScript, vale a dire Array.from().
Mentre Array.from() è disponibile e funziona in tutti i browser supportati dall'API JavaScript di Google Maps, alcune applicazioni hanno codice che sostituisce la versione funzionante di questo con una versione non valida da una libreria - creando un ambiente JS non valido. Programma della versione • La versione 3.54 sarà caricata nel canale settimanale a metà agosto 2023 e nel canale trimestrale a novembre 2023. • La versione 3.53 (l'ultima versione che non utilizza Array.from()) sarà dismessa a maggio 2024.
In alternativa, per il momento puoi specificare una versione dell'API JavaScript di Maps inferiore alla v3.54, con l'avvertenza che qualsiasi versione è disponibile solo per un anno. Ad esempio, puoi specificare v=3.53 fino ad aprile 2024, dopodiché tutte le versioni JavaScript di Maps richiederanno una correzione per la tua applicazione.""

In attesa di un rinnovo totale del sito, a me andrebbe anche bene questa soluzione provvisoria (trovata anche su Google Maps Platform), quindi:

"Un aggiornamento ha interessato la mia applicazione
L'aggiornamento dei canali di rilascio potrebbe incidere sulla tua applicazione. Questo può accadere perché la tua applicazione si basa su funzionalità non documentate o deprecate oppure a causa di un bug o di una correzione di bug che abbiamo introdotto.
Come soluzione alternativa temporanea, puoi riconfigurare l'applicazione in modo che utilizzi una versione precedente.
   1   Apri la console negli strumenti per sviluppatori del browser e osserva il valore di google.maps.version
   2   Aggiorna il tag script che carica l'API e richiedi un numero di versione precedente"

Ora, dato che sul sito in questione sto utilizzando l'estensione JEA (Joomla Estate Agency) che presenta questo problema, supongo che il TAG in questione si trovi al suo interno, per caso qualcuno ha qualche suggerimento su dove trovarlo?
Grazie per l'aiuto.
(spero di aver pubblicato nella sezione corretta)
« Ultima modifica: 07 Dic 2023, 11:52:42 da enrico62 »

 



Web Design Bolzano Kreatif