Autore Topic: Non mi funziona PayPal  (Letto 2697 volte)

Offline Myrko

  • Nuovo arrivato
  • *
  • Post: 44
    • Mostra profilo
Non mi funziona PayPal
« il: 31 Mag 2007, 00:04:22 »
Salve a tutti.
Nel mio sito ho configurato PayPal quale metodo di pagamento oltre ad altri, ma quando provo ad effettuare un ordine il mio sito non mi reindirizza al sito di PayPal.
Forse il tutto è dovuto al fatto che nel Payment Extra Info per PayPal non ho alcun codice di programmazione.
Ho letto, infatti, che c'è da cambiare il suffisso .com con .it ma io non ho codice!
Potete aiutarmi?
Grazie

Offline surfbit

  • Instancabile
  • ******
  • Post: 7316
  • Sesso: Maschio
  • Verranno ignorati mp tecnici
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #1 il: 31 Mag 2007, 15:07:23 »
Se il sito non ti reindirizza al sito di PayPal hai sbagliato il link.
A volte basta un sorriso per far felice una persona.

La guida alla scelta dell'hosting per Joomla!  Joomlaspace.it: l'hosting per Joomla

Offline Myrko

  • Nuovo arrivato
  • *
  • Post: 44
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #2 il: 31 Mag 2007, 19:40:19 »
Forse non mi sono spiegato bene. Spuntando il tipo di pagamento con PayPal il cliente che compra dal mio sito arriva a fine ordine e gli viene data la conferma dell'ordine effettuato senza reindirizzarlo a PayPal. A me arriva l'email di completamento ordine nel quale si dice che il cliente vuole pagare tramite PayPal e quindi devo mandargli io la richiesta di transazione dal sito di PayPal presso l'e-mail che ha specificato nel form. Nella sezione di configurazione di PayPal posso solo aggiungere l'indirizzo e-mail da usare per la transazione e determinare lo status dei vari ordini pagati con PayPal, ma non mi compare alcun campo in cui immettere l'URL per il reidirizzamento.
Spero di aver spiegato con sufficiente chiarezza.
Ragazzi per gentilezza datemi una mano perché gestisco una libreria esoterica molto nota e il pagamento con PayPal mi è fondamentale per i clienti stranieri e non solo.
Grazie

Offline cos

  • Abituale
  • ****
  • Post: 1872
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #3 il: 31 Mag 2007, 20:13:46 »


hai guardato nella seconda linguetta della configurazione del pagamento

il codice è li  !!

ovviamente sei registrao a paypal??

Offline Myrko

  • Nuovo arrivato
  • *
  • Post: 44
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #4 il: 31 Mag 2007, 21:13:08 »
Certo che sono registrato a PayPal, ho un conto Business!
Nella seconda linguetta mi riporta solo i seguenti comandi:

Modalità di prova?  Sì No
 
Email PayPal:
 
Stato dell´ordine che determina se una transazione è andata a buon fine:
 
Order Status for Pending Payments:

Accept only verified buyers?  No Sì 

Stato dell´ordine per transazioni non andate a buon fine:

E ci sono gli Extra Payment Info vuoti.

Offline cos

  • Abituale
  • ****
  • Post: 1872
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #5 il: 01 Giu 2007, 07:32:50 »

E ci sono gli Extra Payment Info vuoti.
ecco quello che ci dovrebbe essere

<?php
$url = "https://www.paypal.com/cgi-bin/webscr";
$tax_total = $db->f("order_tax") + $db->f("order_shipping_tax");
$discount_total = $db->f("coupon_discount") + $db->f("order_discount");
$post_variables = Array(
"cmd" => "_xclick",
"business" => PAYPAL_EMAIL,
"receiver_email" => PAYPAL_EMAIL,
"item_name" => $VM_LANG->_PHPSHOP_ORDER_PRINT_PO_NUMBER.": ". $db->f("order_id"),
"order_id" => $db->f("order_id"),
"invoice" => $db->f("order_number"),
"amount" => round( $db->f("order_subtotal")+$tax_total-$discount_total, 2),
"shipping" => sprintf("%.2f", $db->f("order_shipping")),
"currency_code" => $_SESSION['vendor_currency'],
"image_url" => $vendor_image_url,
"return" => SECUREURL ."index.php?option=com_virtuemart&page=checkout.result&order_id=".$db->f("order_id"),
"notify_url" => SECUREURL ."administrator/components/com_virtuemart/notify.php",
"cancel_return" => SECUREURL ."index.php",
"undefined_quantity" => "0",
"test_ipn" => PAYPAL_DEBUG,
"pal" => "NRUBJXESJTY24",
"no_shipping" => "1",
"no_note" => "1"
);
if( $page == "checkout.thankyou" ) {
$query_string = "?";
foreach( $post_variables as $name => $value ) {
$query_string .= $name. "=" . urlencode($value) ."&";
}
mosRedirect( $url . $query_string );
} else {

echo '<form action="'.$url.'" method="post" target="_blank">';
echo '<input type="image" name="submit" src="http://images.paypal.com/images/x-click-but6.gif" border="0" alt="Make payments with PayPal, it is fast, free, and secure!">';

foreach( $post_variables as $name => $value ) {
echo '<input type="hidden" name="'.$name.'" value="'.$value.'" />';
}

echo '</form>';

}
?>

Offline Myrko

  • Nuovo arrivato
  • *
  • Post: 44
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #6 il: 01 Giu 2007, 12:08:10 »
Ciao, non so come ringraziarti!
Funziona tutto!!!
Siccome ho iniziato un anno fa a fare ricerche su Joomla+VirtueMart ed a testarli, a uplodarli sul mio spazio web e poi quando sbagliavo tutto li disinstallavo. E' successo che ho cancellato tutte le modalità di pagamento che allora pensavo non mi sarebbero servite.
Quanto mi sbagliavo!
Ora le ho ricaricate tutte ma ovviamente il sito non le riconosce se non le richiami.
Così è stato con PayPal.
Comunque, ti ringrazio ancora tanto e ringrazio tutti gli amici del forum che hanno reso possibile quello che oggi è Joomla: un software fantastico!

Myrko

Offline cos

  • Abituale
  • ****
  • Post: 1872
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #7 il: 01 Giu 2007, 13:41:35 »
be appena pronto il sito

likalo che sono curioso



Offline Myrko

  • Nuovo arrivato
  • *
  • Post: 44
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #8 il: 01 Giu 2007, 18:43:52 »
Il sito l'ho finito ed ora lo sto popolando di prodotti.
E' visibile presso http://lnx.ilreamedinverno.com .
Premetto che si tratta di una libreria esoterica e quindi non so se si può linkare un sito commerciale nel forum.
Se ciò dovesse essere contrario alle norme comportamentali del forum, potete cancellare il messaggio.
Ancora un grazie e buon lavoro.

P.S. Magari di tanto in tanto posto qualche altro problemino in modo da mantenere i contatti?
Scherzo!

Myrko

Offline vincenzo (enzojoomla)

  • Appassionato
  • ***
  • Post: 227
  • Sesso: Maschio
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #9 il: 01 Ott 2007, 16:35:41 »
Il sito l'ho finito ed ora lo sto popolando di prodotti.
E' visibile presso http://lnx.ilreamedinverno.com .
Premetto che si tratta di una libreria esoterica e quindi non so se si può linkare un sito commerciale nel forum.
Se ciò dovesse essere contrario alle norme comportamentali del forum, potete cancellare il messaggio.
Ancora un grazie e buon lavoro.

P.S. Magari di tanto in tanto posto qualche altro problemino in modo da mantenere i contatti?
Scherzo!

Myrko
Ho visto il sito ...complimenti..ci sto provando anche io a fare una cosa simile ...cioè utilizzare VM ma sono in alto mare...a partire dalla lingua italiana che non riesco a capire come si imposta visto che ho il file italian.php ma non trovo la cartella languages....mi potresti aiutare?
grazie v.

Offline akramul

  • Nuovo arrivato
  • *
  • Post: 22
  • Sesso: Maschio
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #10 il: 03 Ott 2007, 13:49:03 »

Citazione
Ho visto il sito ...complimenti..ci sto provando anche io a fare una cosa simile ...cioè utilizzare VM ma sono in alto mare...a partire dalla lingua italiana che non riesco a capire come si imposta visto che ho il file italian.php ma non trovo la cartella languages....mi potresti aiutare?
grazie v.

Per impostare VirtueMart devi caricare il fil italian.php alla seguente cartella.

/administrator/components/com_virtuemart/languages

una volta caricato con FTP al server automaticamente si imposta in Italiano
sè vuoi potrai dare in occhiata al mio sito che ho impostato in Italiano www.outshop.net

spero di esserti stato d'aiuto
~~~~~~~~~~~~~~~~~~~~&~~~~~~~~~~~~~~~~~~~~

Condividiamoci le IDEE sul Forum Joomla.It  ~~~~~~~~~~~~~~~~~~~~&~~~~~~~~~~~~~~~~~~~~

Offline vincenzo (enzojoomla)

  • Appassionato
  • ***
  • Post: 227
  • Sesso: Maschio
    • Mostra profilo
Re: Non mi funziona PayPal
« Risposta #11 il: 03 Ott 2007, 14:31:21 »

Citazione
Ho visto il sito ...complimenti..ci sto provando anche io a fare una cosa simile ...cioè utilizzare VM ma sono in alto mare...a partire dalla lingua italiana che non riesco a capire come si imposta visto che ho il file italian.php ma non trovo la cartella languages....mi potresti aiutare?
grazie v.

Per impostare VirtueMart devi caricare il fil italian.php alla seguente cartella.

/administrator/components/com_virtuemart/languages

una volta caricato con FTP al server automaticamente si imposta in Italiano
sè vuoi potrai dare in occhiata al mio sito che ho impostato in Italiano www.outshop.net

spero di esserti stato d'aiuto

grazie avevo risolto.....non andavo a vedere in administrator ma in components.
ciao e complimenti per il sito...

 

Host

Torna su