Autore Topic: Innumerevoli errori sul sito... aggiornamento server o possibile attacco?  (Letto 1906 volte)

Offline wendy

  • Esploratore
  • **
  • Post: 121
  • Sesso: Femmina
    • Mostra profilo
Ciao a tutti!
Da qualche mese ho messo il mio sito su un server remoto... fatta nuova installazione, ricaricato il db e tutto funzionava a meraviglia (joomla 1.0.13 stabile in italiano su server linux)... ultimamente poi per varie cose non sono più andata a controllare il sito o ad aggiornare gli articoli, finché un paio di giorni fa a casa di un'amica decido di farle vedere il mio portale; entro nel sito e va tutto ok... faccio il login, e a quel punto mi è preso un accidente!!! Praticamente mi trovo tutta la hp sballata con una sfilza di errori nel modulo di login di CB e in quello delle immagini random di Ponygallery... argh!! che è successo??? Inizio a girare per il sito e ci sono liste interminabili di errori in praticamente tutte le pagine, anche se poi il resto della pagina viene visualizzata correttamente... panico totale!! La sera da casa cerco di capirci qualcosa, vado nel pannello dei settaggi e provo a settare la segnalazione errori da nessuna a semplice, torno in frontend e tutti i messaggi di errore sono spariti! Faccio di nuovo il giro di qualche pagina tra le news e le rubriche e pare essere tutto a posto, per fortuna, e lo stesso in diverse pagine del pannello di admin. Poi decido di fare un controllo nel frontend su tutti i vari componenti ed ecco nuove sorprese! A parte il fatto che in molte pagine il testo mi risulta con le lettere accentate sostituite dai classici caratteri che si ritrovano in genere dopo la sostituzione del db da un precedente backup (caratteri che ovviamente avevo rimesso a posto completamente dopo il trasferimento di server 3 mesi fa), mi accorgo che ci sono vari componenti che hanno iniziato a dare i numeri con un'altra sfilza di errori vari...  ???

Mi sono ritrovata ad esempio con il Docman che nelle pagine delle categorie funziona bene, ma quando entro nella pagina dei files mi rifila questi messaggi:

Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/home/isola/domains/isolachenonce-online.it/public_html/community/dmdocuments/) is not within the allowed path(s): (/var/www/vhosts/isolachenonce-online.it/httpdocs:/tmp) in /var/www/vhosts/isolachenonce-online.it/httpdocs/portale/administrator/components/com_docman/classes/DOCMAN_file.class.php on line 72

Warning: filesize() [function.filesize]: open_basedir restriction in effect. File(/home/isola/domains/isolachenonce-online.it/public_html/community/Nuovi Manoscritti del Mar Morto.pdf) is not within the allowed path(s): (/var/www/vhosts/isolachenonce-online.it/httpdocs:/tmp) in /var/www/vhosts/isolachenonce-online.it/httpdocs/portale/administrator/components/com_docman/classes/DOCMAN_file.class.php on line 87

ripetuti per ognuno dei files inseriti, e gli stessi errori me li dà nella pagina della gestione dei files in admin. Frugando nel forum ho trovato un amico che aveva ricevuto lo stesso tipo di errore in una sua installazione e aveva risolto reinstallando il componente, ma a quanto pare lui aveva avuto questo problema fin dall'inizio, mentre da me prima funzionava bene... praticamente è come se i files inseriti per il download non esistessero, seppure vengano correttamente segnalati nell'indicatore di files presenti nelle categorie e, sotto la sfilza di errori, nella stessa pagina dei download. Tra l'altro, quando sono andata sul server a controllare se i files fossero a posto, ho notato che tutti i permessi precedentemente settati a 644 ora erano tutti a 600 (solo per i files da scaricare da Docman)!!! Ho ripristinato i permessi giusti ma purtroppo non è cambiato niente, oltre al fatto che uno dei files, seppure presente sul server, quando lo vado a selezionare da Joomlaxplorer per modificare i permessi, mi dà errore dicendo che il file è inesistente!!! Come può essere possibile se il file lì c'è??  :o

Altro problema l'ho riscontrato coi componenti Ponygallery e Ricettario, dal momento che entrando nella pagine iniziali dei componenti ho le pagine corrette, ma se provo ad entrare nelle categorie principali mi dà una pagina bianca con la sola barra di navigazione del componente, il campo per la ricerca e i link per le top ten, gli ultimi files inseriti ecc., ma per il resto nisba, né oggetti, né template.. niente!! La cosa ancora più strana è che in Ponygallery (nel ricettario non so, poiché non ci sono ancora ricette inserite), se accedo alle sottocategorie tramite il modulo per le immagini random, posso entrare nelle pagine visualizzate correttamente, così come non ho problemi nella pagina di visualizzazione delle immagini singole ingrandite. Inoltre è andato fuori combattimento anche il Security Image che non mi visualizza più le immagini coi codici di sicurezza e al momento ho dovuto disattivarlo...  :'(

P.S. Ho appena saputo che circa una ventina di giorni fa, per cui probabilmente dopo il mio ultimo accesso al sito, sul mio server hanno fatto un aggiornamento del php dalla 5.0 mi pare alla 5.2.5...

adesso vorrei sapere se c'è qualche anima gentile che sa darmi qualche informazione al riguardo; il dubbio è: possibile che l'aggiornamento del php abbia potuto causare tutti questi casini??
O è possibile che si tratti di qualche altro problema legato a qualche manomissione esterna al sito??? E in ogni caso, come si potrebbero risolvere i problemi?
Nel caso la cosa fosse collegata all'aggiornamento del server, i problemi possono essere legati alla compatibilità di alcuni moduli e componenti con la nuova versione del php? E in questo caso allora ci sono degli aggiornamenti per questi componenti o basterebbe reinstallare i suddetti componenti per rimettere tutto a posto?? O mi tocca reinstallare da capo tutto il portale?? Non ci capisco più niente!!! :o

I componenti al momento caricati sono:

Akobook v. 2.0.4
Akocomment v. 2.0
Angelday v. 1.0
Bioritmo v. 0.2.1
Community Builder v. 1.1
Docman v. 1.3 RC2
Ewriting v. 1.2.1
Extcalendar v. 0.9.2
Gary's Cookbook v. 2.1b
Glossary v. 1.8
Ponygallery v. 1.15 Beta
Joomblog v. 3
Joomlaboard v. 1.1.4 stabile
Joomlaxplorer v. 1.6.0
Livesupport
Marketplace v. 1.2
Noah v. 1.0 Beta 4
MyPMS Opensource v. 2.5.0
Ricettario v. 1.02
Rwcards v. 2.4.0
Security Image v. 3.0.8
Simple Rewiew v. 1.3.5
Yanc v. 1.5 beta2

e quelli in neretto sono tutti quelli che in un modo o nell'altro hanno dato problemi.

Scusate per la lunghezza del post e spero di essere stata chiara nella spiegazione dei problemi!!

Un saluto a tutti

Wendy

http://www.isolachenonce-online.it/portale/

Non cambierai mai le cose combattendo la realtà esistente; costruisci un modello nuovo che renda la realtà obsoleta! (B. Fuller)

 

Host

Torna su