Autore Topic: Attenzione: aggiornare Docman alla 1.4.0RC2  (Letto 36692 volte)

Offline ste

  • Instancabile
  • ******
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Attenzione: aggiornare Docman alla 1.4.0RC2
« il: 20 Feb 2008, 10:19:11 »
Disponibile l'aggiornamento di Docman alla versione 1.4.0RC2 per la scoperta di una falla di sicurezza importante
http://forum.joomla.it/index.php/topic,37784.0.html
E' vivamente consigliato aggiornare a questa versione.
« Ultima modifica: 20 Feb 2008, 14:17:03 da filpi5481 »
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline rinuccio

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 3140
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #1 il: 20 Feb 2008, 12:30:47 »
come si aggiorna? non trova la patch ???

Offline ste

  • Instancabile
  • ******
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #2 il: 20 Feb 2008, 12:41:13 »
Qui trovi le istruzioni
http://downloads.joomlacode.org/frsrelease/2/2/4/22417/readme_1.4.0rc2.txt
Trovi le istruzioni per aggiornare dalla 1.4.0 in su qui:
Upgrading from v1.4.0 ALPHA or later
e le istruzioni per aggiornare versioni più vecchie qui:
Upgrading from v1.3 RC1 or RC2
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline rinuccio

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 3140
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #3 il: 20 Feb 2008, 12:44:42 »
LoL inglese ;D
io ho su la  1.4.0beta2 September 2007...
Sinceramente non ho capito come fare :-[

Offline ste

  • Instancabile
  • ******
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #4 il: 20 Feb 2008, 12:56:37 »
Per la tua versione dovrebbe essere sufficiente disinstallare e reinstallare il componente.
Per sicurezza prima fai un backup del database e dei file
/administrator/components/com_docman/docman.config.php
/components/com_docman/themes
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline sali40

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4791
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #5 il: 20 Feb 2008, 13:00:54 »
ho visto 1.4.0RC2 anche per i vari moduli e mambot, però

Offline rinuccio

  • Team Joomla.it
  • Instancabile
  • *******
  • Post: 3140
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #6 il: 20 Feb 2008, 13:04:53 »
xfetto :p aggiornato con successo... GraZie :):):)

Offline filpi5481

  • Global Moderator
  • Instancabile
  • *****
  • Post: 4106
  • Sesso: Maschio
  • NO MP TECNICI
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #7 il: 20 Feb 2008, 14:17:40 »
aggiornato senza problemi :)

ciao
Volete sapere tutto sul nuovo iPad di Apple? iPad Forum Italia
Global moderator Joomla.it

Offline ugoberenice

  • Esploratore
  • **
  • Post: 142
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #8 il: 20 Feb 2008, 19:31:37 »
Effettuato positivamente.
L'unica cosa alla quale bisogna fare attenzione sono i permessi. bisogne reimpostare tutto. ;)

Offline Elwood

  • Esploratore
  • **
  • Post: 129
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #9 il: 22 Feb 2008, 01:20:23 »
ho letto che il config va risettato.
sapete dirmi se i dati dei counters (n° di downloads) vanno persi  e ripartono da zero o sono mantenuti nella nuova versione?

Grazie,
Elwood
Il mio Onore si chiama Fedeltà

Offline Carlotul

  • Esploratore
  • **
  • Post: 62
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #10 il: 22 Feb 2008, 17:19:28 »
Qui trovi le istruzioni
http://downloads.joomlacode.org/frsrelease/2/2/4/22417/readme_1.4.0rc2.txt
Trovi le istruzioni per aggiornare dalla 1.4.0 in su qui:
Upgrading from v1.4.0 ALPHA or later
e le istruzioni per aggiornare versioni più vecchie qui:
Upgrading from v1.3 RC1 or RC2

Ciao, ho fatto l'installazione della nuova versione, ora dove posso trovare le traduzioni in italiano ?

Grazie ;)

Carlo





Offline filpi5481

  • Global Moderator
  • Instancabile
  • *****
  • Post: 4106
  • Sesso: Maschio
  • NO MP TECNICI
    • Mostra profilo
Volete sapere tutto sul nuovo iPad di Apple? iPad Forum Italia
Global moderator Joomla.it

Offline bettaj

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #12 il: 23 Feb 2008, 12:34:49 »
1-Ho aggiornato joomla 1.5 a 1.5.1.
2-Ho disinstallato DocMan 1.4.ORC1
3-Ho controllato che tutte le cartelle fossero scrivibili.
4-Ho provato ad installare il nuovo DocMan 1.4.0RC2. L'installazione fallisce con il seguente messaggio di errore:
DOCman
Unwriteable: /
Installation failed!
DOCman is a document management and download component for Joomla! v1.0.x and v1.5.x.

Qualcuno ha qualche idea per risolvere il problema?


Offline filpi5481

  • Global Moderator
  • Instancabile
  • *****
  • Post: 4106
  • Sesso: Maschio
  • NO MP TECNICI
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #13 il: 23 Feb 2008, 13:12:05 »
ciao.. bevenuto sul forum di joomla.it

prova a settare i permessi a 755 o 777

ciao
filpi5481
Volete sapere tutto sul nuovo iPad di Apple? iPad Forum Italia
Global moderator Joomla.it

Offline ste

  • Instancabile
  • ******
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #14 il: 23 Feb 2008, 17:50:17 »
Ciao bettaj, ti consiglio di attendere che esca una versione di Docman per la 1.5, questa versione è compatibile solo col Legacy mode attivo.
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline bettaj

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #15 il: 23 Feb 2008, 18:52:31 »
Grazie, ho risolto, cambiando temporaneamente il proprietario della DocumentRoot da root ad apache per poter effettuare l'installazione. Però con la versione di docman 1.4.RC1 non era necessario.
Adesso sembra che funzioni!
ciao
Bettaj

Offline Doctorweb

  • Esploratore
  • **
  • Post: 164
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #16 il: 25 Feb 2008, 16:18:45 »
Salve a tutti,
ho installato a la nuova versione la 1.4 RC2  ma  non mi fa scaricare i file anche se dalla configurazione ho impostato i permessi in modo che i "guest" possano vedere e scaricare.

Non appare proprio il pulsantino download e ne neppure  dettagli. Ho provato anche a disinstallare completamente le il componente e le tabelle .

Questo è quello che succede: http://www.certamenciceronianum.it/index.php?option=com_docman&task=cat_view&gid=47&&Itemid=53

La versione di Joomla è la 1.0.15 con "Register Globals Emulation" setting   `ON`

Qualcuno ha avut lo stesso problema e può aiutarmi ?

Ciaoo

« Ultima modifica: 25 Feb 2008, 16:22:05 da Doctorweb »

Offline marco0906

  • Nuovo arrivato
  • *
  • Post: 49
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #17 il: 26 Feb 2008, 15:51:38 »
Citazione
Salve a tutti,
ho installato a la nuova versione la 1.4 RC2  ma  non mi fa scaricare i file anche se dalla configurazione ho impostato i permessi in modo che i "guest" possano vedere e scaricare.
ciao a tutti,
ho avuto anche io questo problema : andando a fare l'upgrade dall versione beta2 all' RC2 e ripristinando il "docman.config.php" e la directory "Themes" in modo da mantenere i parametri di configurazione che avevo e non perdere tutte le modifiche che avevo apportato al componente(come indicato nelle istruzioni di upgrade) ma non riuscivo piu a scaricare i documenti con nessun tipo di utente(guest registarto o admin) e non visualizzavo nessun bottone (download,dettagli,visualizza ..) sotto ai link ai documenti.Facendo alcune prove mi sono accorto che andando a ripristinare themes->templates  dell'installazione della RC2 i documeti erano di nuovo linkati     
 e comparivano di nuovo i bottoni (anche se mancava la traduzione di questi che ho aggiunto nel file english.php di themes->language).non so se sia la soluzione migliore ma sicuramente non potevo rimanere cosi appeso privando per molto tempo gli utenti del mio sito di scaricare documenti.Se avete qualche idea migliore la aspetto con ansia!!!
Ps soluzione "maccheronica" ma efficace!

ciao
« Ultima modifica: 26 Feb 2008, 17:29:13 da marco0906 »
Guarda tutti i tuoi video e film preferiti e scoprine di nuovi.. Veedeo ti permette di visualizzare di video aggregandoli dai migliori media provider della rete. Buon divertimento !

Offline robertocgs

  • Nuovo arrivato
  • *
  • Post: 35
  • Sesso: Maschio
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #18 il: 26 Feb 2008, 16:25:56 »
anche io ho questo problema... possibile che nessuno abbia risolto dall'alto questo bug?? hanno aggiornato il componente ma se uno non si mette a smanettare una serata intera ritorna indietro... sarà anche RC2 ma finchè non verrà sistemato questo fix difficilmente la gente aggiornerà la release .. oooo se qualcuno ha trovato una soluzione solida e completa al bug provi a scriverlo perchè quello che ho letto fino ad adesso non mi sembra sia applicabile
La perfezione non è umana

Offline Doctorweb

  • Esploratore
  • **
  • Post: 164
    • Mostra profilo
Re: Attenzione: aggiornare Docman alla 1.4.0RC2
« Risposta #19 il: 27 Feb 2008, 10:05:05 »
Ciao,
io ho provato a disinstallare la vecchia versione e installare direttamente la RC2 ma con lo stesso problema.

Strano che siamo solo noi ad avere questo problema però...

Ciaoooooo

 

Host

Torna su