Autore Topic: [RISOLTO] Perchè il mio sito si vede bene con Firefox e male con IE7?  (Letto 3692 volte)

Offline marcoma

  • Esploratore
  • **
  • Post: 90
  • Sesso: Maschio
    • Mostra profilo
Ciao a tutti.
Volevo sottoporvi un quesito che mi fa impazzire  :o!
Sto realizzando un sito con template cah_ndeso, ho provato anche con qualche altro template. Ho visto che con Firefox tutti gli articoli sono visualizzati quasi correttamente, ho dei problemi con gli elenchi puntati e numerati e con il copia e incolla da word. Quando visualizzo le stesse pagine con IE7 mi trovo il macello, compaiono dei "tag" tipo "<!--[if !supportLists]-->" oppure "<!--[endif]-->"?????  ???
Che cosa succede?
Che cosa bisogna fare?
Devo cambiare template?
Vi ringrazio!
« Ultima modifica: 18 Apr 2008, 14:55:58 da marcoma »

Offline denzel

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re: Perchè il mio sito si vede bene con Firefox e male con IE7?
« Risposta #1 il: 22 Mar 2008, 21:31:31 »
E' cosa nota che i browser microsoft hanno un rispetto approssimativo a quelle che sono le regole stabilite dal w3c, e quindi ai css.
Almeno sapevo che era così fino alla versione 6 di internet explorer: ma a quanto mi pare di capire leggendo il tuo post i problemi non sono stati ancora risolti con il 7!
Mi pare strana una cosa simile: non so essere più preciso per il tuo caso perchè quel template non lo conosco: prova a darci più info, o anche a cambiare template per indagare meglio.

Offline marcoma

  • Esploratore
  • **
  • Post: 90
  • Sesso: Maschio
    • Mostra profilo
Re: Perchè il mio sito si vede bene con Firefox e male con IE7?
« Risposta #2 il: 22 Mar 2008, 21:59:03 »
Ho provato a cambiare template ma non ho ottenuto dei miglioramenti. Quale template mi consiglieresti per fare un'ulteriore verifica?

Offline denzel

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re: Perchè il mio sito si vede bene con Firefox e male con IE7?
« Risposta #3 il: 25 Mar 2008, 00:18:26 »
con ogni template che provi gli errori sono esattamente gli stessi? e... esattamente quali?
ancora: gli stessi errori li ottieni con il template di default di joomla?
ciao!

Offline marcoma

  • Esploratore
  • **
  • Post: 90
  • Sesso: Maschio
    • Mostra profilo
Re: Perchè il mio sito si vede bene con Firefox e male con IE7?
« Risposta #4 il: 25 Mar 2008, 11:55:49 »
Grazie denzel, ho fatto delle prove con uno dei due template di defaults. Niente di nuovo. Adesso ho capito che cosa è successo.
Le "schifezze" sono queste "<!--[if !supportLists]-->" oppure "<!--[endif]-->". Le ho importate da word con il copia ed incolla di elenchi numerati. Copiando questi elenchi in notepad e riportandoli in Joomla!, dopo averli sistemati, sono sparite! Il comando dell'editor che pulisce le formattazioni non aveva alcun effetto. Probabilmente sono io che non lo so usare.
Ciao e Grazie! ;)

Offline denzel

  • Nuovo arrivato
  • *
  • Post: 27
    • Mostra profilo
Re: Perchè il mio sito si vede bene con Firefox e male con IE7?
« Risposta #5 il: 25 Mar 2008, 12:51:50 »
hai trovato l'errore, bene!
infatti è sempre sconsigliato copia-incollare da word-processor, bisogna sempre passare per un text-editor per evitare di trascinarti dietro monnezza di vario tipo!
ciao!

 

Host

Torna su