Back to top

Autore Topic: Errore installazione pacchetti, permessi?  (Letto 4780 volte)

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Errore installazione pacchetti, permessi?
« il: 06 Apr 2008, 21:14:49 »
Salve. Non riesco a installare i pacchetti per i moduli (ovviamente compatibili 1.5..), ho provato in tutti i modi possibili di mia conoscenza. Tra i permessi ho visto che administrator/modules/ e /modules erano settati a 755 (in joomla mi diceva tutti "non scrivibile), li ho messi a 777 ma ancora mi dice che non può fare l'upload dei pacchetti. Sono queste le cartelle da settare a 777 per i moduli? Quale potrebbe essere la causa?
« Ultima modifica: 06 Apr 2008, 21:20:40 da saxofonaio »

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #1 il: 06 Apr 2008, 23:16:31 »
Salve,
ho avuto il medesimo problema, i files che installi di sicuro risultano assegnati a gruppo/utente diversi.
Ho dovuto ricorrere alla assistenza hosting e dopo molto tempo sono riusciti a risolvere (anche se ancora non completamente) il problema.
Tutto per me filava liscio fino ad un certo momento.. poi non so cosa sia accaduto (penso abbiano hanno adottato misure di sicurezza più restrittive)  e non riuscivo più ad installare estenzioni.. avevo da poco installato 1.5.2 e pensavo di aver sbagliato qualcosa, ho cancellato tutto e reinstallato dacapo ma il problema è comparso nella nuova installazione, quindi era sia nei pemrmessi e sia nella assegnazione gruppo/utente...
Ti conviene ricorrere all'assistenza Hosting e spiegare bene che si tratta di joomla 1.5.2
Ciao
« Ultima modifica: 06 Apr 2008, 23:45:45 da 56francesco »
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #2 il: 07 Apr 2008, 00:01:27 »
Grazie Francesco, sembra più grave del previsto.  :-[
Ma cosa dovrei chiedergli esattamente? Non ho afferrato tutto... ::)

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #3 il: 07 Apr 2008, 14:35:35 »
Posso dirti quello che ho fatto io: ho chiesto l'intervento dell'assistenza hosting e gli ho spiegato che si trattava di joomla 1.5.2 rilasciato solo pochi giorni fa (su questo ho dovuto insistere) e non del "solito" joomla, loro hanno modificato i permessi e le combinazioni gruppi/utenti ed  ora il sito funziona...
PS
le varie impostazioni gruppi/utenti dei files nel mio caso non posso gestirle io in quanto utente ma provvede direttamente l'assistenza tecnica.

« Ultima modifica: 07 Apr 2008, 14:39:49 da 56francesco »
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #4 il: 07 Apr 2008, 18:13:41 »
Quindi non è un problema di permessi delle cartelle...
Io pensavo che cambiandole a 777 avrei risolto. E' successo ad altri? E' un problema conosciuto?

Posto qui i permessi cartelle, qualcosa è sbagliato o da cambiare?

administrator/backups/   Non scrivibile
administrator/components/   Non scrivibile
administrator/language/   Non scrivibile
administrator/language/en-GB/   Non scrivibile
administrator/language/it-IT/   Non scrivibile
administrator/modules/   Scrivibile
administrator/templates/   Non scrivibile
components/   Non scrivibile
images/   Non scrivibile
images/banners/   Non scrivibile
images/stories/   Non scrivibile
language/   Non scrivibile
language/en-GB/   Non scrivibile
language/it-IT/   Non scrivibile
language/pdf_fonts/   Non scrivibile
modules/   Scrivibile
plugins/   Non scrivibile
plugins/content/   Non scrivibile
plugins/editors/   Non scrivibile
plugins/editors-xtd/   Non scrivibile
plugins/search/   Non scrivibile
plugins/system/   Non scrivibile
plugins/user/   Non scrivibile
plugins/xmlrpc/   Non scrivibile
tmp/   Non scrivibile
templates/   Non scrivibile
Cartella Cache /var/www/vhosts/********.it/httpdocs/portale/cache/   Scrivibile
Cartella Cache /var/www/vhosts/*********.it/httpdocs/portale/administrator/cache/   Non scrivibile
« Ultima modifica: 07 Apr 2008, 18:22:48 da saxofonaio »

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #5 il: 08 Apr 2008, 11:45:58 »
Hai provato a rivolgerti all'assistenza?

L'elenco dei files lo hai preso da Aiuto, Sistema?
I miei erano alcuni scrivibile e alcuni no, a metterli tutti scrivibili ci ero riuscito ma non risolvevo il problema.

Prova via ftp  (io uso filezilla) a modificare un file (ad esempio il logo o una qualsiasi immagine  .ipg o .png o .gif)  te la fa modificare?
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #6 il: 08 Apr 2008, 18:13:56 »
L'assistenza l'ho contattata ma ancora niente. La lista l'ho presa da Aiuto - sistema. Io posso modificare tutto senza problemi via ftp, anche i files, purtroppo non installa i moduli. Ma sono giusti questi "scrivibili" o sono pochi? Se non trovo una risposta qui che è il forum ufficiale!...  ::)

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #7 il: 08 Apr 2008, 18:32:43 »
i files della pagina citata devono essere tutti scrivibili, cioè tutti spuntati verdi, nelle istruzioni di istallazioni è la prima e sola cosa che dicono di verificare appena dopo l'installazione...
se non ti rispondono la vedo dura, devi fare in modo che diventino tutti spuntati verdi, se li hai potuto modificare nei permessi aspp...
- hai cancellato i temporanei del tuo pc?
- hai scelto di cambiare i permessi solo alle dir oppure alle sottocartelle?
Però non serve 777 basta dare  775  per le dir   e le sottodir
per i file 664, così almeno stanno settati su tre siti che funzionano...

poi per caricare prova a non dare user e pass ftp così aggiorni da sito e non da ftp..



(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #8 il: 08 Apr 2008, 18:38:04 »
Ah... Da configurazione server posso inserire i dati e fare tutto da joomla? non lo sapevo! Comunque ho safe mode "on", può essere questo?  ::)

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #9 il: 08 Apr 2008, 18:43:18 »
Ah... Da configurazione server posso inserire i dati e fare tutto da joomla? non lo sapevo! Comunque ho safe mode "on", può essere questo?  ::)

dovresti concentrarti sul problema dei permessi dei files fino a che diventano tutti scrivibili..
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #10 il: 08 Apr 2008, 18:45:10 »
Grazie, proverò...  ;)

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #11 il: 09 Apr 2008, 19:13:53 »
Ecco cosa mi ha detto il mio host, è vero? ::) Io ho la 1.5.1

il safe_mode non può essere disabilitato.
Le suggeriamo di installare la versione di joomla 1.5.2 che ha corretto questi probemi:
http://joomla.it/
« Ultima modifica: 10 Apr 2008, 18:30:08 da saxofonaio »

Offline saxofonaio

  • Esploratore
  • **
  • Post: 89
    • Mostra profilo
Re: Errore installazione pacchetti, permessi?
« Risposta #12 il: 10 Apr 2008, 18:30:46 »
Nessuno sa niente se è vera questa cosa?

 



Web Design Bolzano Kreatif