Autore Topic: Problema di installazione componente  (Letto 952 volte)

Offline farooldi

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Problema di installazione componente
« il: 07 Giu 2009, 16:35:55 »
Salve
sto cercando di installare una componente, in particolare DOCMAN, ma mi viene restituito questo errore:
* JFolder::create: Impossibile creare la cartella
* JInstaller::install: Creazione cartella fallita.
"/home/miosito/public_html/:.:.:SITE:.:.:/components/com_docman/assets/css".

Ho controllato e settato tutti i permessi a 777.
Ho controllato che i path delle variabili $log_path e $tmp_path siano settate in modo corretto. Non sò cosa fare. Per favore aiutatemi!
Non esistono donne brutte, esiste solo poca vodka!

enzoschi

  • Visitatore
Re:Problema di installazione componente
« Risposta #1 il: 07 Giu 2009, 18:01:30 »
Versione Joomla utilizzata???

Offline farooldi

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Re:Problema di installazione componente
« Risposta #2 il: 07 Giu 2009, 18:08:14 »
La versione è 1.5.11
Non esistono donne brutte, esiste solo poca vodka!

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Re:Problema di installazione componente
« Risposta #3 il: 07 Giu 2009, 19:48:36 »
Ciao farooldi,
   1. Controlla di utilizzare un server linux. In caso tu sia su un server windows passa a linux.
   2. Controlla i permessi delle cartelle via FTP (devono essere settati a 755)
   3. Controlla via FTP di essere l'owner dei files siate voi(Nel caso non lo sia siete mpossibilitati a cambiare alcunchè perchè il server non vi riconosce come "padroni" e quindi non vi autorizza)
      Nel caso contatta il tuo hosting e fai cambiare l'owner dei files e delle cartelle. Alcuni hosting permettono di farlo autonomamente dal pannello di controllo.
   4. Controlla nel file configuration.php i percorsi delle variabili
      var $log_path = '';
      var $tmp_path = '';
      Un'impostazione tipica può essere questa:
      var $log_path = '/home/www/tuosito.com/logs';
      var $tmp_path = '/home/www/tuosito.com/tmp';
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline farooldi

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Re:Problema di installazione componente
« Risposta #4 il: 07 Giu 2009, 20:40:43 »
sono tutti controlli che ho effettuato, per questo non so + a che santo appellarmi.
mi trovo su un server linux dove sono il proprietario delle cartelle e dei files, i permessi dopo continui tentativi successivi sono arrivato a settarli tutti a 777 ed infine ho le variabili settate nel modo corretto.

Per favore sono ormai disperato, non ho altre soluzioni!

Help Help!

Grazie
Non esistono donne brutte, esiste solo poca vodka!

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Problema di installazione componente
« Risposta #5 il: 07 Giu 2009, 22:00:48 »
chiedi all'assistenza hosting se docman di jommla può girare sui loro server ed attendi la loro risposta...
metti tutte le versioni mi raccomando..


(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline farooldi

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
[risolto] - Re:Problema di installazione componente
« Risposta #6 il: 08 Giu 2009, 13:28:29 »
Grazie per aver risposto
Ho contattato il servizio hosting questa mattina e sto aspettando una loro risposta.
In quanto al problema, spulciando nel codice, (ma va!) mi sono reso conto che non riusciva ad effettuare la funzione mkdir.
Quindi da attribuirsi più ad un problema di hosting che ad uno del software.

Vi ringrazio tutti
Buon lavoro!
Non esistono donne brutte, esiste solo poca vodka!

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Problema di installazione componente
« Risposta #7 il: 08 Giu 2009, 13:29:49 »
Citazione
mi sono reso conto che non riusciva ad effettuare la funzione mkdir.
bene,
possiamo aggiungere risolto al titolo, allora?

(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline farooldi

  • Nuovo arrivato
  • *
  • Post: 20
  • Sesso: Maschio
    • Mostra profilo
Re:Problema di installazione componente
« Risposta #8 il: 09 Giu 2009, 19:57:19 »
perchè non l'ho aggiunto?
Non esistono donne brutte, esiste solo poca vodka!

 

Host

Torna su