Autore Topic: Disperazione: l'installazione non crea più il database!  (Letto 2406 volte)

Offline elenix

  • Appassionato
  • ***
  • Post: 234
  • Sesso: Femmina
    • Mostra profilo
Ciao,
non ho la minima idea di cosa possa essere accaduto (uso joomla praticamente tutti i giorni), ma non riesco più ad installare joomla in locale (xampp). Allo step di creazione del database mi risponde "I dettagli del database fornito non sono corretti e/o vuoti."
Cosa diavolo può essere successo?
HELP, HELP, HELP!

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #1 il: 25 Mar 2009, 14:40:22 »
un'installazione di joomla NON crea un database in mysql: il db deve essere preesistente e con un apposito utente per joomla configurato da phpmyadmin.

se hai già fatto questi passaggi, allora i parametri che stai inserendo nei campi di richiesta sono errati: controllali.

Offline elenix

  • Appassionato
  • ***
  • Post: 234
  • Sesso: Femmina
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #2 il: 25 Mar 2009, 15:53:15 »
Permettimi di dissentire ;): l'installazione di joomla (in locale) crea sempre il db e lo popola con le tabelle (vuote) standard di joomla.
« Ultima modifica: 25 Mar 2009, 15:58:26 da elenix »

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #3 il: 25 Mar 2009, 16:00:45 »
Permettimi di dissentire ;): l'installazione di joomla (in locale) crea sempre il db e lo popola con le tabelle (vuote) standard di joomla.


non credo proprio, almeno per quel che mi risulta: il db va creato prima (da te se stai lavorando in locale o dall'host) e joomla poi lo popola in fase d'installazione.

edit: mi è venuto un tremendo sospetto: non dirmi che usi root come nome utente!  :o
come nome di db cosa usi?
« Ultima modifica: 25 Mar 2009, 16:04:57 da RiccardoS »

Offline elenix

  • Appassionato
  • ***
  • Post: 234
  • Sesso: Femmina
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #4 il: 25 Mar 2009, 16:14:27 »
:) sì, in locale uso root e il db ogni volta cambia nome (ovviamente). Nomi brevi tipo: "sito1"

Offline elenix

  • Appassionato
  • ***
  • Post: 234
  • Sesso: Femmina
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #5 il: 25 Mar 2009, 17:20:51 »
cosa c'è che non va nel chiamarsi "root"?

Offline r-evolving

  • Appassionato
  • ***
  • Post: 362
  • Sesso: Maschio
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #6 il: 25 Mar 2009, 20:59:07 »
Usare l'utenza root è come lasciare le chiavi nella toppa.
Assolutamente nessun problema ad utilizzarla su un computer in locale e "stand alone".

Importante:
un'installazione di joomla NON crea un database in mysql: il db deve essere preesistente e con un apposito utente per joomla configurato da phpmyadmin.

Cito RiccardoS e ribadisco: l'istallazione di Joomla! NON crea il db ma solo le tabelle.
Paolo
"I don't have a photograph, but you can have my footprints. They're upstairs in my socks"

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #7 il: 26 Mar 2009, 10:02:08 »
cosa c'è che non va nel chiamarsi "root"?

ti ha già risposto r-evolving: l'importante è ricordarsi di cambiare utente e pwd quando si porta il sito in remoto (cosa che in genere avviene quasi automaticamente poichè nessun hosting lascia entrare gli utenti come root) però sarebbe cosa buona abituarsi ad usare un utente apposito per joomla anche in locale, per capire un pò come funziona almeno la gestione degli utenti e dei db in mysql.
inoltre, metti caso che il sito in locale serva ad una intranet: è molto consigliabile adottare anche qui delle misure di sicurezza minime.

Offline r-evolving

  • Appassionato
  • ***
  • Post: 362
  • Sesso: Maschio
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #8 il: 26 Mar 2009, 11:22:09 »
inoltre, metti caso che il sito in locale serva ad una intranet: è molto consigliabile adottare anche qui delle misure di sicurezza minime.

Esattamente: quando parlavo di computer "stand alone" pensavo ad eventuali situazioni come questa.
Paolo
"I don't have a photograph, but you can have my footprints. They're upstairs in my socks"

Offline elenix

  • Appassionato
  • ***
  • Post: 234
  • Sesso: Femmina
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #9 il: 26 Mar 2009, 15:12:23 »
Perdonatemi, ma da due anni istallo in locale joomla (chiamandomi root, ovviamente) e mi ha sempre creato il database durante l'installazione.
Nei vari server, ovviamente, la procedura è diversa, ovvero non mi chiamo più root (che è un nome molto carino) ma utentex, ho una password e creo preventivamente il db con il phpmyadmin del server che mi ospita.
Sono CERTA che fino a ieri l'istallazione locale creava anche il Db.
Da ieri qualcosa è cambiato, tant'è vero che anche creando un db preventivamente l'installazione non lo popola con le tabelle di joomla.
Non voglio assolutamente essere polemica :) vorrei solo risolvere questa cosa TERRIBILE...
(

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #10 il: 26 Mar 2009, 17:15:33 »
spiega un pò meglio:
hai detto che usi XAMPP, che passi fai esattamente durante l'installazione di Joomla?
quando arrivi alla schermata simile a questa:


che dati inserisci? In particolare nel campo Database Name Mysql inserisci un nome a caso?

Ti ri-assicuro che joomla NON crea il db, a meno che, come detto, usi l'utente "root" con la corretta password come nome utente.

edit: leggo ora che usi proprio questo utente...
Se crei il db con phpmyadmin continua a dirti che "I dettagli del database fornito non sono corretti e/o vuoti."? oppure l'installazione prosegue ma non crea le tabelle?

non è che magari hai cambiato password a root o hai cliccato sull'opzione di messa in sicurezzadi xampp?
« Ultima modifica: 26 Mar 2009, 17:29:43 da RiccardoS »

Offline Kriss

  • Team Joomla.it
  • Abituale
  • *******
  • Post: 1763
  • Sesso: Maschio
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #11 il: 26 Mar 2009, 17:55:32 »
A dire il vero anche io uso xampp da un bel po', e in locale non ho mai creato preventivamente il db. Così scagiono Elenix,alla quale però dico di verificare nella figura che ha inviato RiccardoS se ha riempito tutti i campi correttamente.
Ehi, l'email è solo per salutarmi!

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #12 il: 26 Mar 2009, 18:55:29 »
A dire il vero anche io uso xampp da un bel po', e in locale non ho mai creato preventivamente il db. Così scagiono Elenix,alla quale però dico di verificare nella figura che ha inviato RiccardoS se ha riempito tutti i campi correttamente.

sì infatti mi sono accorto dopo che usava come utente "root": in quel caso, joomla riesce a creare direttamente il db nel mysql di xampp. Personalmente non avevo mai provato perchè ho sempre preferito crearmi uno specifico db ed un utente apposito con i soli permessi su quel db.

Offline elenix

  • Appassionato
  • ***
  • Post: 234
  • Sesso: Femmina
    • Mostra profilo
Re: Disperazione: l'installazione non crea più il database!
« Risposta #13 il: 01 Apr 2009, 11:25:38 »
Vi ringrazio per gli interventi.
Non sono riuscita a risolvere il problema (quindi popolo il database da un'altra installazione già presente e scrivo manualmente il configuration php).
Forse il problema è di xampp (cosa diavolo sarà successo, improvvisamente?) per cui ho deciso di aggiornarlo all'ultima versione rilasciata, la 1.7. Appena avrò finito di lottare anche con xampp vi aggiornerò :)
Grazie ancora per l'interessamento :)

 

Host

Torna su