Autore Topic: dopo update vista xampp morto! RISOLTO  (Letto 4075 volte)

Offline sauro

  • Nuovo arrivato
  • *
  • Post: 31
    • Mostra profilo
dopo update vista xampp morto! RISOLTO
« il: 12 Mar 2009, 13:36:56 »
Prima era un dubbio adesso una certezza. Dopo l'update automatico di vista localhost non esiste pi. La prima volta ho risolto facendo il ripristino di sistema poi, proprio stamattina, nuovo update automatico di vista e di nuovo sito in locale sparito.. proprio localhost che non si raggiuge pi, neanche attraverso il pannello di controllo di xampp. Qualcuno ha lo stesso problema e lo ha risolto?
« Ultima modifica: 15 Mar 2009, 14:52:33 da sauro »

SteveTW

  • Visitatore
Re: dopo update vista xampp morto!
« Risposta #1 il: 12 Mar 2009, 14:40:07 »
easyphp? .... provalo.... non ha questi problemi!!!

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
    • Comune di Lendinara - sito ufficiale
Re: dopo update vista xampp morto!
« Risposta #2 il: 12 Mar 2009, 15:54:30 »
non capisco che relazione ci sia fra aggiornamenti di vista e xampp che un ottimo server completamente standalone che non ha nemmeno bisogno di essere installato, basta estrarlo in una cartella. io lo faccio sempre e non mi ha mai dato problemi del genere.

in che senso localhost sparito? il server non attivo? sono sparite le pagine?

hai provato a rilanciare il file "setup_xampp.bat"?
questo batch configura il server a seconda della posizione in cui si trova nel pc (disco, cartella o penna usb).

Offline sauro

  • Nuovo arrivato
  • *
  • Post: 31
    • Mostra profilo
Re: dopo update vista xampp morto!
« Risposta #3 il: 12 Mar 2009, 16:44:59 »
Non saprei dire... a me comunque successo proprio cos.. avevo intuito la causa quando successo la prima volta ed ora, dopo che ricapitato, ne ho la conferma.
Quando dico che localhost sparito intendo dire che prima, componendo la url http://localhost/  appariva una pagina con vari parametri e l'accesso al database mentre ora appare il classico avviso di indirizzo non trovato.

Prover con le indicazioni che mi avete dato. Grazie

Offline sauro

  • Nuovo arrivato
  • *
  • Post: 31
    • Mostra profilo
Re: dopo update vista xampp morto!
« Risposta #4 il: 12 Mar 2009, 23:30:00 »
Con easyphp riesco ad accedere al database ma non vedo il sito. Prima ho importato le cartelle del vecchio sito nel database e poi ho messo tutti i files nella cartella www. Pi o meno lo stesso procedimento che con xampp funzionava.
Alla fine ho riportato il registro di sistema a prima degli aggiornamenti, ho reinstallato xampp, e tutto ha funzionato. Sembra che la colpa sia proprio di questi ultimi aggiornamenti di Vista. Strano se capita solo a me!

SteveTW

  • Visitatore
Re: dopo update vista xampp morto!
« Risposta #5 il: 13 Mar 2009, 10:04:04 »
Sembra che la colpa sia proprio di questi ultimi aggiornamenti di Vista. Strano se capita solo a me!

Purtroppo non uso Vista, attendo fine anno con Windows 7.... mi sembra di vivere la stessa situazione che nacque tra windows 98 e windows 98 SE

Offline sauro

  • Nuovo arrivato
  • *
  • Post: 31
    • Mostra profilo
Re: dopo update vista xampp morto!
« Risposta #6 il: 15 Mar 2009, 12:06:54 »
Confermando le circostanze o coincidenze dette in precedenza sembrerebbe che gli aggiornamenti di windows non c'entrino con il mio problema. Nonostante avessi bloccato gli aggiornamenti, di nuovo, di colpo, non sono pi riuscito a collegarmi al server locale. Poi, come controprova, nel computer di mia figlia (con vista aggiornato) nessun problema.

Fatto sta che a me il server in locale non funziona pi e non so che pesci pigliare. Forse installando tutte le componenti di xampp separatamente potrei risolvere qualcosa ma la sensazione che sarebbe una fatica inutile e che il problema risieda da qualche altra parte.... naturalmente sarei felicissimo se qualcuno sapesse darmi una dritta! Ciao


Offline sauro

  • Nuovo arrivato
  • *
  • Post: 31
    • Mostra profilo
Re: dopo update vista xampp morto! RISOLTO
« Risposta #7 il: 15 Mar 2009, 14:50:59 »
Ho risolto utilizzando e capendo meglio Easyphp 3.

Sostanzialmente, a differenza di xampp, dove la url per raggiungere il sito in forma http://localhost/.. , in easyphp http://127.0.0.1/...(almeno nel mio caso ... non ho approfondito oltre.. funziona e mi basta!).

Ciao.

Offline RiccardoS

  • Appassionato
  • ***
  • Post: 509
    • Mostra profilo
    • Comune di Lendinara - sito ufficiale
Re: dopo update vista xampp morto! RISOLTO
« Risposta #8 il: 16 Mar 2009, 10:38:54 »
localhost e l'indirizzo ip 127.0.0.1 ("loopback") sono la stessa cosa: identificano cio la macchina locale (o meglio il server attivo su di essa).

l'equivalenza fra i due viene impostata nel file "hosts" (senza estensione) che in xp in cartella_di_windows\system32\drivers\etc, in Vista non ricordo e non ce l'ho sottomano.

in questo file dovrebbe esserci scritto almeno, qualcosa del genere: "127.0.0.1       localhost" poi possono esserci anche altre righe a seconda del bisogno.

prova a vedere se in vista trovi quel file e cosa c' scritto. occhio che dovrebbe essere un file nascosto.

p.s. ma in xampp non funziona con l'indirizzo ip?

Offline pakino

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: dopo update vista xampp morto! RISOLTO
« Risposta #9 il: 08 Apr 2009, 16:31:40 »
Per risolvere questo problema in vista basta eseguire questi passaggi:

1) impostare la visualizzazione di file cartelle nascosti
2) aprire il file C:\Windows\System32\drivers\etc\Host
3) aggiungere alla riga ::1      localhost l'ip 127.0.0.1
alla fine deve essere cosi:
::1         127.0.0.1    localhost
4) salvare tutto e aprendo il tuo broswer digiti anzich 127.0.0.1 http://localhost

PS: funziona perfettamente anche con Xampp

 

Host

Torna su