Autore Topic: Il mio primo template problemi di visualizzazione  (Letto 2171 volte)

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Il mio primo template problemi di visualizzazione
« il: 23 Apr 2009, 18:04:03 »
Ciao a tutti, premetto che sono inesperta perch il primo template che costruisco ed da poco tempo che uso joomla.
Ho costruito il mio template e in locale almeno su firefox funziona tutto alla perfezione. Prima di pubblicarlo nell'hosting definitivo ho fatto una prova su altervista e una volta pubblicato il sito sono nati vari problemi:
- l'animazione che sta nel top non si vede pi ne su firefox n su explorer (mentre in locale si vede benissimo)
- su explorer 7 l'impaginazione risulta totalmente sballata mentre in locale no
- l'effetto delle gallerie di foto tipo lightbox che ho realizzato installando simple image gallery funziona soltanto su firefox.
Potete vedere il mio lavoro qui: http://www.ferraguzzo.altervista.org/
Potreste gentilmente dirmi se posso risolvere tutti questi problemi?
Grazie in anticipo a tutti

Offline sudoku

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4076
  • Sesso: Maschio
  • Non serve essere alti. basta essere all'altezza
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #1 il: 23 Apr 2009, 18:14:57 »
I problemi che si incontrano ad una vista superficiale (ho controllato tramite codice pagina con FF) sono dovuti al non aggiornamento dei percorsi delle immagine che citano ancora <td align="center"><a href="http://localhost/etc...etc...etc..
Per il file swf che non si vede controlla che sia nella cartella images del template. sembrerebbe anche qui un problema di percorsi.
Joomla non una soluzione, un metodo
http://www.BreezingTest.altervista.org

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #2 il: 23 Apr 2009, 20:43:05 »
Ho provato a correggere gli indirizzi delle immagini ma poi sufficente ripubblicare solo index.php? Perch io l'ho fatto ma non cambiato nulla.
Scusami per le domande proprio terra a terra ma con joomla ho davvero poca confidenza. Ero partita abbastanza bene ma ora mi sono relamente persa....

Grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #3 il: 27 Apr 2009, 11:48:01 »
Eccomi di nuovo  :)
Allora ho risolto tutti i problemi delle immagini e ho ripubblicato il sito su netsons e lo potete vedere qui http://www.ferraguzzo.netsons.org/.
Uno dei problemi che mi rimasto per l'effetto lightbox su explorer 7. Come vi dicevo ho installato simple image gallery che su firefox funziona correttamente mentre su explorer apre l'immagine ingrandita in cima alla pagina e non crea l'effeto di oscuramento della pagina. Con il template beez funziona correttamente anche con explorer quindi penso che il problema sia legato al mio template, potete dirmi se posso fare qualcosa attraverso i fogli di stile?
Una delle pagine in cui possibile vedere il problema questa http://www.ferraguzzo.netsons.org/index.php?option=com_content&view=article&id=20&Itemid=21&lang=it
Grazie a tutti in anticipo

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #4 il: 27 Apr 2009, 12:03:54 »
ciao
il menu con firefox e sopra il primo articolo
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #5 il: 27 Apr 2009, 12:26:13 »
Gi, questo un'altro problema ma volevo affrontare uno alla volta,  :) su questo potete darmi un mano? Vi spiego cosa mi successo perch non so dove intervenire. Ho sviluppato tutto il template e poi ho installato swmenufree e succede che per far apparire il menu nella posizione giusta nel mio template devo mettere il valore -65 per Top Menu Top Offset mentre per explorer devo lasciarlo a 0, adesso il men su firefox spopra all'articolo perch il valore di Top Menu Top Offset 0. Come posso intervenire nel template per non avere pi questo problema?
Grazie ancora

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #6 il: 27 Apr 2009, 12:31:56 »
ciao
allora non avendo il template x fare le prove  e capire cosa succede , unica cosa sarebbe che tu zippa tutto il template   e lo posti cosi si pu fare le prove .
 riguardo al menu me parso di aver visto 2 id menu , ripeto senza template da far le prove e un po dura .
se vuoi postare lo zip  posso vedere cosa succede.
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #7 il: 27 Apr 2009, 12:39:34 »
Certo, gentilissimo ti allego lo zip del template....

Grazie

[allegato eliminato da un amministratore perch pi vecchio di 365 giorni]

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #8 il: 27 Apr 2009, 12:57:11 »
Certo, gentilissimo ti allego lo zip del template....

Grazie

istallando il tuo template pagina binca  sicuro di sver preso tutto il template?
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #9 il: 27 Apr 2009, 13:39:52 »
Scusami sono una vera imbranata, in tutti i miei tentativi mi ero dimenticata di buttare una cartella che avevo fatto per prova e ti ho zippato quella perch si chiama allo stesso modo, scusami tanto. E' troppo grande per caricarlo qui come allegato quindi lo trovi qui: http://www.ferraguzzo.netsons.org/ferraguzzo2.zip

Scusami ancora e grazie

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #10 il: 27 Apr 2009, 15:33:21 »
domanda xche hai messo la colonna left in posizione centrale?
non hai una posizione menu ecco perche ti trovi con il menu spallato.
prova pubblicare qualcosa nel modulo left si sovrappone sul main centrale
« Ultima modifica: 27 Apr 2009, 15:49:11 da conti1 »
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #11 il: 27 Apr 2009, 16:27:31 »
Mannaggia io non me ne ero neppure accorta, forse me ne accorgevo quando mettevo il contenuto nelle news!!!  :-[
Questo il mio primo template con joomla e con i div quindi ho sicuramente pasticciato un bel po'. Ma per dare una posizione al menu con che propriet dei css lo faccio? Ad un certo punto della costruzione avevo provato a dare una posizione alla colonna left attraverso float ma la pagina mi si scombina tutta.
Devo usare float o qualcosaltro?

Grazie ancora per la pazienza

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #12 il: 28 Apr 2009, 00:31:44 »
ciao
il tuo sito sta prendendo forma
http://www.plutozio.altervista.org/
dimi che ne dici
scarica lo zip e provalo nel tuo
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #13 il: 28 Apr 2009, 01:01:26 »
Ma sei un mago!!!!!
Grazie davvero, adesso devo studiarmi il tutto! Ma mi dicevi di scaricare lo zip, da dove posso scaricarlo?

Grazie veramente di tutto

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #14 il: 28 Apr 2009, 01:05:32 »
Scusami oltre che sbadata sono anche stanca stasera e non avevo visto leggendo che me lo avevi messo proprio nel template il link.... scusami  :-[

Grazie grazie adesso scarico, leggo tutto quello che hai scritto e cerco di togliermi un po' di confusione dalla testa

Grazie davvero

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #15 il: 28 Apr 2009, 01:24:11 »
ciao lo zip lo messo nel sito  dove vedi il template

leggi il primo articolo
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Raku

  • Nuovo arrivato
  • *
  • Post: 18
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #16 il: 28 Apr 2009, 01:37:56 »
Si grazie mille poi l'ho visto come ti dicevo oltre che sbadata sono anche un po' stanca.
Adesso l'ho scaricato e provato ma in locale mi scompare del tutto il menu e tutto il contenuto si sposta a destra e non nel centro della pagina, non riesco a capire dove ho sbagliato.....  :(

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9070
  • Sesso: Maschio
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #17 il: 28 Apr 2009, 01:45:59 »
Si grazie mille poi l'ho visto come ti dicevo oltre che sbadata sono anche un po' stanca.
Adesso l'ho scaricato e provato ma in locale mi scompare del tutto il menu e tutto il contenuto si sposta a destra e non nel centro della pagina, non riesco a capire dove ho sbagliato.....  :(
appena scaricato ora lo zip che ho postato x vedere  se era corrotto  lo istallato  e vunziona anche in locale.

se intendi il menu sulla sinistra se non hai tu publicato  e logico che sparisca.
se non ti serve il menu sinistro usa questo di  php

se invece vuoi che il main centrale prenda lo spazio della colonna sinistra quando non hai pubblicato nulla  torna sul sito riscarica  lo zip io metterei quello se ti serve almeno hai una colonna sinistra


[allegato eliminato da un amministratore perch pi vecchio di 365 giorni]
« Ultima modifica: 28 Apr 2009, 03:32:39 da conti1 »
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline joomy74

  • Esploratore
  • **
  • Post: 128
  • www.andreaschilani.it
    • Mostra profilo
Re: Il mio primo template problemi di visualizzazione
« Risposta #18 il: 29 Apr 2009, 16:32:50 »
se posso offrir eil mio aiuto
http://forum.joomla.it/index.php/topic,69238.0.html forse fai prima risparmi tempo e io mi sento utile al open source
http://www.misfattimatti.it

porta avanti il mondo open source

 

Host

Torna su