Back to top

Autore Topic: Editor che non salva le modifiche sugli articoli  (Letto 3647 volte)

Offline nexus6

  • Esploratore
  • **
  • Post: 58
  • Sesso: Maschio
    • Mostra profilo
Editor che non salva le modifiche sugli articoli
« il: 27 Mag 2009, 09:22:15 »
Buona giornata.

Sperando in una risposta chiedo se ci sono esperienze o spiegazioni su questa casistica:

in un sistema su cui joomla 1.5.10 sembra funzionare (moduli che si installano, pagine che possono essere visitate) volendo editare un contenuto (articolo) l'editor mi permette di "formattarlo" (grassetto, dimensioni, a capo, etc) ma nel momento in cui vado a salvare mi compatta tutto il testo e mi cancella ogni formattazione.

Se entro in un articolo già formattato (gli esempi che joomla installa) e NON modifico nulla, se esco dall'editor cliccando su SALVA anche quell'articolo perde ogni formattazione.

Edito gli articoli come supervisore, ho abilitato nelle preferenze i supervisori come "White list", ho abilitato nell'editor (JCE) l'uso di java, ccs etc..

Ho verificato il problema utilizzando sia JCE che il tiny editor di default.

Sembra che l'editor non riesca a scrivere l'articolo quando lo salva, come un problema di files temporanei.

Joomla è installato in un ambiente che i test ufficiali joomla.org definiscono 100% compatibile, tutte le cartelle sono scrivibili (verdi), tutti i settaggi suggeriti sono attivi.

Se servono phpinfo ed altre cose specifiche le posto immediatamente
Nulla sfugge all'occhio vigile ed attento del cacciator di acqua e di valli

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Editor che non salva le modifiche sugli articoli
« Risposta #1 il: 27 Mag 2009, 09:31:20 »
Citazione
Joomla è installato in un ambiente che i test ufficiali joomla.org definiscono 100%
quale ambiente? win per caso? e quali testi?

http://docs.joomla.org/Beginners
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline nexus6

  • Esploratore
  • **
  • Post: 58
  • Sesso: Maschio
    • Mostra profilo
Re:Editor che non salva le modifiche sugli articoli
« Risposta #2 il: 27 Mag 2009, 11:19:07 »
Buona giornata.

L'ambiente è un classico LAMP (centos+apache2.2+php 2.5.9+mysql).

Ci sono diversi accounts sullo stesso server, uno dei quali funziona perfettamente con settaggi molto simili (non dico identici per non commettere errori).

Per fare delle prove ho ricreato un account ex novo SENZA installare jce editor e senza installare nessun componente se non 1 (jumi).

Ho notato che abilitando il super-administrator con l'opzione "White list" nelle preferenze di gestione dei contenuti, il problema enunciato si presenta sistematicamente, risettandolo a Black list (default) l'editor torna a funzionare e mi salva le modifiche.

Devo poter abilitare la white list almeno per il super-administrator per poter inserire degli scripts all'interno dei contributi.

Non sono un beginnes di joomla, sono un utilizzatore esperto che sta facendo il passo di crearsi un suo host proprietario su cui farlo girare.

A completamento Le allego i risultati del classico test di joomla.org per l'ambiente:

[size=90]

[/size][size=85]Diagnostic Information
Joomla! Version: Joomla! 1.5.10 Production/Stable [ Wohmamni ] 27-March-2009 23:00 GMT
configuration.php: Not Writable (Mode: 444 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.18-128.1.6.el5 ( x86_64) | Web Server: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_perl/2.0.4 Perl/v5.8.8 ( 95.211.14.237 ) | PHP Version: 5.2.9
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Writable | Max.Execution Time: 120 seconds | File Uploads:  Enabled
MySQL Version: 5.0.77-community ( Localhost via UNIX socket )

Extended Information:
SEF: Disabled (without ReWrite)  | FTP Layer: Disabled | htaccess: Not Implemented
PHP/suExec: User and Web Server accounts are the same. (PHP/suExec probably installed)
PHP Environment: API: cgi-fcgi | MySQLi: Yes | Max. Memory: 64M | Max. Upload Size: 750M | Max. Post Size: 32M | Max. Input Time: 120 | Zend Version: 2.2.0
Disabled Functions: system,popen,dl,passthru,proc_open,shell_exec
MySQL Client: 5.0.77 ( latin1 )[/size]
            

e anche questo risultato dell'altro test del server:


Joomla!
Health, Installation and Security Audit

Installation Assessment:

                                                
100%
Joomla! should install or run, with no immediate issues. Enjoy your Joomla! Experience.

Host Environment:

This is an overview of your host servers' environment.

Hostname    host.xxxxxxxxxxxxxxxxx.xxxxxx
  - Host IP Address    
  - Platform    Linux 2.6.18-128.1.6.el5 #1 SMP Wed Apr 1 09:10:25 EDT 2009
  - Architcture    x86_64
  - Username    xxxxxxxxx
  - Current Path    /home/xxxxx/public_html

The Web-Servers virtual Site IP Address ( xxxxxx ) will be your Web Site IP Address
The Document Root is most likely going to be the base of your Joomla! absolute_path variable, with any sub-directory appended to it that you have installed Joomla! into.

Web-Server Environment:

This is an oveview of the hosts Web Serving environment and configuration.

Server Version    Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_perl/2.0.4 Perl/v5.8.8
  - Host    xxxxx
  - Document Root    /usr/local/apache/htdocs
  - Site IP Address    xxxxxxxxxx
  - Server Port    80
  - Server Admin    info@xxxxx.it
  - Server Signature    

Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_perl/2.0.4 Perl/v5.8.8 Server at xxxxxxxx Port 80
  - Server Protocol    HTTP/1.1
  - Gateway Interface    CGI/1.1

PHP Environment:

This is an oveview of the hosts PHP environment and configuration.
PHP Version    5.2.9
  - Include Files    .:/usr/lib/php:/usr/local/lib/php
  - PHP API    cgi-fcgi
  - Zend Version    2.2.0

Your configuration.php is not writable. For security this is good, however, you will no longer be able to use Joomla! to modify the configuration online.

Required Settings Check:

If any of these items are highlighted in red then please take actions to correct them.

Failure to do so could lead to your Joomla! installation not functioning correctly.

PHP version >= 4.1.0    Yes (il test è vecchio e verifica e restituisce una stringa vecchia per la versione)
  - zlib compression support    Available
  - XML support    Available
  - MySQL support    Available
configuration.php    Writeable
Session save path    Writeable
( /tmp )
Recommended Settings Check:

These settings are recommended for PHP in order to ensure full compatibility with Joomla!.

However, Joomla! will still operate if your settings do not quite match the recommended
Directive    Recommended    Actual
Safe Mode:    OFF:    OFF    
Display Errors:    ON:    ON    
File Uploads:    ON:    ON    
Magic Quotes GPC:    ON:    ON    
Magic Quotes Runtime:    OFF:    OFF    
Register Globals:    OFF:    OFF    
Output Buffering:    OFF:    OFF    
Session auto start:    OFF:    OFF    
Register Globals Emulation:    OFF:    N/A    

Register Globals Emulation is a Joomla! function and can only be tested with Joomla! installed.

Se come detto servono parametri ancora più dettagliati sono a disposizione
« Ultima modifica: 27 Mag 2009, 11:26:51 da nexus6it »
Nulla sfugge all'occhio vigile ed attento del cacciator di acqua e di valli

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re:Editor che non salva le modifiche sugli articoli
« Risposta #3 il: 27 Mag 2009, 11:43:20 »
scusa ma forse sono stato travisato, i dati del server non era necessario inviarli tutti  la mia domanda era solo per verificare che non eri su un server win con quello che comporta.

torniamo al problema
Citazione
Sembra che l'editor non riesca a scrivere l'articolo quando lo salva, ......

certamente lo avrai già trovato, lo riposto solo per ricordare a me stesso che problemi simili li risolvo seguendo questa FAQ:
http://wiki.joomla.it/index.php?title=FAQ_Joomla_1.5.8#Filtraggio_del_contenuto_degli_articoli
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline nexus6

  • Esploratore
  • **
  • Post: 58
  • Sesso: Maschio
    • Mostra profilo
Re:Editor che non salva le modifiche sugli articoli
« Risposta #4 il: 27 Mag 2009, 15:20:27 »
Grazie per il link alla faq.

Credo però di non essermi espresso bene omettendo che proprio utilizzando i settaggi nelle preferenze per il gruppo superadministrator (che ho scoperto essere comunque abilitato di default) ho incontrato questo problema.

La cosa che non riesco a fare è "cancellare" la selezione salvata (blacklist o  white list) perchè non c'è la possibilità di farlo una volta
salvato (rimane almeno un'opzione selezionata.

Dal confronto tra vari joomla su vari host non noto alcuna differenza (al massimo c'è blacklist SENZA alcun tag indicato).

La formattazione del testo è sicuramente un aspetto importante, ma più importante per me poter insere del codice senza che sia "pulito" all'uscita.


Nulla sfugge all'occhio vigile ed attento del cacciator di acqua e di valli

Offline nexus6

  • Esploratore
  • **
  • Post: 58
  • Sesso: Maschio
    • Mostra profilo
Re:Editor che non salva le modifiche sugli articoli
« Risposta #5 il: 27 Mag 2009, 15:35:20 »
Come workaround ho selezionato un gruppo e l'ho assegnato alla blaklist, contando sul fatto che joomla applica solo 1 tipo di filtro per dominio, cosa che di fatto mi ha "liberato" il gruppo supervisor dal filro.

Ovviamente non è una risposta definitiva ma se per caso succede che facciate un errore nel settare un filtro (il mio primo è stato quello di selezionare white list invece che blacklist) può tornare utile
Nulla sfugge all'occhio vigile ed attento del cacciator di acqua e di valli

 



Web Design Bolzano Kreatif