Autore Topic: Configurazione SEO  (Letto 11325 volte)

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Configurazione SEO
« il: 11 Giu 2009, 10:51:25 »
Ho effettuato il cambio di Hosting con successo, ora tutto pare finalmente funzionare abbastanza correttamente.
In questi giorni stò testando il funzionamento del backup e della configurazione SEO, quest'ultima infatti, se vado per attivarla inizia a dare problemi sul sito presente sul nuovo hosting, mentre precedentemente funzionava a meraviglia.

Se attivo la voce: Friendly URL per i motori di ricerca visualizzo correttamente la home page, ma le pagine interne non vengono visualizzate e al loro posto mi compare scritta questa dicitura:
404 - Componente non trovato
Non è possibile visualizzare questa pagina a causa di:

un bookmark/preferiti scaduto
una ricerca attraverso il motore di ricerca che ha una lista scaduta per questo sito
un indirizzo compilato male
Non hai accesso a questa pagina
La risorsa richiesta non esiste
Si è verificato un errore durante l'esecuzione della tua richiesta.
Prova una delle seguenti pagine:


Home Page

Se persistono delle difficoltà, contatta l'Amministratore di questo sito.

Componente non trovato

Se attivo solamente "Aggiungi il suffisso agli URL" e "Utilizza mod_rewrite" tutto pare funzionare correttamente, ma se attivo come già detto "Friendly URL per i motori di ricerca" nulla mi funziona.

aspetto un vostro consiglio
sperando che tutto possa risolversi per il meglio.
Grazie
Alixys

Offline gugu

  • Esploratore
  • **
  • Post: 99
    • Mostra profilo
Re:Configurazione SEO
« Risposta #1 il: 11 Giu 2009, 12:06:02 »
Sarei interessato anche io alle risposte!

Offline nellocammar

  • Appassionato
  • ***
  • Post: 678
  • Sesso: Maschio
    • Mostra profilo
Re:Configurazione SEO
« Risposta #2 il: 11 Giu 2009, 12:38:57 »
lascia la configurazione seo come si trova,prima   fai ricerche sul forum trovi miriadi di soluzioni e guide per ottimizzare e settare joomla. per i motori di ricerca l'utente Odino e' un maestro, cerca i suoi articoli che facciano riferimento ai seo.
segui questa guida nei punti dell'installazione del componente per creare una sitemap e di creare un account google per l'aggiunta di tale sitemap

http://bsaett.altervista.org/docman/view-document-details/4-ottimizzare-joomla-per-i-motori-di-ricerca.html

poi segui i punti di come ottimizzare un articolo con parole chiave titolo etc...
sono importanti i contenuti, piu' articoli hai attinenti al sito e ben settati e piu' verrai indicizzato.
La guida e' molto chiara leggila bene, non avere fretta google ci mette un po a visitare il sito. Evita di cambiare parole chiave e titolo perche ancora non sei visualizzato nei motori come vorresti e soprattutto finisci tutti i tuoi articoli e le varie compilazioni per l'indicizzazione prima di creare e inserire una sitemap.
“Dobbiamo davvero inchinarci davanti ai resti di quelli che furono i leoni della Folgore…”

Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #3 il: 11 Giu 2009, 14:24:38 »
che versione di PHP ha il nuovo hosting?

edit: grazie nello

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #4 il: 11 Giu 2009, 14:41:20 »
che versione di PHP ha il nuovo hosting?

edit: grazie nello



PHP V. 5.2.9
« Ultima modifica: 11 Giu 2009, 16:39:34 da Alixys »

Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #5 il: 11 Giu 2009, 16:04:33 »
N O N  S I  F A N N O  R I F E R I M E N T I  C O M M E R C I A L I

dopo 90 messaggi lo si dovrebbe capire, no? che dici?

Edita il tuo messaggio...

Comunque non è il PHP, allora postami l'url che ti viene generata ( sulla stessa pagina, ad esempio quella dei contatti ) con:

1. tutto il SEF disabilitato

2. Sef si, htaccess no, suffissi no

3. sef si, htaccess si, suffissi no

4. tutto attivato

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #6 il: 11 Giu 2009, 16:48:16 »
non ti ho capito.

nella configurazione di joomla posso configurare questi paramentri che attualmente sono così impostati.

Friendly URL per i motori di ricerca (disattivato)
Utilizza mod_rewrite (attivo)
Aggiungi il suffisso agli URL (attivo)

così il sito funziona regolarmente.

se attivo anche quella disabilitata mi compare la scritta: "siamo spiacenti ma il link selezionato è inesistente".

se disabilito le voci attive e attivo solamente la Friendly URL mi appare:
404 - Componente non trovato
Non è possibile visualizzare questa pagina a causa di:

un bookmark/preferiti scaduto
una ricerca attraverso il motore di ricerca che ha una lista scaduta per questo sito
un indirizzo compilato male
Non hai accesso a questa pagina
La risorsa richiesta non esiste
Si è verificato un errore durante l'esecuzione della tua richiesta.
« Ultima modifica: 11 Giu 2009, 16:51:27 da Alixys »

Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #7 il: 11 Giu 2009, 16:58:02 »
SI, ma anche quella pagina ha un URL, per cui postamela.

E postami le url delle pagine ( che andanno in errore, ok... ) con le configurazioni che ti ho indicato

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #8 il: 11 Giu 2009, 17:52:30 »
SI, ma anche quella pagina ha un URL, per cui postamela.

E postami le url delle pagine ( che andanno in errore, ok... ) con le configurazioni che ti ho indicato

tutto disabilitato: http://www.abruzzonatura.com/cascatedelverde/

oppure anche:
http://www.abruzzonatura.com/cascatedelverde/index.php?option=com_content&view=frontpage&Itemid=67&lang=it

Sef si, htaccess no, suffissi no
http://www.abruzzonatura.com/cascatedelverde/index.php/it/home

sef si, htaccess si, suffissi no
http://www.abruzzonatura.com/cascatedelverde/index.php/it/home

tutto attivato:
http://www.abruzzonatura.com/cascatedelverde/index.php/it/home




Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #9 il: 12 Giu 2009, 11:17:09 »
disabilita joomfish ( e per favore vedi se riesci a darmi delle url che non siano della homepage  :) )

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #10 il: 14 Giu 2009, 14:37:40 »
disabilita joomfish ( e per favore vedi se riesci a darmi delle url che non siano della homepage  :) )

Di joomfish in un prossimo futuro ne avrò bisogno; cmq ho disabilitato il modulo.

SEO Tutto Attivato (ma non funziona)
http://www.abruzzonatura.com/cascatedelverde/it/la-fauna-della-riserva.html

SEO Tutto attivato esclusa la voce Friendly URL per i motori di ricerca.
http://www.abruzzonatura.com/cascatedelverde/index.php?option=com_content&view=article&id=99&Itemid=70&lang=it

Tutto disattivato
http://www.abruzzonatura.com/cascatedelverde/index.php?option=com_content&view=article&id=98&Itemid=82&lang=it


aspetto tue
grazie

Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #11 il: 14 Giu 2009, 15:23:41 »
disabilita joomfish ( e per favore vedi se riesci a darmi delle url che non siano della homepage  :) )

Di joomfish in un prossimo futuro ne avrò bisogno; cmq ho disabilitato il modulo.

SEO Tutto Attivato (ma non funziona)
http://www.abruzzonatura.com/cascatedelverde/it/la-fauna-della-riserva.html

SEO Tutto attivato esclusa la voce Friendly URL per i motori di ricerca.
http://www.abruzzonatura.com/cascatedelverde/index.php?option=com_content&view=article&id=99&Itemid=70&lang=it

Tutto disattivato
http://www.abruzzonatura.com/cascatedelverde/index.php?option=com_content&view=article&id=98&Itemid=82&lang=it


aspetto tue
grazie

disabilita per favore joomfish, vedi che le url contengono riferimenti alla categoria?

Disabilita JF, attiva tutto il seo e facci sapere.

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #12 il: 14 Giu 2009, 15:36:11 »
si, ho disabilitato il modulo ma il problema continua...

ora mi sn accorto che andando nel pannello di controllo di joomfish mi appare quest'altro problema.

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /web/htdocs/www.abruzzonatura.com/home/cascatedelverde/administrator/components/com_joomfish/classes/JCacheStorageJFDB.php on line 52
« Ultima modifica: 14 Giu 2009, 15:41:24 da Alixys »

Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #13 il: 14 Giu 2009, 15:50:13 »
si, ho disabilitato il modulo ma il problema continua...

ora mi sn accorto che andando nel pannello di controllo di joomfish mi appare quest'altro problema.

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /web/htdocs/www.abruzzonatura.com/home/cascatedelverde/administrator/components/com_joomfish/classes/JCacheStorageJFDB.php on line 52

Non il modulo anche il componente e relativi plugin, non vedi che nelle URL permangono i riferimenti alla lingua?

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #14 il: 14 Giu 2009, 16:10:38 »
ora l'ho proprio disinstallato anche perchè nn funzionava più, cmq come potrai vedere il problema persiste :(

Ho provato a reinstallarlo ma joomfish continua a non voler funzionare...continua a darmi l'errore di prima! ...ora sono 2 le cose che non funzionano  :'(
« Ultima modifica: 14 Giu 2009, 17:11:02 da Alixys »

Offline gugu

  • Esploratore
  • **
  • Post: 99
    • Mostra profilo
Re:Configurazione SEO
« Risposta #15 il: 15 Giu 2009, 11:48:29 »
Ho provato a reinstallarlo ma joomfish continua a non voler funzionare...continua a darmi l'errore di prima! ...ora sono 2 le cose che non funzionano  :'(

Si, JoomFish è alquanto rognosetto da disinstallare.. ci avevo speso qualche ora tempo fa per risolvere i problemi seguiti alla imperfetta disintallazione (a me era scomparso il front-end).
Pare d'altronde sia un problema risaputo e per cui c'è un 'trucco' a disposizione: si trattava di cancellare manualmente un file di JoomFish dal server PRIMA di procedere alla disinstallazione.
Dunque dovresti re-installare -> cancellare file -> disinstallare nuovamente.
Purtroppo non ho conservato link alla procedura, ma se non ricordo male l'avevo trovata nel forum ufficiale di JoomFish.

Offline = odino =

  • Instancabile
  • ******
  • Post: 5696
  • Sesso: Maschio
  • "In realtà li trasforma in menomati" Danzel
    • Mostra profilo
Re:Configurazione SEO
« Risposta #16 il: 15 Giu 2009, 12:17:09 »
Hai modificato la riga

Codice: [Seleziona]
# RewriteBase /
dell'htaccess?

Offline gugu

  • Esploratore
  • **
  • Post: 99
    • Mostra profilo
Re:Configurazione SEO
« Risposta #17 il: 16 Giu 2009, 10:55:55 »
Hai modificato la riga

Codice: [Seleziona]
# RewriteBase /
dell'htaccess?

Non so se la domanda fosse rivolta a me o meno, ma nel caso potesse interessare, credo che la procedura da me seguita tempo fa per risolvere con JoomFish, fosse questa

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #18 il: 17 Giu 2009, 17:00:11 »
Hai modificato la riga

Codice: [Seleziona]
# RewriteBase /
dell'htaccess?

No, non ho modificato nulla.

quale riga dovrei modificare e cosa dovrei inserire?

la modifica risolverebbe il problema SEO o il problema di JoomFish?

Grazie

Offline Alixys

  • Appassionato
  • ***
  • Post: 215
    • Mostra profilo
Re:Configurazione SEO
« Risposta #19 il: 20 Giu 2009, 14:30:27 »
chi mi dice qualcosA??

 

Host

Torna su