Autore Topic: Problema joomla e ccnewsletter  (Letto 12624 volte)

Offline ziolambrusco

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Problema joomla e ccnewsletter
« il: 25 Gen 2009, 15:51:58 »
Salve a tutti, sono nuovo del forum.

Ho installato il componente ccNewsLetter e sto riscontrando dei problemi.
Come mai quando un utente si registra alla newsletter gli arriva il messaggio di attivazione ma non il link dove attivare l'account???
ho inserito nel corpo della mail
Codice: [Seleziona]
[activate link].
Altro problema che se ho un utente disabilitato perch gli arrivano lo stesso le newsletters? ???
Qualcuno sa darmi qualche spiegazione in merito???

Grazie a tutti!!!!!!

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #1 il: 25 Gen 2009, 16:49:06 »
ma quale account dovrebbe attivare? l'utente si iscritto quindi tu sei autorizzato a mandargli la tua newsletter, almeno fino a quando non ci cancella, questo fa quel componente, punto.

arriva anche ai disattivati e anche ai non registrati, sono due componenti diversi, con tabelle di utenti diversi perch gli standard internazionali sulla privacy e sul servizio di posta, non consentono l'invio di mail a chi si registra ad un sito, ma solo a chi esprime una richiesta espressa a riprova documentata e documentabile del suo consenso informato.
« Ultima modifica: 25 Gen 2009, 16:55:53 da 56francesco »
(uso XP perch win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline Francky

  • Nuovo arrivato
  • *
  • Post: 13
  • Sesso: Maschio
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #2 il: 26 Gen 2009, 22:25:21 »
Anche io ho lo stesso problema, quando imposto la mail di conferma iscrizione, il messaggio arriva senza il link di conferma o cancellazione, l'utente rimane disattivato e lo si pu attivare dal pannello di ccnewsletter, ma non si ha la vera conferma da parte sua.
Quando invece inserisco il link di cancellazione nella newsletter il link sembra corretto.
Qualche idea?
Grazie

Offline biofrost

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #3 il: 27 Gen 2009, 17:55:47 »
ciao a tutti, sono nuovo di joomla, ho insatllato anche io questo modulo e mi da 2 problemi che ritengo importanti:

1) dall'amministrazione non cancella gli iscritti.

2) non crea i link nella mail di conferma di avvenuta iscrizione che permettano all'iscritto di essere attivato, in pratica se qualcuno si iscrive con un falso indirizzo la newsletter non pu n chiedergli conferma, e quindi evitare l'attivazione del falso indirizzo, n come dicevo nel punto 1, darmi modo di cancellarlo, stress.

Ho visto che altri hanno il mio problema, la soluzione davvero non c'? mi pare una cosa rilevante per un modulo di newsletter.

Grazie ed a presto.

Offline tgalex

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #4 il: 01 Feb 2009, 01:20:37 »
Come mai quando un utente si registra alla newsletter gli arriva il messaggio di attivazione ma non il link dove attivare l'account???
ho inserito nel corpo della mail
Codice: [Seleziona]
[activate link].
Altro problema che se ho un utente disabilitato perch gli arrivano lo stesso le newsletters? ???
Qualcuno sa darmi qualche spiegazione in merito???
Grazie a tutti!!!!!!

Spero di esordire ( il mio primo post qui) con una soluzione alla tua domanda  :)
Sbattendoci la testa ho capito che se come me hai installato la lingua italiana del modulo, anche i codici da inserire nei corpi delle mail sono differenti come riportato nelle istruzioni delle singole schede; quindi nel tuo caso (ma anche nel mio)
Codice: [Seleziona]
[activate link] diventa in italiano
Codice: [Seleziona]
[link di attivazione] cos come
Codice: [Seleziona]
[unsubscribe link] diventa nella nostra lingua
Codice: [Seleziona]
[link di annullo iscrizione] Ciao,
  Alex

Offline grafikoris

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #5 il: 04 Feb 2009, 15:24:38 »
per quanto riguarda il problema della NON CANCELLAZIONE degli utenti dall'amministrazione ccnewsletter (errato funzionamento del pulsante cancella). Abbiamo risolto... il problema si presentava nel file "it-IT.com_ccnewsletter.ini" NELLA CARTELLA "administrator/language/it-IT".

Praticamente i traduttori avevano lasciato delle virgolette che creavano problemi con il codice javascript, la soluzione che abbiamo adottato (alla riga 79 del suddetto file) quella di sostituire le due virgolette presenti con un doppio apice.. ecco l'esempio allegato (zippato).. se qualcuno vuole provare.. raccomandiamo di farsi una copia del vecchio files ini originale cos potete tornare indietro..

ciao

[allegato eliminato da un amministratore - Il file era vecchio]

Offline eliofras

  • Nuovo arrivato
  • *
  • Post: 2
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #6 il: 26 Feb 2009, 18:37:46 »
Come mai quando un utente si registra alla newsletter gli arriva il messaggio di attivazione ma non il link dove attivare l'account???
ho inserito nel corpo della mail
Codice: [Seleziona]
[activate link].
Altro problema che se ho un utente disabilitato perch gli arrivano lo stesso le newsletters? ???
Qualcuno sa darmi qualche spiegazione in merito???
Grazie a tutti!!!!!!

Spero di esordire ( il mio primo post qui) con una soluzione alla tua domanda  :)
Sbattendoci la testa ho capito che se come me hai installato la lingua italiana del modulo, anche i codici da inserire nei corpi delle mail sono differenti come riportato nelle istruzioni delle singole schede; quindi nel tuo caso (ma anche nel mio)
Codice: [Seleziona]
[activate link] diventa in italiano
Codice: [Seleziona]
[link di attivazione] cos come
Codice: [Seleziona]
[unsubscribe link] diventa nella nostra lingua
Codice: [Seleziona]
[link di annullo iscrizione] Ciao,
  Alex


Anche io non riesco ad usare il LINK DI ATTIVAZIONE. Quando viene inviata la email di iscrizione, inserisco il link di conferma usando  [link di attivazione]  ma al destinatario compare tale scritta senza nessun link. Non si riesce a confermare quindi l'iscrizione. Qualcuno pu aiutarmi a risolvere il problema ?

Cosa diversa invece per la cancellazione dove il link [link di annullo iscrizione] funziona correttamente.

Offline Oidelon

  • Nuovo arrivato
  • *
  • Post: 10
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #7 il: 04 Mar 2009, 15:57:04 »
Ciao a tutti! Io ho installato CCnewsletter con Joomla ver. 1.5.9 ma ho qualche problema. Ho sistituito come suggerito il file della lingua e il problema della cancellazione degli utenti stato risolto. Adesso ho il problema dei link di attivazione e disattivazioen che non funzionano. Ad esempio, nell'email che arriva a chi si iscrive per la conferma dell'attivazione, il nome viene inserito correttamente ma i due link per attivazione e disattivazioe no... mi compare direttamente la scritta [link di annullo iscrizione] e [link di attivazione]. Sbaglio io qualcosa? Grazie dell'aiuto, buona giornata

Offline breevido

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #8 il: 15 Mar 2009, 09:22:34 »
Stesso identico problema... ho provato anche a fare il tutto dal pannello di amministrazione in lingua inglese.. ma il risultato non cambia.

E non e' un bug da poco..

Cambiare componente??
« Ultima modifica: 15 Mar 2009, 09:28:58 da breevido »

Offline Nikotra

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
[RISOLTO] Re: Problema joomla e ccnewsletter
« Risposta #9 il: 22 Mar 2009, 01:47:46 »
Credo di avere risolto, e' anche in questo caso un problema di traduzione. La sostanza e' che nei due file con i testi in lingua, quello lato admin e quello lato client, le due parole chiave/variabili :
CC_ACTIVATION_LINK e
CC_UNSUBSCRIBE_LINK
Devono essere valorizzate in entrambi i file con lo stesso testo, incluse maiuscole e minuscole. Altrimenti il codice non riesce a sostituire il testo tra parentesi quadre quando costruisce i link.
In questo modo direi che siamo/siete/sono a cavallo. Ciao a tutti

Offline Hellsan

  • Nuovo arrivato
  • *
  • Post: 7
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #10 il: 27 Mar 2009, 13:29:08 »
Ciao...
scusa potresti elencare il percorso dei file dove trovare queste due voci?
Grazie...

Offline maisotti

  • Esploratore
  • **
  • Post: 172
  • Sesso: Maschio
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #11 il: 03 Apr 2009, 16:01:01 »
 ;D
Grazie anche da parte mia. Avevo lo stesso problema e l'ho risolto
La tendenza alla normalit va curata.
(Frank Zappa)

Offline maxximiliano

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #12 il: 09 Apr 2009, 20:16:50 »
Ciao a tutti anke io ho problemi con ccnewsletter, ma il mio problema che le mail non le invia proprio ne invia una sola a me amministratore potete aiutarmi grazie.

Offline slf

  • Appassionato
  • ***
  • Post: 252
    • Mostra profilo
Re: [RISOLTO] Re: Problema joomla e ccnewsletter
« Risposta #13 il: 16 Apr 2009, 17:30:49 »
Credo di avere risolto, e' anche in questo caso un problema di traduzione. La sostanza e' che nei due file con i testi in lingua, quello lato admin e quello lato client, le due parole chiave/variabili :
CC_ACTIVATION_LINK e
CC_UNSUBSCRIBE_LINK
Devono essere valorizzate in entrambi i file con lo stesso testo, incluse maiuscole e minuscole. Altrimenti il codice non riesce a sostituire il testo tra parentesi quadre quando costruisce i link.
In questo modo direi che siamo/siete/sono a cavallo. Ciao a tutti

grazie alla tua dritta sono riuscito a risolvere proprio un secondo prima di disinstallare il componente!!  ;D

grazie 1000!

Offline magicfix

  • Esploratore
  • **
  • Post: 87
    • Mostra profilo
Re: Problema joomla e ccnewsletter
« Risposta #14 il: 17 Apr 2009, 14:27:47 »
Ciao...
scusa potresti elencare il percorso dei file dove trovare queste due voci?
Grazie...

Allora una voce in:
\language\it-IT\it-IT.com_ccnewsletter.ini

l'altra :
\administrator\language\it-IT\it-IT.com_ccnewsletter.ini

Spero di esser stato d'aiuto.
Saluti

Offline atman

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Re:Problema joomla e ccnewsletter
« Risposta #15 il: 17 Mag 2009, 01:32:00 »
perfetto grazie  ;D

Offline cave80

  • Nuovo arrivato
  • *
  • Post: 24
    • Mostra profilo
Re:[RISOLTO] Re: Problema joomla e ccnewsletter
« Risposta #16 il: 22 Mag 2009, 23:21:49 »
Credo di avere risolto, e' anche in questo caso un problema di traduzione. La sostanza e' che nei due file con i testi in lingua, quello lato admin e quello lato client, le due parole chiave/variabili :
CC_ACTIVATION_LINK e
CC_UNSUBSCRIBE_LINK
Devono essere valorizzate in entrambi i file con lo stesso testo, incluse maiuscole e minuscole. Altrimenti il codice non riesce a sostituire il testo tra parentesi quadre quando costruisce i link.
In questo modo direi che siamo/siete/sono a cavallo. Ciao a tutti

Non capisco cosa intendi scusa....io in entrambi i file ho le due voci:

CC_ACTIVATION_LINK=link attivazione
CC_UNSUBSCRIBE_LINK=link rimozione

eppure quando nella newsletter metto [link rimozione] quando mi mando il test ricevo esattamente la scritta cos com' senza il link.....cosa dovrei editare dentro i txt?

Grazie

Offline giuggiola

  • Nuovo arrivato
  • *
  • Post: 33
  • Sesso: Femmina
    • Mostra profilo
Re:Problema joomla e ccnewsletter
« Risposta #17 il: 04 Ago 2009, 09:05:32 »
Ciao a tutti,
potreste postare i 2 file della lingua completi di correzioni?
Nella cartella del componente che ho scaricato non li ho trovati...
Grazie
Ciao

 

Host

Torna su