Back to top

Autore Topic: OpenSEF - Problema  (Letto 3601 volte)

Offline Claudio

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
OpenSEF - Problema
« il: 18 Lug 2006, 09:49:51 »
Ciao a tutti, spero di aver postato nel posto giusto per questo problema. In caso contrario prego il moderatore di indicarmi dove postare.

Mi sto sbattezzando con OpenSEF 2.0.0-RC5 ma non riesco a farlo funzionare; ho seguito anche alla lettera le indicazioni (tra l'altro molto ben fatte) postate in questo thread, http://www.joomla.it/index.php?option=com_smf&Itemid=128&topic=5054.0, ma niente!

Gli indirizzi vengono effettivamente abbrviati, ma quando vado per provarne il funzionamento, non va niente (vedi pagina di errore in allegato).
Ad esempio la pagina dei contatti, l'ho abbreviata in trade-online.it/contatti, ma se ci clicco ....nada!

Mi dite dove sbaglio o cos'altro devo settare?

Grazie mille!

[allegato eliminato da un amministratore]
La mente è come un paracadute: ti salvi solo quando è aperta!

www.trade-online.it

Offline Claudio

  • Nuovo arrivato
  • *
  • Post: 41
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #1 il: 18 Lug 2006, 14:40:52 »
Ho spippolato un pò per escludere alcuni fattori che possono causare tale problema.
Ho disattivato OpenSEF e ho lasciato abilitato solamente il SEO nella configurazione globale di Joomla (backend)...non funziona comunque!

Quindi non dipende dall'OpenSEF ma deve essere un problema sicuramente legato al file .htaccess.

Ho seguito tutte le guide ed i consigli presenti sul Forum riguardo alla modifca del file htaccess.txt in .htaccess...non so più che fare. E' essenziale che riesca a far funzionare i Friendly URL.

Il file .htaccess, l'ho modificato, secondo le guide che ho trovato, in questo modo:

##
# @version $Id: htaccess.txt 1570 2005-12-29 05:53:33Z eddieajau $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#
# mod_rewrite in use
#

# RewriteEngine On

##
## NOTE!
## When using multiple Joomla sites or other web applications in sub-folders,
## you must explicitly turn the RewriteEngine off or use the settings
## recommended for the application
##

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update YourJoomlaDirectory (just / for root)

# RewriteBase /

#
# Rules
#

# RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
# RewriteCond %{REQUEST_FILENAME} !-f
# RewriteCond %{REQUEST_FILENAME} !-d
# RewriteRule ^(.*) index.php

Se vado sulla pagina principale funziona; non funziona quando vado a cliccare sui link modificati con il SEO. ???
La mente è come un paracadute: ti salvi solo quando è aperta!

www.trade-online.it

Offline qbert

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #2 il: 08 Ago 2006, 15:41:12 »
Mi accodo anche io ai problemi sull'utilizzo di Opensef.
Io utilizzo joomla 1.0.10 stable e OpenSEF 2.0.0-RC5 SP2.
Anche io ho smanettato un pochino ma nn sono riuscito a farlo funzionare in nessun modo.
I link mi vengono cambiati, ma con delle url che nn corrsipondono con quelle da me inserite nelle "Friendly URLs", con la conseguenza che ricevo "not found" quando clicco sui link cambiati.
Ho provato abilitando SEO oppure no ma nn cambia niente.

Qualcuno che riesce a farlo funzionare mi può dire quali passi seguire o darmi qualche dritta ?

Grazie a tutti.

Offline rays84

  • Esploratore
  • **
  • Post: 161
  • Sesso: Maschio
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #3 il: 08 Ago 2006, 15:53:26 »
io se cambio htaccess.txt in .htaccess mi da errore, neanche mi fa vedere l'homepage ???

non so piu' che fare

premesso che ancora sono in locale.....

Offline qbert

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #4 il: 10 Ago 2006, 22:24:37 »
Riporto in UP la discussione.
Rimango speranzoso  :)

Offline grigoa

  • Abituale
  • ****
  • Post: 1952
  • Sesso: Maschio
  • Joomla is a passion
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #5 il: 11 Ago 2006, 09:07:44 »
Non riesco veramente a capire.......  :-X
L'unico dubbio che mi assale è legato al fatto che siete entrambi in localhost.....
Se avete seguito la guida di Ferraresi dovrebbe funzionare tutto.....  :-\
L'erba voglio non cresce neppure
nel giardino del re
www.erbavoglio.info

Offline qbert

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #6 il: 11 Ago 2006, 13:32:12 »
Grazie dell'intervento  ;)
Io ho tutto online, nn sono il locale.

Ciao

Offline qbert

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #7 il: 12 Ago 2006, 14:05:15 »
Chiedo venia a tutti e mi cospargo il capo di cenere.
Rileggendo la guida del buon Ferraresi vedevo che dovevo rinominare il file htaccess.txt in .htaccess...e non in .htaccess.txt  :P

Adesso modificato il file ha cominciato a funzionare ma non in maniera completa.
Ovvero alcune pagine vengono rinominate come vuole il modulo...es:
anzieché /index.php?com_xxxxxx...
così /component/option,com_search/Itemid,5/

Alcuni di questi link dopo due/tre click prendono magicamente il link ripulito da me.
Altri, pur funzionando, continuano a rimanere non ripuliti con quello scritto da me in "Friendly URLs"

Solo un link effettivamente non funziona per niente, nel senso che reindirzza da tutt'altra parte.

Altra domanda non capisco come funzioni effettivamente opensef, nel senso che nella lista "Friendly URLs" si creano indirizzi che io nn ho inserito, quindi il modulo qualcosa la fa di sua iniziativa.

Attendo vostre delucidazioni, grazie come sempre e buon ferragosto a tutti.

Offline rays84

  • Esploratore
  • **
  • Post: 161
  • Sesso: Maschio
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #8 il: 12 Ago 2006, 16:14:08 »
ma per capire...in locale questo componente funziona o no? a me dopo la modifica del file htaccess.txt in .htaccess non funziona più nulla

Offline qbert

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #9 il: 24 Ago 2006, 23:15:55 »
any news ?  ;D

Offline ferraresi_4ever

  • Appassionato
  • ***
  • Post: 492
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #10 il: 25 Ago 2006, 09:29:42 »
Chiedo venia a tutti e mi cospargo il capo di cenere.
Rileggendo la guida del buon Ferraresi vedevo che dovevo rinominare il file htaccess.txt in .htaccess...e non in .htaccess.txt  :P

Adesso modificato il file ha cominciato a funzionare ma non in maniera completa.
Ovvero alcune pagine vengono rinominate come vuole il modulo...es:
anzieché /index.php?com_xxxxxx...
così /component/option,com_search/Itemid,5/

Alcuni di questi link dopo due/tre click prendono magicamente il link ripulito da me.
Altri, pur funzionando, continuano a rimanere non ripuliti con quello scritto da me in "Friendly URLs"

Solo un link effettivamente non funziona per niente, nel senso che reindirzza da tutt'altra parte.

Altra domanda non capisco come funzioni effettivamente opensef, nel senso che nella lista "Friendly URLs" si creano indirizzi che io nn ho inserito, quindi il modulo qualcosa la fa di sua iniziativa.

Attendo vostre delucidazioni, grazie come sempre e buon ferragosto a tutti.

Certo ... a seconda delle impostazioni il componente associa ad una certa pagina un url che puo essere tratto o dal titolo del contenuto joomla ... ad esempio www.sito.com/titolocontenuto.php/html ... o a seconda della categoria : www.sito.com/cat1/contenuto2 ... o qualcosa di simile se non sbaglio

Offline Gaetano Portiero

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #11 il: 25 Ago 2006, 09:47:18 »
ciao a tutti ho installato OpenSef e non mi da nessun problema a parte che quando sono nella Home e apro un altro collegamento il link mi si apre correttamente modificato però mi mette due // dopo il dominio, oppure quando sono in un altro link e devo tornare alla Home Page cliccando sul link mi da come collegamento http:///. Come devo risolvere??

Disattivando OpenSef il tutto funziona ma senza i link modificati..

Offline qbert

  • Nuovo arrivato
  • *
  • Post: 12
    • Mostra profilo
Re: OpenSEF - Problema
« Risposta #12 il: 25 Ago 2006, 10:04:36 »

Certo ... a seconda delle impostazioni il componente associa ad una certa pagina un url che puo essere tratto o dal titolo del contenuto joomla ... ad esempio www.sito.com/titolocontenuto.php/html ... o a seconda della categoria : www.sito.com/cat1/contenuto2 ... o qualcosa di simile se non sbaglio

Grazie dell'intervento, però non capisco se sia un comportamento di OpenSef normale e che quindi non posso fare niente per ovviare ed avere tutti i link modificati.
In più ho notato che, nella home, alcuni link sono modificiati come da me impostati. Se lascio la home page, i "Friendly URLs" non sono più come da me impostati.
Anche questo è normale...o c'è qualcosa che non va o va impostato in modo particolare ?

Grazie ancora

 



Web Design Bolzano Kreatif