Back to top

Autore Topic: Xmap ed errore Google  (Letto 7438 volte)

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Xmap ed errore Google
« il: 02 Ago 2009, 13:01:39 »
Salve ragazzi, su un sito sto utilizzando xmap per generare dinamicamente la sitemap, ho inviato a google la sitemap generata attraverso strumenti per i webmaster e fin qui tutto ok.
Da qualche giorno sempre accedendo agli strumenti per webmaster noto una bella X rossa sulla sitemap xml generata da xmap con la seguente scritta da parte di google:"Questo URL è un duplicato di un altro URL nella Sitemap. Rimuovilo e invia nuovamente la Sitemap." e per tre volte viene indicato l'url assoluto del sito ovvero quello che richiama l'home page.

In più ho caricato altre due sitemap oltre a quella generale gestita da xmap, le due sitemap in questione sono all'interno di due cartelle e dovrebbero indicizzare altre pagine html, il problema è che mentre una è perfettamente a posto e gli url sono già stati indicizzati, l'altra è ok ma nessun url è stato ancora indicizzato e intanto sono già passate 3 settimane. Qualcuno riesce a darmi delucidazioni in merito?
Creatore e Ideatore di Aghape Ambiente

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #1 il: 06 Ago 2009, 15:43:32 »
Quindi nessuno ne ha idea?

Almeno sapete dirmi perchè nonostante la sitemap non abbia errori (stando a quanto dice google) gli url non sono ancora stati indicizzati dopo quattro settimane??
Creatore e Ideatore di Aghape Ambiente

Offline dadelinux

  • Nuovo arrivato
  • *
  • Post: 5
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #2 il: 06 Ago 2009, 20:45:31 »
E' un bug di Xmap! Devi aggiornare Xmap all'ultima versione.
Xmap 1.2.2: This release fixed the problem with duplicated URLs included in the XML sitemap causing the sitemaps being rejected by Google. Is strongly recommended to upgrade to this new version.

Ciao
Davide

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #3 il: 08 Ago 2009, 21:35:54 »
Si ma a prescindere vorrei sapere perchè cavolo non mi indicizza le pagine di una sitemap che non ha errori...sono 5 settimane che è inviata ed è ok con 0 url indicizzati.

In più ho fatto un blog con wordpress attaccandolo ad un sito joomla, installato la google sitemap generator per il blog e utilizzato permalink ottimizzati e non mi indicizza na pippa.. ma che cavolo sta succedendo???!
Creatore e Ideatore di Aghape Ambiente

Offline bighe

  • Esploratore
  • **
  • Post: 175
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #4 il: 08 Ago 2009, 22:16:41 »
Ma tu hai fatto l'aggiornamento che ti hanno consigliato?

se hai la x rossa non può caricarle perché c'è un problema e possono passere anche tre anni che non cambia nulla.

Al limite manda un'istantanea, ma sempre dopo aver fatto l'aggiornamento.

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #5 il: 08 Ago 2009, 23:08:24 »
Forse non ci siamo capiti o non hai letto bene quanto ho scritto sopra.

Il problema della sitemap non indicizzata non è quella di xmap.

Allora ri-spiego un'ultima volta così vediamo se sono + chiaro:

Ho un sito in joomla con relativa sitemap dinamica fatta con xmap aggiornato alla 1.2.2 come consigliato ed è tornata a funzionare e tutto ok.

Oltre a ciò sempre sotto la stessa root del sito ho creato due cartelle all'interno delle quali ci sono delle pagine html, relativi fogli di stile e relative sitemap .xml

Entrambe sono state segnalate a google (oltre a quella del sito generata con xmap chiaramente) tramite "strumenti x webmaster", mentre 1 funziona bene e gli url sono stati indicizzati, l'altra è stata inviata 5 settimane fà, status ok da parte di google (quindi no errori/avvisi rilevati) ma url indicizzati 0.

Stessa cosa x il blog di wordpress che ha anch'esso una sua sitemap generata con un plugin (google sitemap generator for wp) e che è attaccato al suddetto sito. E' più chiaro ora?!

Se non sono stato sufficientemente chiaro obiettate pure.
Creatore e Ideatore di Aghape Ambiente

Offline bighe

  • Esploratore
  • **
  • Post: 175
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #6 il: 09 Ago 2009, 15:41:59 »
Facciamo un po di ordine.

1) Dadelinux ti ha suggerito una soluzione e non hai risposto se avevi fatto l'aggiornamento proposto. Non mi sembra corretto nei confronti di una persona che mette a disposizione il suo tempo e non da un senso logico alla risoluzione di un problema.

2) nel tuo primo posto ha scritto:
Da qualche giorno sempre accedendo agli strumenti per webmaster noto una bella X rossa sulla sitemap xml generata da xmap con la seguente scritta da parte di google:"Questo URL è un duplicato di un altro URL nella Sitemap. Rimuovilo e invia nuovamente la Sitemap." e per tre volte viene indicato l'url assoluto del sito ovvero quello che richiama l'home page.

e poi mi rispondi:

Ho un sito in joomla con relativa sitemap dinamica fatta con xmap aggiornato alla 1.2.2 come consigliato ed è tornata a funzionare e tutto ok.

non abbiamo la sfera di cristallo....

3) IMPARA ad avere PAZIENZA. Premesso che ora sia tutto a posto con l'invio delle sitemap e che tu non abbia altri errori evidenziati, non basta spingere un bottone per avere tutte le pagine indicizzate su Google & c. Ci sono tempi più o meno lunghi per l'indicizzazione, in funzione di una quantità enorme di variabili, a partire dall'anzianità delle pagine e del sito. Da quanto tempo sono state fatte le tue pagine? Hai links che puntano verso le tue pagine e in che quantità e da quale siti?

Concludendo: le sitemaps sono solo uno dei tanti strumenti da utilizzare per l'indicizzazione e fare ed inviare una sitemap non significa avere automaticamente risultati. Se le tue pagine e il tuo sito hanno pochi links che puntano a loro, mi sembra una situazione piuttosto normale.


Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #7 il: 11 Ago 2009, 02:40:17 »
senti: punto primo rispondo quando posso e punto secondo non è corretto cosa?!, io non sono qui a fare polemica e nemmeno a trovar da dire x forza con qualcuno (nel qual caso tu). quindi chiedo scusa se ho avuto modi maldestri (sempre che li abbia avuti) ma non mi pare che questo debba scatenare problemi. se poi hai qualcosa da dirmi magari me lo dici in pvt senza piantare lezioni in pubblico che non mi sembra il caso.
Creatore e Ideatore di Aghape Ambiente

Offline taolo

  • Global Moderator
  • Instancabile
  • *****
  • Post: 3651
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #8 il: 11 Ago 2009, 02:47:30 »
emmm..  ::)

Tornando in tema... hai provato ad utilizzare un'altro programma per generare la sitemap?
Ogni tanto passo da Joomla Blog! Un blog su Joomla

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #9 il: 11 Ago 2009, 02:52:30 »
ti riferisci a quella del sito o a quelle due satelliti inserite all'interno delle due cartelle?. sorry talo ma non mi pare di avere detto niente di male e non credo che una persona debba rivolgersi agli altri (nel qual caso me) in questo modo. Se poi ce l'ha con il sottoscritto per qualcosa può tranquillamente dirmelo in pvt
Creatore e Ideatore di Aghape Ambiente

Offline taolo

  • Global Moderator
  • Instancabile
  • *****
  • Post: 3651
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #10 il: 11 Ago 2009, 02:57:47 »
Ok. può bastare

Intendo la sitemap della cartella che non viene indicizzata. Prova qualche programma online che genera sitemap e sottoponila a google.

A volte la struttura della sottocartella può impedire al bot di analizzare e indicizzare. Non per forza deve essere un problema di mappa. Possono subentrare vari fattori tra cui, in primis, la struttura d'ordine del sito stesso.
Ogni tanto passo da Joomla Blog! Un blog su Joomla

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #11 il: 11 Ago 2009, 03:01:40 »
ok proverò. ciao e grazie
Creatore e Ideatore di Aghape Ambiente

Offline taolo

  • Global Moderator
  • Instancabile
  • *****
  • Post: 3651
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #12 il: 11 Ago 2009, 03:06:57 »
Di niente... figurati.

Tienici informati.

Ciao  :)
Ogni tanto passo da Joomla Blog! Un blog su Joomla

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #13 il: 15 Ago 2009, 12:30:08 »
niente, ho provato a re-inviarla da 4 giorni con 1 nuovo tool via web ma ancora 0 url indicizzati..boh
Creatore e Ideatore di Aghape Ambiente

Offline taolo

  • Global Moderator
  • Instancabile
  • *****
  • Post: 3651
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #14 il: 17 Ago 2009, 00:26:41 »
L'importante è che non ricevi errori. Vedrai che tra un pò ti indicizza qualcosa.
Ogni tanto passo da Joomla Blog! Un blog su Joomla

Offline fabiuzz1983

  • Esploratore
  • **
  • Post: 188
  • Sesso: Maschio
    • Mostra profilo
Re:Xmap ed errore Google
« Risposta #15 il: 19 Ago 2009, 09:27:35 »
ok grazie
Creatore e Ideatore di Aghape Ambiente

 



Web Design Bolzano Kreatif