Autore Topic: [RISOLTO] con IE8 ed il mio sito...in pratica il footer si ritira una volta tutt  (Letto 4638 volte)

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Salve a tutti,
come da oggetto ho un problema con IE8 ed il mio sito...in pratica il footer si ritira una volta tutto a sx una volta tutto a dx del browser causando sovrapossizione degli oggeti contenuti nel footer...ovvero alcune voci di menu!
Con firefox tutto ok...
« Ultima modifica: 19 Ott 2009, 21:46:58 da Xone »
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Re:Problemone con IE8
« Risposta #1 il: 18 Ott 2009, 12:46:30 »
Ciao Xone,
un link al sito?
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Re:Problemone con IE8
« Risposta #2 il: 18 Ott 2009, 13:43:14 »
« Ultima modifica: 19 Ott 2009, 17:30:19 da Xone »
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
ma ....
se metti immagini ed oggetti che non ci stanno perch troppo grandi  come speri di avere una visualizzazione corretta?
(uso XP perch win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
ma ....
se metti immagini ed oggetti che non ci stanno perch troppo grandi  come speri di avere una visualizzazione corretta?

forse non ci capiamo!
apri con firefox e vedi se va bene...
gli oggetti hanno una misura giusta...!
tutto giusto...
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Ciao Xone,
il tuo problema dato molto probabilemente dal fatto che hai fatto copia/incolla da un documento di word.
E' altamente sconsigliato il copia/incolla da applicativi terzi perch creano i problemi tipo quello che hai tu.
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Ciao Xone,
il tuo problema dato molto probabilemente dal fatto che hai fatto copia/incolla da un documento di word.
E' altamente sconsigliato il copia/incolla da applicativi terzi perch creano i problemi tipo quello che hai tu.
mmm...e ma cosa avrei potuto fare copia incolla...voglio dire...sono 4 immagini e poi le parlo giu nel footer le ho scritte io... :-\
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Il problema deriva dall'articolo, non dal footer.
Guarda il sorgente della pagina e vedrai quanta spazzatura ti sei portato dietro.
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Il problema deriva dall'articolo, non dal footer.
Guarda il sorgente della pagina e vedrai quanta spazzatura ti sei portato dietro.

 :o :o :o
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
si accettano volentieri consigli...
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Scusa ma scrivo difficile?

Apri l'articolo che hai in homepage.
Con l'editor in modalit HTML controlla l'articolo, vedrai che hai una sfilza di caratteri del tipo:
Codice: [Seleziona]
<!--[if gte mso 9]><xml>  <w:WordDocument>   <w:View>Normal</w:View>   <w:Zoom>0</w:Zoom>   <w:HyphenationZone>14</w:HyphenationZone>   <w:PunctuationKerning/>   <w:ValidateAgainstSchemas/>   <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>   <w:IgnoreMixedContent>false</w:IgnoreMixedContent>   <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>   <w:Compatibility>    <w:BreakWrappedTables/>    <w:SnapToGridInCell/>    <w:WrapTextWithPunct/>    <w:UseAsianBreakRules/>    <w:DontGrowAutofit/>   </w:Compatibility>   <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel>  </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml>  <w:LatentStyles DefLockedState="false" LatentStyleCount="156">
E ce ne sono molte altre nell'articolo.

Cancella tutto che non serve e vedrai che il sito si vedr bene anche con IE8
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Okey...ci provo...
« Ultima modifica: 18 Ott 2009, 15:25:13 da 56francesco »
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Fatto...ma non ho risolto nulla... :-[
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Interessante,
hai provato a disabilitare uno per uno i vari moduli in basso per vedere se cozzano con la visualizzazione?
Se non ne veniamo fuori magari spostiamo il messaggio nella sezione templates...
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
ora li ho disabilitati tutti...ma il footer continua a comportarsi in modo strano...
credo che dipenda da qualche valore di width nel file...css o php? npn lo so!
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
Sposto il messaggio nella sezione templates dove ci sono gli esperti mondiali di joomla ;)
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Perfetto...ti ringrazio molto...
Spero ora si riuscir a venirne a capo... altre info che possono risultare importanti al fine della comprensione del manfunzionamento:

1)Ho provato a disabilitare tutti i componenti in basso...Result: nothing!

2) Ho pulito il codice html dell'articolo...Result: nothing!

Confido in voi Sacri del codice!:D
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Up...
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
ciao
prova a rimettere quello che evevi nel fotter  x vedere che succede.
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
ciao
prova a rimettere quello che evevi nel fotter  x vedere che succede.

fatto...il footer rimane diciamo costretto in una sola porzione ... in pratica diventa la met e quello che c' scritto sopra si sovrappone...!

Ti allego il CSS del template...

[allegato vecchio pi di un anno eliminato automaticamente]
« Ultima modifica: 19 Ott 2009, 13:00:24 da Xone »
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
ciao
 hai provato ah  specificare il css  x il solo ie8 visto che hai lo specifico nel template x ie6-7
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
no...mi diresti come fare?
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
vieni msn
che proviamo

pipo1it@yahoo.it
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
okey...ti ho aggiunto!
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline Xone

  • Esploratore
  • **
  • Post: 119
  • Sesso: Maschio
    • Mostra profilo
Risolto...si che ho risolto... ;D grazie all'aiuto del "Conti1"...davvero un sentito grazie!
La risoluzione al problema avvenuta andando a mettere mano al codice della index.php del template ad al css del medesimo!
Grazie ancora conti ...
Ciauzuzzu ;D
"Il problema non la caduta. Ma l'atterraggio!" da "L'Odio" di M.K.

Offline sudoku

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4076
  • Sesso: Maschio
  • Non serve essere alti. basta essere all'altezza
    • Mostra profilo
sarebbe bello che queste soluzioni fossero messe a disposizioni di tutti gli utenti. Tanto per spirito di condivisione.
Joomla non una soluzione, un metodo
http://www.BreezingTest.altervista.org

Offline conti1

  • Global Moderator
  • Instancabile
  • *****
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
e si ma anche se si postasse come e stato risolto non e un problema comune ma un problema individuale
del template  comunque la solazione e far si che il template abbia un css ie8

nel php si aggiunge

Codice: [Seleziona]
<!--[if lte IE 8]>
<link href="templates/<?php echo $this->template ?>/css/ie8.css" rel="stylesheet" type="text/css" />
<![endif]--> 

poi  si deve aggiungere il css nella cartella css del template che si chiamera ie8.css
 nel css si mette  dire mettere e troppo generico ma individuare il problema poi spostare il css nella cartella ie8.css in questo caso il css era il footer bche dava problemi

Codice: [Seleziona]
/* FOOTER
--------------------------------------------------------- */
#ja-footerwrap {
clear:both;
float:left;
font-size:92%;
margin-top:30px;
width:100% ;
}

#ja-footer {
-moz-background-clip:border;
-moz-background-inline-policy:continuous;
-moz-background-origin:padding;
background:#F3F3F3 none repeat scroll 0 0;
border-top:1px solid #CCCCCC;
clear:both;
padding:8px 0;
position:relative;
width:100% ;
}

small.ja-copyright {
margin-top:10px;
position:absolute;

}

#ja-botsl {
clear:both;
padding:30px 0 0;
width:100%;
}

si riprende il css del template e riportato per ie8  modificandolo e adattandolo x la visione .
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

 

Host

Torna su