Autore Topic: (RISOLTO) noixacl installato ma non fa nulla  (Letto 4395 volte)

Offline Urmonmax

  • Appassionato
  • ***
  • Post: 249
    • Mostra profilo
(RISOLTO) noixacl installato ma non fa nulla
« il: 03 Dic 2009, 10:02:33 »
Ciao a tutti segendo la guida di Marcoj ho installato esattamente i componenti da lui segnalati e nell'ordine coronologico indicato.
L'installazione va a buuon fine ma non riesco ad ascludere le categorie dalla visualizzazione di alcuni menu.. chi mi sa aiutare? forse sbaglio qualcosa.
questi sono i componenti installati:

noixacl2.0.6 (poi cancellato e installato il 2.0.11. perchè con l'altro non mi faceva modificare i menu)

mod_mainmenu_noix.zip
adapterAccess1.5.3
adapterContent1.5.5
adapter Modlesv1.0
menuAdapter1.5.1

mi sapete dire se sbaglio qualcosa?

creo il menù dedicato ad una categoria, lo metto come Registered, pio creo la categoria sotto registered chiamandola "Rivenditori" e "clienti", dal pannello di controllo di noixacl su configurazione gruppi, sulla categoria clienti metto il spunta sul modulo che non voglio venga visto dai rivenditori
creo l'utente come rivenditore

quando entro come l'utente registrato sotto rivenditori vedo comunque tutti e due i menu.. perchè?

chi mi sa aiutare?

« Ultima modifica: 18 Dic 2009, 10:59:12 da Urmonmax »

Offline MarcoJ

  • Appassionato
  • ***
  • Post: 408
  • Sesso: Maschio
    • Mostra profilo
Re:noixacl installato ma non fa nulla
« Risposta #1 il: 03 Dic 2009, 10:39:56 »
Ciao Urmonmax,
come ho detto varie volte non è semplicissimo usare NoixAcl  :D.
Almeno per mia esperienza (che evidentemente vale quello che vale), non è bene muoversi "a senzasioni" utilizzando NoixAcl.
Ci sono dei componenti per quali non c'è bisogno di leggere neanche un rigo di documentazione (cattiva abitudine): basta smanettare e tutto va a posto.
Non così per NoixAcl.

Ti consiglio di andare a vedere a questo indirizzo le istruzioni di creazione di una applicazione di esempio: sono ben fatte e pronte in soli... 52 passi, che io ho seguito lettera-lettera, come un bue.
L'indirizzo della pagina è
http://blueflyingfish.no-ip.biz/joomla15/index.php?option=com_k2&view=item&layout=item&id=79&Itemid=82&lang=en, ma devi registrarti.
Se vuoi usare questo componente credo che sia indispensabile.
Quando poi si è riusciti a eseguire passo-passo la prima installazione, allora si comincia a capire la filosofia del componente e si può iniziare ad azardare.
Ti confermo però che il componente funziona bene.
Buon lavoro  8)
È più facile fare la cosa corretta, quando sappiamo qual’è la cosa corretta da fare.

Offline Urmonmax

  • Appassionato
  • ***
  • Post: 249
    • Mostra profilo
Re:(RISOLTO)noixacl installato ma non fa nulla
« Risposta #2 il: 03 Dic 2009, 19:10:41 »
Marcoj... grazie alla tua guida o risolto il problema, ora va tutto bene.. ho solo un piccolo problema, mi è scomparso il top menu.. non so se a causa dell'installazione del noix o per mio errore, sai aiutarmi?

comunque grazie della guida!!

Offline MarcoJ

  • Appassionato
  • ***
  • Post: 408
  • Sesso: Maschio
    • Mostra profilo
Re:(RISOLTO)noixacl installato ma non fa nulla
« Risposta #3 il: 04 Dic 2009, 10:30:18 »
Ciao,
a meno che non ti sia scappata qualche castroneria sui menu' stessi, non dovrebbero esserci problemi o almeno io non li ho mai avuti.
Vedi bene la configurazione del modulo del tuo menu'.
È più facile fare la cosa corretta, quando sappiamo qual’è la cosa corretta da fare.

Offline MarcoJ

  • Appassionato
  • ***
  • Post: 408
  • Sesso: Maschio
    • Mostra profilo
Re:(RISOLTO)noixacl installato ma non fa nulla
« Risposta #4 il: 15 Dic 2009, 14:08:31 »
Urnonmax,
svuota la casella dei messaggi ricevuti, perche' altrimenti...
È più facile fare la cosa corretta, quando sappiamo qual’è la cosa corretta da fare.

Offline Urmonmax

  • Appassionato
  • ***
  • Post: 249
    • Mostra profilo
Re:(RISOLTO)noixacl installato ma non fa nulla
« Risposta #5 il: 15 Dic 2009, 22:26:01 »
Nulla Marco, sono giorni e giorni che provo, noixacl fa tutto quello che dovrebbe fare solo che purtruppo rimane quel problema.. Gli utenti dei due gruppi creati sotto registered continuano ad avere la possibilità di modificare da frontend gli articoli in home page


Offline Urmonmax

  • Appassionato
  • ***
  • Post: 249
    • Mostra profilo
Re:noixacl installato ma non fa nulla
« Risposta #6 il: 18 Dic 2009, 10:56:51 »
Scrivo questo prima di tutto per ringraziare infinitamente Marcoj che con la sua pazienza e gentilezza ha risolto il problema.
Lo scrivo per tutti coloro che hanno lo stesso mio problema.

Seguendo passo passo la guida si arriva a dare ai gruippi di utenti i permessi per accedere o visualizzare sezioni, menu e articoli o inibire agli stessi la visualizzazione. Il mio problema era che alla fine tutti gli utenti dei gruppi creati sotto registered potevano  modificare gli articoli da frontend anche in home page.. Grazie a Marcoj ho risolto il problema, anzi.. l'ha risolto lui per me nel seguente modo:

cito le parole testuali di Marcoj
Vengo ora a spiegarti dove era l'inghippo.
La procedura indicata sulla documentazione era stata eseguita correttamente, salvo un piccolo errore che pero' non c'entrava nulla con il tuo problema.
Occorreva per risolvere il problema andare un po' piu' a fondo ed io l'ho fatto curiosando tra le montagne di parametri di NoixAcl.
La cosa che mi aveva colpito e' stato che nella procedura indicata, all'interno della gestione dei gruppi, non c'era nessun riferimento all'adattatore di tipo Access.
Il problema infatti, guarda caso, e' proprio li'.
Quindi devi andare su:
Controllo accessi -> Configura Gruppi -> Selezionare il
tuo gruppo (p.e. Volunteers).
In questo caso il sistema parte proprio con la configurazione dell'adattatorre Accessm, che ha 3 "linguette": Administrator, Site e General.
Clicca su General e vai nella sezione "Manage content" (infatti il problema era collegato alla gestione dei contenuti).
Li' ci sono 4 voci:

•Frontpage Add
•Frontpage Edit All
•Frontpage Edit Own
•Frontpage Publish.
Ora solo l'ultima di queste e' spuntata, ma quando si crea un nuovo utente per default viene spuntata anche la seconda, ossia "Frontpage Edit All".
Ti dice niente questo ?
Io non ho fatto altro che andare li' e togliere la spunta su quella voce... et voila'. 
Provare per credere.

Non è che tutto sia stato così veloce come ora te l'ho descritto, perche' come dico sempre NoixAcl è abbastanza incasinato, ma quello che conta è il risultato.


GRAZIE ANCORA MARCO!
« Ultima modifica: 18 Dic 2009, 10:58:39 da Urmonmax »

Offline cerberus

  • Esploratore
  • **
  • Post: 98
    • Mostra profilo
Re:(RISOLTO) noixacl installato ma non fa nulla
« Risposta #7 il: 12 Gen 2010, 16:52:23 »
Mi intrometto in questa discussione, sperando nell'aiuto di Marcoj.
Ho installato anche io NoixAcl, ho letto le guida e seguito tutti i passi.
Quello che ho fatto è creare un gruppo di utenti che possa inserire gli articoli ed avere un minimo di "potere" nel pannello di controllo. Sarebbe un account manager ma con qualche limitazione in più. Funziona tutto tranquillamente, tranne la possibilità di inviare articoli nel backend. Il problema so qualìè, ma non si risove. Infatti andando nel sezione access, in general e poi in Manage Content, la spunt frontpage add non viene mantenuta!!! Cioè, io inserisco la spunta (che diovrebbe permnettere l'invio di un nuovo articolo) ma quando salvo il componente e vado a controllare, la spunta è eliminata!!!

Com'è possibile?

Grazie a tutti!

Offline luken

  • Nuovo arrivato
  • *
  • Post: 44
    • Mostra profilo
Re:(RISOLTO) noixacl installato ma non fa nulla
« Risposta #8 il: 19 Gen 2010, 16:24:30 »
Scusate l'incapacità , ma io non riesco a trovare la  guida di Marcoj

ho cercato sul forum ma senza alcun risultato

mi potreste dare il link

grazie mille

Offline alfix

  • Nuovo arrivato
  • *
  • Post: 3
    • Mostra profilo
Re:(RISOLTO) noixacl installato ma non fa nulla
« Risposta #9 il: 31 Dic 2010, 07:33:09 »
In effetti il link postato da marcoj non fa più riferimento alla guida, piacerebbe pure a me leggerla, potete ripostare il link corretto?

Offline ippogrifo

  • Appassionato
  • ***
  • Post: 209
    • Mostra profilo
Re:(RISOLTO) noixacl installato ma non fa nulla
« Risposta #10 il: 05 Gen 2011, 12:37:02 »

ciao

anch'io vorrei leggera la guida poichè ho insatallato il componente piu' volte senza i risultati voluti


grazie

 

Host

Torna su