Autore Topic: Attachments e dimensioni file da caricare: problema  (Letto 3774 volte)

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
Attachments e dimensioni file da caricare: problema
« il: 16 Dic 2009, 14:03:12 »
ho installato il componente Attachmate ma ho riscontrato che non si riesce a caricare allegati con dimensioni superiori agli 800/900 kb.
purtroppo non compare nessun messaggio di errore che segnali il malfunzionamento.
ho controllato le impostazioni di Joomla e alla voce dimensione allegati ho settato il valore "0" (pertanto dimensione illimitata)

c'è qualcos'altro da controllare ??

Valter
« Ultima modifica: 16 Dic 2009, 18:11:22 da ilvanni »

Offline frascan

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4988
  • Sesso: Maschio
    • Mostra profilo
Re:Attachmate e dimensioni file da caricare: problema
« Risposta #1 il: 16 Dic 2009, 15:23:34 »
Ciao.
Devi vedere le limitazioni a livello di server. Anche impostando come illimitato il limite in joomla devi tener conto delle limitazioni a livello di confingurazione generale del server.
Per la natura stessa delle cose un esploratore non può mai sapere che cosa stia esplorando finché l’esplorazione non sia stata compiuta.

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
Re:Attachmate e dimensioni file da caricare: problema
« Risposta #2 il: 16 Dic 2009, 15:33:11 »
cosa intendi per limitazione del server ?
io lo sto usando su una macchina con s.o. Ubuntu e alla fine "dovrebbe" diventare un portale nella intranet dell'Ufficio...
non mi pare che in fase d'installazione mi sia stato chiesto di specificare valori particolari.

Offline frascan

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4988
  • Sesso: Maschio
    • Mostra profilo
Re:Attachmate e dimensioni file da caricare: problema
« Risposta #3 il: 16 Dic 2009, 17:10:19 »
In fase di inatallazione di joomla lo so che non ti sono state fatte richieste del genere.
Quindi si tratta di un pc su cui è installato ubuntu mi pare di capire, giusto?
La configurazione del pc con ubuntu è stata fatta correttamente?
In ogni caso se vai nel pannello di amministrazione di joomla e poi in Aiuto -> Info sistema -> Informazioni php e cerchi questa stringa upload_max_filesize dovresti vedere il limite per l'upload dei files sul server.
Per la natura stessa delle cose un esploratore non può mai sapere che cosa stia esplorando finché l’esplorazione non sia stata compiuta.

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
Re:Attachments e dimensioni file da caricare: problema
« Risposta #4 il: 17 Dic 2009, 10:06:45 »
esattamente.
un pc locale con Ubuntu che fa funzioni di web server, su cui ho installato utto il pacchetto per gestire Joomla (Apache2, Mysql,Php5) e il solito webmin..
ho controllato le impostazioni che mi hai suggerito ed ho trovato questo:
"upload_max_filesize 2M 2M "
se ho capito bene ho il limite a 2 mb
presumo pertanto che devo modificare un qualche file di configurazione aumentando magari il valore (penso di non dover mettere allegati maggiori di 10 Mb)

valter

Offline frascan

  • Global Moderator
  • Instancabile
  • ********
  • Post: 4988
  • Sesso: Maschio
    • Mostra profilo
Re:Attachments e dimensioni file da caricare: problema
« Risposta #5 il: 17 Dic 2009, 10:24:15 »
si esatto quello è il limite per l'upload dei files.
devi modificare il file di configurazione del php. lo editi trovi la riga in questione ed aumenti il valore.
Per la natura stessa delle cose un esploratore non può mai sapere che cosa stia esplorando finché l’esplorazione non sia stata compiuta.

Offline valtere

  • Esploratore
  • **
  • Post: 101
    • Mostra profilo
Re:Attachments e dimensioni file da caricare: problema
« Risposta #6 il: 17 Dic 2009, 20:59:26 »
grazie per l'indicazione.
modifica effettuata e ora va alla grande...

buone feste a tutti

Valter - TV

Offline magoo

  • Nuovo arrivato
  • *
  • Post: 17
    • Mostra profilo
Re:Attachments e dimensioni file da caricare: problema
« Risposta #7 il: 01 Feb 2010, 15:28:58 »
avevo un problema simile poi ho capito che il problema stava nel fatto che il pulsante sotto l'editor non funziona ma se faccio inserisci allegato da fuori l'editor funziona forse ho scoperto un bug di fckeditor...
tanto va la gatta al lardo che ci lascia lo zampino...più la si mescola e più puzza... nel dubbio è meglio non toccare.

 

Host

Torna su