Autore Topic: problemi con swmenufree nel template siteground-j15-92 RISOLTO  (Letto 1521 volte)

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Ciao a tutti,
ho un problema per quanto riguarda l'utilizzo di swmenufree nel template siteground-j15-92.
Il menu mi viene visualizzato ma i sottomenu no.Cioè al passaggio del mouse non succede niente, non visualizzo alcun sottomenu.
Qualcuno di voi mi sa dire perchè succede questo??
Grazie.
« Ultima modifica: 06 Feb 2010, 16:42:17 da tonicopi »

Offline eddydesigner

  • Esploratore
  • **
  • Post: 64
  • Sesso: Maschio
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #1 il: 05 Feb 2010, 19:58:47 »
è sicuramente un problema di z-index.. in realtà i sottomenu ci sono ma non si vedono perchè rimangono sotto al div che contiente l'elemento sotto al menu.

Senza vedere il sito è difficile aiutarti cmq proviamo... dovresti individuare l'id del div che contiene il menu e nel css mettere
 position:relative;
 z-index:3;

e all'id div che contiene l'elemento sotto al menu

position:relative;
 z-index:2;

posta l'indirizzo del sito se online

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #2 il: 05 Feb 2010, 20:11:55 »
xxxxxxxxxxxxx 
sotto lega A non si aprè il menù a tendina..

cosa mi consigli?
« Ultima modifica: 06 Feb 2010, 16:41:28 da newutente »

Offline eddydesigner

  • Esploratore
  • **
  • Post: 64
  • Sesso: Maschio
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #3 il: 05 Feb 2010, 20:35:29 »
scusa la domanda stupida, ma sei sicuro di aver pubblicato le voci di menu sotto a Lega A?? Perchè se guardi il codice generato le voci non ci sono proprio.. quindi non è un problema di posizionamento, prova a verificare ancora se effettivamente hai pubblicato le voci sotto.. oppure devi cambiare modulo...

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #4 il: 05 Feb 2010, 20:46:53 »
no le ho pubblicate perchè se cambio template compaiono normalmente..

Offline eddydesigner

  • Esploratore
  • **
  • Post: 64
  • Sesso: Maschio
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #5 il: 05 Feb 2010, 20:52:11 »
beh a questo punto credo che la cosa più veloce sia quella di cambiare modulo..
http://extensions.joomla.org/extensions/structure-a-navigation/menu-systems/drop-a-tab-menus
mi dispiace di non esserti stato d'aiuto. :-[
« Ultima modifica: 06 Feb 2010, 00:24:41 da eddydesigner »

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #6 il: 05 Feb 2010, 21:09:38 »
cambiando il menù da trans a mygosu qualcosa anche se lievemente appare...
cosa mi consigli?

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #7 il: 05 Feb 2010, 21:27:44 »
dove posso trovare z-index così da provare a modificarlo?

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #8 il: 05 Feb 2010, 23:00:54 »
non riesco proprio a capire, se vado in preview il menù è creato bene e funziona perfettamente, vado poi nel sito ed invece non va...potete cortesemente aiutarmi?
sono davvero in difficoltà.

Grazie

Offline tonicopi

  • Global Moderator
  • Instancabile
  • ********
  • Post: 12762
  • Sesso: Maschio
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #9 il: 06 Feb 2010, 15:36:34 »
Togli l'overflow hidden da questa regola:
Codice: [Seleziona]
#pillmenu {
-moz-background-clip:border;
-moz-background-inline-policy:continuous;
-moz-background-origin:padding;
background:transparent url(../images/t_menu_bg.png) no-repeat scroll center center;
bottom:17px;
height:30px;
left:0;
padding:0 20px;
position:absolute;
width:920px;
}
;)
joomlacsszengarden.com = il giardino dei css di Joomla!
L'attesa del piacere è essa stessa... piacere!

Offline newutente

  • Esploratore
  • **
  • Post: 56
    • Mostra profilo
Re:problemi con swmenufree nel template siteground-j15-92
« Risposta #10 il: 06 Feb 2010, 16:39:23 »
Grazie Toni,
sono riuscito a risolvere il problema grazie al tuo consiglio.

Ciao

 

Host

Torna su