Autore Topic: Cache del Modulo "Articoli Recenti"  (Letto 319 volte)

Offline sgiobbio

  • Esploratore
  • **
  • Post: 163
    • Mostra profilo
Cache del Modulo "Articoli Recenti"
« il: 15 Ott 2019, 20:49:00 »
Mi capita una cosa bizzarra.
Sul sito www.convivium.club utilizzo un modulo del tipo "Articoli Recenti".
Questo modulo viene visualizzato sia in un articolo normale ("Le ultime prove") sia in un articolo "in evidenza" (in Home Page), e in entrambi i casi viene richiamato attraverso l'istruzione {loadposition}. Il modulo è settato "no cache" nelle istruzioni avanzate.
Nell'articolo normale mostra realmente gli articoli recenti aggiornati: infatti è settato per mostrare i 12 articoli pubblicati per ultimi, e questo avviene regolarmente.
Invece nell'articolo "in evidenza", che viene mostrato in Home Page, gli "articoli recenti" non sono aggiornati e per vedere realmente gli ultimi pubblicati non è sufficiente svuotare tutta la cache (sia quella di joomla sia quella di Siteground sia quella di Cloudflare), ma occorre svuotare anche la cache dei miei Browser Firefox e Chrome.
Come mai?
Il modulo è sempre lo stesso, la sua funzione nativa è quella di mostrare gli articoli recenti, il richiamo del modulo con loadposition è sempre uguale...
Forse dovrei operare sulla cache della Home Page che si popola come un puzzle degli "Articoli in evidenza"? E come?
Sto diventando matto e non ho la minima idea di dove intervenire.
Qualcuno mi sa dare la dritta giusta?
« Ultima modifica: 17 Ott 2019, 10:01:31 da sgiobbio »

Offline sgiobbio

  • Esploratore
  • **
  • Post: 163
    • Mostra profilo
Re:Cache del Modulo "Articoli Recenti"
« Risposta #1 il: 17 Ott 2019, 09:56:01 »
Nessuna suggestione?

Offline sgiobbio

  • Esploratore
  • **
  • Post: 163
    • Mostra profilo
Re:Cache del Modulo "Articoli Recenti"
« Risposta #2 il: 22 Ott 2019, 14:46:38 »
Qualcuno sa darmi un suggerimento?

Offline sgiobbio

  • Esploratore
  • **
  • Post: 163
    • Mostra profilo
Re:Cache del Modulo "Articoli Recenti"
« Risposta #3 il: 26 Ott 2019, 11:50:18 »
Nessuno ha risposto.
Mi sono ingegnato da solo e ho trovato una soluzione empirica, che tuttavia non spiega il problema.
In buona sostanza, invece che richiamare con loadposition il modulo "articoli recenti" all'interno di un articolo in evidenza, ho fatto diventare in evidenza l'articolo già esistente che lo incorporava.
Questo ha comportato una serie di modifiche alla struttura "blog" della Home Page, per mantenere il layout predefinito anche con un articolo in evidenza in più.
Adesso gli articoli recenti mostrati sono effettivamente gli ultimi 12, come deve essere, e non quelli di 2 mesi fa...
Continuo a non spiegarmi il perché, posso fare soltanto una congettura: quel modulo "articoli recenti", se richiamato da loadposition in più di un articolo, nel secondo articolo mostra contenuti in cache anziché quelli che dovrebbe mostrare...
Cervellotico, ma non me lo spiego altrimenti.
Non metto ancora "risolto" perché mi piacerebbe leggere il parere di qualcuno di voi.

 

Host

Torna su