Autore Topic: [RISOLTO!!] Nascondere edit per publisher o rendere non modificabili articoli  (Letto 7660 volte)

Offline valex

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
Ciao a tutti, come va?

ho un problema che non riesco a risolvere, magari qualcuno ha avuto la mia stessa esperienza e può darmi gentilmente un consiglio.

sto costruendo un portale abbastanza complesso e mi si presenta il seguente problema, per esigenza del cliente ho bisogno che gli articoli al momento del salvataggio siano direttamente pubblicati senza aver bisogno di approvazione dal back end. quindi ho creato tutti utenti publisher di default.

il problema è che in questo modo gli articoli sono modificabili da tutti, anche se creati da superadmin..corretto? il problema non è rendere accessibile o meno un contenuto ma fare in modo che non sia editabile da tutti, ciò accade perchè sono publisher.

ho provato noixacl ma agisce soprattutto per il backend ed è in beta. magari c'è qualche componente commerciale? sarebbe ottimo riuscire a trovare un plugin che permetta di non visualizzare l'icona edit per alcuni articoli (come per l'icona email e pdf), bisognerebbe cambiare il codice php e l'xml, o magari che l'articolo sia modificabile solo da chi lo ha creato.

qualche consiglio?

stavo riflettendo sulla possibilità di modificare gli attributi dei registered sul database per fare in modo che gli articoli siano direttamente pubblicati, che ne pensate? si può fare?

insomma non so che pesci prendere mmm...

« Ultima modifica: 05 Mar 2009, 17:38:45 da valex »

Offline valex

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
risoltooooooo!

in libraries/joomla/user/authorization.php ho cambiato la stringa che individua la editabilità di tutti gli articoli da parte dei publisher!

da all ho cambiato il valore in own e ora i publisher possono cambiare solo i propri singoli articoli!

la riga in questione è
$this->addACL( 'com_content', 'edit', 'users', 'publisher', 'content', 'all' )

iaahuuu!! ;D

Offline viris

  • Nuovo arrivato
  • *
  • Post: 1
    • Mostra profilo
ciao, ho visto che sei molto pratico e che ti sei risolto il problema anche da solo :-D  ... volevo chiederti una cortesia tu o qualcuno che possa aiutarmi

sto facendo un sito con joomla 1'5 all'inizio prima che io ci mettessi le mani funzionava tutto bene ora funziona ancora tutto tranne che quando faccio un articolo riesco anche a mettere un immagine ma non me la visualizza quando pubblico l'articolo....io uso come editor jck ma ho provato anche ad inserirlo con l'editor standard senza alcun risultato

credo di aver tolto qualche autorizazione sapete come posso fare per farli visualizzare?


aiutatemi vi prego

Offline claudio78

  • Nuovo arrivato
  • *
  • Post: 17
  • Sesso: Maschio
    • Mostra profilo
Questa domanda non c'entra molto con l'argomento del thread. Inoltre dovresti fornire maggiori informazioni: quali sono state le tue modifiche? Come aggiungi le foto al sito? Le immagini non si vedono in assoluto oppure solo all'interno di un particolare contenuto? Hai installato plugin riguardanti le immagini, le gallerie ecc.?

Non sono espertissimo ma se il tuo sito gira sotto linux ti suggerisco di verificare che la cartella images/stories (piu' le sottocartelle e i file in essa contenuti) abbia i permessi necessari alla lettura dei file. Solitamente questi permessi sono impostati a 775 (trovi abbondante documentazione online su come cambiarli, cerca per 'chmod' e 'chown').

Buona fortuna!


Claudio Tortorelli

Offline bigham

  • Global Moderator
  • Instancabile
  • ********
  • Post: 3662
  • Sesso: Maschio
  • Contagiato dalla Joomlaite :)
    • Mostra profilo
Compilenti a valex!!  ;D ;D

@viris
Dove lo stai facendo il sito? su un server remoto o sul tuo computer?
Ci sono più cose in cielo e in terra, Orazio, di quante ne sogni la tua filosofia.

Offline kalos

  • Nuovo arrivato
  • *
  • Post: 23
    • Mostra profilo
Grazie Valex, il tuo suggerimento mi è stato molto utile  :)

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
I miei rispetti valex  :)
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline dalse

  • Nuovo arrivato
  • *
  • Post: 5
    • Mostra profilo
avrei lo stesso problema, solo che sto usando la versione di Joomla! 1.0.12 Stable.
so bene che sarebbe consigliato l'upgrade ad una versione successiva, ma al momento alcuni moduli fondamentali per me non girano sulla nuova versione che ho testato in locale, ed il tempo che posso dedicare ai test è limitato, dunque non posso che rimanere legato ancora per un po' alla 1.0.X.
è possibile risolvere la cosa anche su questa versione?
grazie 

Offline bot

  • Esploratore
  • **
  • Post: 77
  • Sesso: Maschio
  • www.botsite.it
    • Mostra profilo
Re:Nascondere edit per publisher o rendere non modificabili articoli
« Risposta #8 il: 18 Ago 2009, 16:25:40 »
Ciao Ragazzi ce nessuno che sa dare una risposta per la 1.0???? Mi interessa molto anche a me.

Io ho provato a dare una occhiata all'interno del codice della cartella libraries che c'è nella "vechia" versione , ma non trovo nulla come ha detto Valex.

Valex hai un sec per dare un ochio???

 ??? ??? ???

Grazie ciao

Offline maicolstaip

  • Global Moderator
  • Instancabile
  • ********
  • Post: 17623
  • Sesso: Maschio
    • Mostra profilo
@ dalse
@ bot

Il vostro problema è totalmente differente da quello risolto da valex.
Infatti la vostra versione di joomla è la 1.0.x e non la 1.5.x.

Vi chiedo quindi di aprire un post nella sezione apposita perchè qui non credo che possiate avere assistenza anche perchè il topic è già taggato come [Risolto].

La sezione di joomla 1.0.x è questa:
http://forum.joomla.it/index.php/board,1.0.html
Grazie.
Non si risponde a PM tecnici. Postate sul forum. Grazie.

Offline bot

  • Esploratore
  • **
  • Post: 77
  • Sesso: Maschio
  • www.botsite.it
    • Mostra profilo
ok grazie,
credevo che forse era possibile avere una lucidazione anche qui....

Grazie comunque!! ;D ;D

Offline dalse

  • Nuovo arrivato
  • *
  • Post: 5
    • Mostra profilo
immaginavo, dato il tag, ma sono giorni che provo a venirne a capo. seguirò le tue indicazioni, grazie

Offline valex

  • Esploratore
  • **
  • Post: 62
    • Mostra profilo
sono tornato dopo un bel pò di tempo e ho trovato abbastanza risposte, caspita...scusate non ho avuto tempo lavoravo come un pazzo fino a sera per fare un portale per una grande società, mi avevano prosciugato...a presto!

 

Host

Torna su