Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - valtere

Pagine: [1] 2 3 4 ... 7
1
Joomla! 3 / Re:limitare lunghezza del titolo articolo
« il: 20 Giu 2021, 21:24:52 »
grazie per la rispostaho provato nel "clone" di casa ed ho impostato il template Protostar.anche qui il carattere si sovrapprone
pensavo anche io di metter mano alla tabella...ma poi sicuramente mi esce un problema diverso con qualche altro modulopurtroppo il modulo non ha tre le opzioni la possibilità di ridurre i caratteri
faccio prima a tagliare manualmente i caratteri in eccesso...mi faro carico anche di questa mansione !!

grazie e buona serata

2
Joomla! 3 / limitare lunghezza del titolo articolo
« il: 20 Giu 2021, 15:57:19 »
salve a tuttiè possibile limitare la lunghezza del nome articolo ??chiedo perchè avendo creato un modulo in cui visualizzo a scorrimento gli ultimi articoli pubblicati (modulo "Scroll article excerpt") e pubblicato in homepage (contenttop-a) , quando ho nomi articolo lunghi si vanno a sovrapporre al nome dell'articolo successivo rendendolo difatto illeggibile

se fossi solio io a pubblicare la cosa si fa semplice, quando è lungo taglio...ma gli altri colleghi non hanno questa attenzione..e dopo escono le castronate

è fattibile poter ridurre la lunghezza del nome articolo ??
grazieValter

3
vabbè...è un banale sito/portale per la divulgazione delle informazioni a livello "ufficio", così da evitare quintali di carta stampata...è su rete ministeriale ma non viene visto fuori ufficio.
purtroppo professionisti per ste cose la PA è molto indietro...c'è qualcosa a livello nazionale che sviluppa ma è sempre molto distante da da chi poi lo utilizza...ed i bug e procedure complesse emergono subito

4
purtroppo non è semplice..il sito si trova in una rete ministeriale, non raggiungibile dall'esterno, pertanto diventa tutto più difficile
anche solo consultare la rete per cercare soluzioni spesso è un problema..


5
e niente...dopo numerosi test l'allegato risulta visibile solo se ti logghi
se lo metto a guest viene visto (come nome del file) nell'articolo e anche consultabile da tutti
se lo metto a "registered" sparisce dalla vista dell'articolo e per consultarlo ovviamente bisogna loggarsi (in questo caso a specifica voce tra le opzioni degli allegati contemplava anche "registered")
boh...non ne vengo a capo

6
grazie per la risposta
si...stiamo parlando del componente "attachments"  tra le opzioni, in "visibilita" ho questo, che in teoria dovrebbe fare al caso mio: "mostra gli allegati agli utenti che non hanno fatto l'accesso", dove di default è attivo "public" ,
ho aggiunto anche "guest"
ma purtroppo, aperto l'articolo l'allegato non si vede ancora...

7
dopo aver installato la 3.9 e aggiustato template, componenti e moduli secondo necessita, vorrei risolvere una questione legata agli articoli, ovvero la visibilità degli allegati qualora l'articolo venga settato a "registered"
in sostanza creo un articolo, ci metto una breve descrizione nel corpo dell'articolo e allego un documento (di norma un file pdf)
vorrei proteggere la lettura del solo allegato lasciando la consultabilità dell'articoloho visto che posso proteggere l'allegato settando l'opzione in "registerd" ma se faccio così chi legge l'articolo non sa che c'è pure un allegato da consultare dopo essersi loggati al sito
è possibile far comparire un avviso automatico ...o lasciarlo visibile e cliccabile ma quando ci clicchi chiede il login ? 


Valter

8
boh...ho aggiornato la macchina mettendola in internet nonchè joomla e tutti i componenti ma il problema non si è risolto.nel dubbio ho preparato un pc con Ubuntu 16.04 e riprstinato il backup di Akeba...e qui funziona tuttomistero
mi sa che continuerò a lavorare sul pc e poi farò l'importazione in VMWARE per metterlo in produzione

9
scusami...una svistasto parlando sempre dello stesso plugin "attachments"

10
riprovato sulla macchina "ufficiale" al lavororeinstallati singolarmente i pacchetti di attachmate ma la ricerca ancora non funzionamistero


fatto un restore del sito con Akeba su altra macchina (Ubuntu 16.04 e PHP8) ma il problema permane
anche la reinstallazione di Attachmate da l'errore indicato nei post precedenti
a questo punto mi vien da pensare che il problema sia l'installazione di Joomla che ha qualche problema

11
per fortuna mi son portato dietro il backup .jpaho ripristinato sul muletto di casa (Ubuntu 16.04 Php8) con kickstartprovo ad installare i singoli pacchetti, che vanno quasi tutti a buon fine tranne il pacchetto "attachments_component.zip"    dove ottengo l'errore "count(): Argument #1 ($var) must be of type Countable|array, null given" 

sarei tentato di rimuovere attachmate e reinstallarlo, ma ho paura di perdere i collegamenti ai file "allegati" già caricati
spero di trovare un altra soluzione

12
fatto una prova su altra macchina uguale, stesso templatei plugin di attachmates sono uguali tra le due macchine
la versione di Joomla e Ubuntu anche, unica cosa diversa: Php8.0 dove funziona la ricerca, 7.4 dove NON funziona completamente
non penso sia proprio quello il problema...non va con nessun template
tra l'altro, la macchina con php 8 non mi fa nemmeno aprire le opzioni di "allegati" (Attachmate)...questo si è un problema di compatibilità

nel portale incriminato tra i moduli  trovo il "motore di ricerca" (che trova solo tra il nome articolo ed il suo testo) ed i modulo "Cerca" che rimanda ad una pagina con errore "count(): Argument #1 ($var) must be of type Countable|array, null given "

ho attivato anche il rapporto errori ma non mi viene mostrato nulla

proprio adesso che volevo metterlo online......
tocca ricominciare da capo


13
mi scuso per non averlo scritto prima
in plugin ne ho 2, entrambi attivati, riconducibili al tipo "attachments" e sono "Allegati - Framework del Plugin" e " Allegati - Per contenuti"
 
strana sta cosa....in altro portale con J1.5 , la cosa funziona.....ma stiamo parlando di un prodotto ormai vecchio

14
salve a tuttinel nuovo portale con J3.9 creo nuovi gli articoli a cui aggiungo l'allegato (quasi sempre un .pdf) attraverso il componente Attachmate.ho notato che il modulo di ricerca integrato in Joomla non mi trova gli articoli quando la chiave di ricerca corrisponde ad una parte del nome del file allegatoin sostanza mi cerca solo tra il titolo ed il testo dell'articolo
è risolvibile questa cosa ?grazieValter


15
alla fine ho scelto di rifare tutto nuovo con la 3.9 ed un template acquistato
mi viene più semplice e trovo ovviamente componenti e plugin più aggiornati

ho visto che con Attachmate posso scegliere, per ogni singolo allegato, se renderlo pubblico o registered, cosa molto comoda per gli sviluppi futuri

però se l'allegato lo metto "registered" non lo vedo fintanto che non mi loggo al portale
c'è forse il modo di farlo comunque vedere come "nome allegato" ma che sia consultabile solo dopo aver fatto il login ?
Valter

16
già..son stato troppo vago..
scusatemi

17
I Template di Joomla! 3 / personalizzare Footer e modulo TOP
« il: 03 Mag 2021, 20:11:16 »
salve,
vorrei personalizzare il modulo "footer" che risulta un po troppo "alto"  come spazio occupato e cambiare il colore dei caratteridi testo.stesso cosa vorrei fare con il modulo poizionato in "TOP", anche questo che occupa troppo spazio in altezza per le mie esigenze
immagino che una risposta precisa sia un po difficile da dare, molto dipenderà dal template usato (il mio è acquistato) , ma presumo che mettendo mano ai CSS forse qualcosa si riesce ad aggiustare
che dite ??
Valter

18
si devo ammettere che non è l'idea migliorema a quanto pare si può fare , a questo link ho trovato una descrizione migliore:
 https://tutorial4dev.com/linux/istanze-multiple-apache-php/

magari quando avro tempo ci proverò ..
chissà perchè mi vengono queste idee strane...troppo tempo in casa e ufficio al pc
buona giornata


20
salve a tutti.
secondo voi è possibile far coesistere due siti Joomla (portali ad uso ufficio...circa 5/6 articoli al giorno con allegati .pdf), un 3.9.x e un 1.5.x sulla stessa macchina server ? in sostanza avrei il primo joomla 3.9 ad esempio su 192.168.1.100 mentre il J1.5 su 192.168.1.100/Vecchiosito entrambi puntano ovviamente a database diversi sullo stesso mysql, che gestisco con phpmyadmin (o da pannello webmin).
presumo che il punto critico sia far andare il J3.9 con Php 7.4 (o sup) mentre il J1.5 deve andare con php 5.4
dal pannello webmin ho visto che in Apache posso abilitare i moduli Php che mi interessano...ma poi o va un sito o va l'altro

c'è qualche speranza o abbandono l'idea ?

grazie, Valter

PS: la macchina server (Ubuntu 16.04) non è su internet...

Pagine: [1] 2 3 4 ... 7
Host

Torna su