Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - LuxorTheFirst

Pagine: [1] 2 3 4 ... 11
1
@d-force

Dai un'occhiata sul forum del produttore del componente, altri hanno riportato il tuo errore:

http://redcomponent.com/forum/92-jupgrade/115090-slvgetting-a-few-errors-after-upgrading#115090

2
Non sono il solo.. io però sono più diplomatico di questo utente:

http://extensions.joomla.org/extensions/migration-a-conversion/joomla-migration/11658#rev-112025

Effettivamente dopo una verifica mi sono reso conto che guardavo il problema dal lato sbagliato:

la verità è che Jupgrade modifica gli ID degli articoli durante la migrazione. Ed i menu, che non vengono alterati, continuano a puntare agli article id vecchi generando l'errore 404.

E' un problema. Posterò la soluzione se la troverò. Comunico che esiste un componente commerciale che fa lo stesso lavoro di jupgrade ma senza questo problema, a detta di chi l'ha utilizzato. Si trova sulla JED.

http://extensions.joomla.org/extensions/migration-a-conversion/joomla-migration

Nonostante ciò, per il momento proverò a cercare una soluzione restando con jupgrade, che mi aveva fatto una buona impressione inizialmente....

La soluzione manuale sarebbe modificare tutti i menu (dato che gli id degli articoli non si possono toccare) ma non la auguro nemmeno al mio peggior nemico!  :D

NOTA: Dato che si tratta di un problema noto e potenziale, consiglierei se possibile di evidenziarlo qui su joomla.it , nelle varie guide all'upgrade automatico.

http://redcomponent.com/forum/92-jupgrade/119079-anscontent-id#119079
 

3
Ma dove lo trovo il pacchetto ITA per far sì che possa mettere le voci di menu impostate su tale lingua?

Puoi postarlo sul forum eventualmente? Io ho trovato i file di traduzione frontend e backend ma evidentemente non bastano.

Concordo sul fatto che con la migrazione le voci menu risultino corrotte  ;) però non è un problema comune.

4
Ciao Alexred, ho visto poi sul forum che un altro utente ha avuto il mio stesso problema..quindi adesso se mi risponde magari si può fare un thread unico  :)

Avevo joomfish come estensione per i contenuti, essendo un sito multilingua. Anche l'altro utente da quel che ho capito ce l'aveva, quindi forse la causa risale proprio ad un estensione come dici tu.

Link altro thread analogo in corso:
http://forum.joomla.it/index.php/topic,155545.0.html

5
Ho risolto ma solo in parte.... ???

Il mio è un sito multilingua realizzato con il sistema nativo do Joomla.

Per evitare che cliccando su alcuni link il browser restituisse errore 404, ho dovuto impostare le voci di menù anzichè su "tutte" sulla lingua di appartenenza (es. it-IT se italiano, e così via).

Da quello che ho capito, le voci di menù devono avere impostata una lingua specifica e non "tutte".


Ciao, io ho riscontrato il tuo stesso problema dei link non corretti.

Non capisco però come fai ad impostare le voci di menu in italiano perchè io nel menu a tendina ho solo "English UK" come lingua disponibile (oltre "Tutte"). Dove lo hai trovato il pacchetto ITA? Hai dovuto reinstallare Joomfish forse?
(Nota: io ho già i file italiani di Joomla installati ed impostati come predefiniti...ma nella linguetta "Contenuti" in "Gestione lingue" ho comunque solo "English UK")

Grazie in anticipo!

6

Non so, io passerei direttamente alla 2.5 visto che fai questo mega-sforzo.

Upgrade da 1.7 a 2.5
---------------------------

La guida è qui:

http://wiki.joomla.it/index.php/Aggiornamento_da_una_versione_di_Joomla_1.7_alla_nuova_2.5.1#Aggiornamento_Manuale

Mi sembra alquanto complicato però..rispetto alla soluzione jupgrade.


Il file per l'upgrade manuale qui:

http://www.joomla.it/download/joomla-2/472-aggiornamento-da-joomla-1-7-a-joomla-2-5.html

7
Salve ragazzi, ho fatto una migrazione automatica (con jupgrade) da joomla 1.5 a 2.5.

Tutto bene, tranne il fatto che gli ID degli articoli a cui linka il menu sono tutti sballati, e dunque quando clicco su una voce qualsiasi di un menu, mi dà errore "#404 article not found".

Se manualmente vado a cambiare l'article id nella barra degli indirizzi

...index.php?option=com_content&view=article&id=52&Itemid=111

mettendo l'id giusto (ricopiato da backend) ovviamente mi apre correttamente l'articolo.

...index.php?option=com_content&view=article&id=6&Itemid=111

Dunque la mia domanda è: anche a voi è successo che con la migrazione all'interno degli URL cui puntano i menu originali sono sballati gli ID degli articoli? :o (a differenza degli ID menu o "Itemid", che sono invece rimasti uguali..)

Se sì come avete posto rimedio? Non ditemi che bisogna andare a correggere manualmente tutte le url dei menu...  ;D

EDIT : reso il titolo del thread più specifico

8
Scusa ma potrebbe essere una cosa naturale..quando fai l'upgrade con jupgrade i componenti che non fanno parte del core di joomla li perdi tutti...quindi devi installare quel componente.

(Io ho invece un altro problema, cioè quello dell'articolo non trovato, che è invece un bug..ma credo posterò il tutto in un altro thread.)

9
Ciao maicolstaip!

Non posso credere che fosse così semplice!  :D


Nel mio htaccess c'era pure scritto questo:
Codice: [Seleziona]
#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /


..ma da profano non potevo immaginare.. Domani mattina "scommento" immediatamente, perché ho tutto su un altro pc.

EDIT
Il giorno dopo..
Okay, ho capito qual è il problema. Non c'entra il rewrite base.
Ho fatto un sacco di prove, ma alla fine quella che è più servita era anche la più logica.
Se tolgo la Joomla core SEF SECTION presente nell'htaccess, allora funziona tutto perfettamente.
Senza questa infatti, il redirect va a meraviglia. Cioè se vado su miosito.com, mi ridirige a www.miosito.com

L'unico inconveniente è che poi tutti i miei link (che funzionano con sef urls) non vanno perchè, diciamocelo, è un hack delle palle. Allora devo andare in conf. di joomla e disimpostare il sef url per fare un lavoro fatto bene. Così tutto va, ma in questo modo perdo le sef url che sono invece una gran cosa. E se ho fatto tutto ciò a fini SEO, allora sarei un fesso!

In pratica..io non conosco il php, però posso certamente dire che la soluzione di mmleoni è totalmente in conflitto con joomla con sef urls attive.

Un ringraziamento a maicolstaip per il supporto morale che mi ha portato sulla buona strada per capire il problema.  ;)

10
Qualcuno ha un suggerimento?  ;D

11

Bell'articolo  :)



Io ho un'osservazione.


Cito uno stralcio dell'articolo:
Citazione
Frequenza di ribalzo, permanenza sul sito, numero di pagine visitate dall’utente, sono segnali che il motore sembra prendere in considerazione per penalizzare o premiare un sito web.


Beh, ecco, scemo chi (me compreso, ma almeno consapevole) permette a GATC di utilizzare i propri dati di traffico interno a scopi estranei al monitoraggio interno dell'utente webmaster. Io l'ho sempre detto, perché dare informazioni gratuite a Big G, specie se queste possono esserti ritorcerti contro.


Penso che la stragande maggioranza di chi usa GATC non sappia di aver sottoscritto un accordo con Google con cui gli delega il diritto di utilizzare i propri dati di traffico (certo, sì, anonimamente...). In ogni caso, ciò sicuramente consente a g di fare studi di settore molto approfonditi ed ottenere informazioni che altrimenti non avrebbe, ovvero quella del comportamento dell'utente durante la permanenza su di un sito web esterno (dunque freq. di rimbalzo, ecc.)


In pratica Big G ci studia da quando "nasciamo" a quando "moriamo", telematicamente parlando, ovvero da quando facciamo una ricerca sul loro motore a quando ci stacchiamo dal browser, perché magari ci siamo rotti di stare davanti al PC (peraltro con implicazioni di tipo etico evidenti). Non solo il SEO è un argomento caldo, voglio dire, considerati i risvolti indiretti desumibili dal tuo articolo. Ora sono un po' OT e smetto  :D

12
Ciao mmleoni, sto provando la tua guida, a fini SEO, la sezione per reindirizzare da / al www.

Purtroppo non riesco a farla funzionare o meglio...

1) se uso il mod rewrite da te proposti (sia quello col nome da inserire sia quella da te ottimizzato che non richiede la personalizzazione del codice) non cambia nulla, ovvero non ridirige al www.

2) se provo a usare la sintassi
Codice: [Seleziona]
Redirect 301 / http://www.miosito.com/il browser (chrome, mozilla, opera, ecc) mi dà quest'errore:
Citazione
Questa pagina non reindirizza in modo corretto       

Firefox ha rilevato che il server sta reindirizzando la richiesta per questa pagina in modo che non possa mai essere completata.

 *   Questo problema spesso è causato dal blocco o dal rifiuto dei cookie.
Ho provato anche dal panello di amministrazione fornito dal mio hosting provider, che non fa altro che adottare la soluzione 2, ovvero aggiungere tale riga al mio file  .htaccess. Dando coerentemente sempre il solito errore.


NOTE:Sto usando Joomla 1.5, con htaccess attivo. Allego file htaccess rinominato con estensione ".txt" solo a fini di upload sul forum

Non conosco il php, potrebbe esserci qualche conflitto? Per questo motivo l'ho postato.


Inoltre, ho provato anche con il componente ReDJ, ma credo faccia la stessa cosa della soluzione 1, senza alcun effetto.


[allegato vecchio più di un anno eliminato da un amministratore]

13
Non ho un cellulare compatibile, tuttavia segnalo:

"whit" anzichè "with"

LuxorTheFirst, il Rompi-bug

[allegato vecchio più di un anno eliminato automaticamente]

14
Joomladay / Re:JoomlaDay Italia 2010
« il: 05 Lug 2010, 18:09:27 »

      ##  #######   #######  ##     ## ##          ###    ########     ###    ##    ##
      ## ##     ## ##     ## ###   ### ##         ## ##   ##     ##   ## ##    ##  ## 
      ## ##     ## ##     ## #### #### ##        ##   ##  ##     ##  ##   ##    ####   
      ## ##     ## ##     ## ## ### ## ##       ##     ## ##     ## ##     ##    ##   
##    ## ##     ## ##     ## ##     ## ##       ######### ##     ## #########    ##   
##    ## ##     ## ##     ## ##     ## ##       ##     ## ##     ## ##     ##    ##   
 ######   #######   #######  ##     ## ######## ##     ## ########  ##     ##    ##   

 ___   ___  __  ___ 
|__ \ / _ \/_ |/ _ \
   ) | | | || | | | |
  / /| | | || | | | |
 / /_| |_| || | |_| |
|____|\___/ |_|\___/ 
                   


Volevo emulare la suddetta impresa :D

Beh, Viva il Joomla Day

15
ahem ... si :P per il momento ne sà piu google translate di inglese, il mio è ancora modesto per tradurre contenuti complessi :)

Non credo sia una vergogna.  :D

perchè? ha intrinseco questo codice quando traduci?

Non so se proprio quello che hai postato ma uno che ha lo stesso effetto.

16
Mi viene questo sospetto..stai per caso traducendo con Google Translate?

17
Ma non puoi mettere a posto il sorgente originale?  ???

Citazione
" onmouseover="this.style.backgroundColor='#ebeff9'"

Chettenefai? L'hai messo te o te lo sei ritrovato?

Toglilo..

18
Gestione sito multilingua / Re:errore di joomfish
« il: 28 Giu 2010, 17:51:55 »
@ atalunga

Pura curiosità..come hai risolto?

Hai aggiornato Joomfish

...o hai fatto un downgrade di joomla?  :P

19
Gestione sito multilingua / Re:Sito multilingua
« il: 28 Giu 2010, 17:49:42 »
devo fare un sito multilingua (italiano spagnolo francese)
Ho letto che con joom!fish non si possono nascondere le voci di menù non tradotte...... c'è qualche alternativa??

Tokki, benvenuto nel mondo di Joomfish. Ho avuto le tue stesse rimostranze, ma a parte qualche trucchetto non puoi fare molto. Infatti quella che dici tu sarebbe la cosa migliore, ma non si può fare.  :-\

Alla fine l'unica quanto massiccia soluzione è quella che ti propone il caro Jecko.  :D

Io non l'ho adottata perché tieni presente che più siti joomla devi gestire, più scleri.  >:(

20
Gestione sito multilingua / Re:Guestbook e Joom!Fish
« il: 28 Giu 2010, 17:44:56 »
In:

Codice: [Seleziona]
administrator/components/com_joomfish/contentelements

Pagine: [1] 2 3 4 ... 11
Host

Torna su