Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - fbcyborg

Pagine: [1] 2 3
1
Salve a tutti,

ho un problema con PhocaGallery. Non si sa per quale ragione, mi trovo molte immagini duplicate nella mia galleria di immagini, e non so come fare per togliere i duplicati, dal momento che sono un sacco di immagini. Qualcuno ha un'idea di come poter risolvere?

2
Salve a tutti,

sto cercando di riscrivere un modulo di pagamento per la spedizione in contrassegno.
Il modulo di pagamento dal quale sto partendo è questo:
administrator/components/com_virtuemart/classes/payment/ps_cashondel.php il quale presenta la seguente funzione:
Codice: [Seleziona]
function get_payment_rate($sum)
{
  /*** Get the Configuration File  ***/
  require_once(CLASSPATH ."payment/".$this->classname.".cfg.php");
  if ($sum < 500)
    return -(CASH_ON_DEL_500);
  else if ($sum < 5000)
    return -(CASH_ON_DEL_5000);
  elseif ($sum < 10000)
    return -(CASH_ON_DEL_10000);
  elseif ($sum < 20000)
    return -(CASH_ON_DEL_20000);
  elseif ($sum < 30000)
    return -(CASH_ON_DEL_30000);
  elseif ($sum < 40000)
    return -(CASH_ON_DEL_40000);
  elseif ($sum < 50000)
    return -(CASH_ON_DEL_50000);
  elseif ($sum < 100000)
    return -(CASH_ON_DEL_100000);
  else
    return -(CASH_ON_DEL_100000);

//    return -($sum * 0.10);
}

Vorrei modificare la precedente parte di codice nella seguente:
Codice: [Seleziona]
function get_payment_rate($sum)
{
  /*** Get the Configuration File  ***/
  require_once(CLASSPATH ."payment/".$this->classname.".cfg.php");
  if ($sum < 500)
    return -(CASH_ON_DEL_500);
  else
    return -($sum * 0.10);
}

Il problema è che la variabile $sum è sempre pari a 0 in quel punto del codice, quindi non funziona.
A me servirebbe il valore della variabile $subtotal del file administrator/components/com_virtuemart/html/basket.php invece di $sum, solo che non riesco a reperirlo.
Qualcuno saprebbe darmi una mano?

3
Joomla! 1.5 / Problemi installazione Acajoom 3.2.7
« il: 22 Set 2010, 12:16:46 »
Salve a tutti,

premesso che ho già letto qui, qui e qui, non riesco proprio ad installare bene questo componente per le newsletter.

L'errore che ottengo sempre a fine installazione è il seguente:

Codice: [Seleziona]
Configurazione Acajoom : Installazione riuscita
Codice: [Seleziona]
Plugin (Bot)Acajoom :
Error copying bot file acajoombot.php to bot directory.
Error copying bot file acajoombot.xml to bot directory.
Error copying bot file index.html to bot directory.
Error deleting the temporary bot directory.Errore installatione

Codice: [Seleziona]
Modulo Acajoom :
Error copying module file mod_acajoom.php to module directory .
From /var/www/vhosts/mydomain.com/httpdocs/administrator/components/com_acajoom/modules/mod_acajoom.php To /var/www/vhosts/mydomain.com/httpdocs/modules/mod_acajoom/mod_acajoom.php
Error copying module file mod_acajoom.xml to module directory .
From /var/www/vhosts/mydomain.com/httpdocs/administrator/components/com_acajoom/modules/mod_acajoom.xml To /var/www/vhosts/mydomain.com/httpdocs/modules/mod_acajoom/mod_acajoom.xml
Error deleting : /var/www/vhosts/mydomain.com/httpdocs/administrator/components/com_acajoom/modules/index.htmlErrore installatione

Se installo in locale, tutto ok ma sul sito online non ci riesco.

Ho provato a installare i moduli separatamente ma non c'è verso di installare tutto correttamente. Ho anche settato i permessi tramite Filezilla, ma niente. Suppongo sia un problema di permessi ma anche facendo come dice non risolvo.

Provando jNewsletter, ho gli stessi problemi, anzi peggio.

C'è per caso una procedura di installazione manuale che al momento non trovo?

4
Salve a tutti,

come da titolo, vorrei sapere se e come si possa fare un indice articolo multi colonna. Ho modificato il CSS per farlo apparire in testa ad ogni pagina poiché al lato mi occupava troppo spazio.
Siccome ho molte interruzioni di pagina, vista la lunghezza dell'articolo, vorrei poter mantenere un indice di navigazione in alto nella pagina in modo che non occupi troppo spazio in altezza. Per tale ragione stavo cercando di metterli su più colonne.

Qualcuno mi sa aiutare?

5
Salve a tutti,

vorrei aggiornare JEvents, che attualmente è alla versione 1.4.3 RC2, all'ultima versione (1.5.4).
Ho trovato questa guida, solo che non mi è chiaro quale patch bisogna scaricare per aggiornare il componente, dato che non viene indicato.
Sul sito l'unica patch che c'è è la RSS Feed Event Date Bug Fix, proprio nella sezione patch. Di file di aggiornamento non ne vedo.

Qualcuno ha idea di quale file sia necessario?

6
Salve a tutti,

ho appena installato Phoca Gallery e quando vado nella sezione Immagini del componente ottengo questi warning:
Codice: [Seleziona]
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/localhost/htdocs/website/libraries/joomla/database/database/mysql.php  on line 344

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/localhost/htdocs/website/libraries/joomla/database/database/mysql.php on line 344

Warning: Invalid argument supplied for foreach() in /var/www/localhost/htdocs/website/administrator/components/com_phocagallery/libraries/phocagallery/render/renderadmin.php on line 65

Ho già visto in questo forum. C'è qualcuno che ha risolto riparando tabelle crashate, ma non è una soluzione valida per me. Inoltre è per Ozio Gallery.

Inoltre se entro in Categorie, ho questo altro warning:
Codice: [Seleziona]
Warning: Invalid argument supplied for foreach() in /var/www/localhost/htdocs/website/administrator/components/com_phocagallery/models/phocagallerycs.php  on line 126
In Voto Categorie:
Codice: [Seleziona]
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/localhost/htdocs/website/libraries/joomla/database/database/mysql.php on line 344

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/localhost/htdocs/website/libraries/joomla/database/database/mysql.php on line 344

Warning: Invalid argument supplied for foreach() in /var/www/localhost/htdocs/website/administrator/components/com_phocagallery/libraries/phocagallery/render/renderadmin.php on line 65

Stesso problema in Voto Immagini, Commenti Categorie|Immagini e Utenti.

Qualcuno sa darmi una mano?

Ho risolto, grazie lo stesso.
Ho trovato per fortuna questa pagina, magari può essere di aiuto a qualcun'altro che incappa nello stesso problema.

7
Salve a tutti,

è da un po' che non faccio l'upload di foto sul mio sito, con expose.
Stavoprovando ad aggiungere delle foto ad un album, sia con l'upload dal manager che tramite il bucket, ma all'atto della pressione del tasto upload, le foto non vengono messe nell'album.

Da cosa può dipendere?

8
Salve a tutti,

stavo cercando un modulo molto semplice che mi consente di fare una cosa altrettanto semplice, ma non lo trovo.
In pratica ho bisogno di inserire una lista di "parole" o "titoli" in una delle colonne laterali del template. Siccome la lista potrebbe essere più o meno lunga, e non vorrei che questo mi facesse sprecare troppo spazio, visto che ho già altri moduli piazzati, mi sapete dire se esiste un moduletto che prende in ingresso una lista e la mostra con una scroll bar verticale?

9
Joomla! 1.5 / Rilasciata la versione 1.5.17 di Joomla!
« il: 27 Apr 2010, 23:41:17 »
Finalmente, dopo "lunga" attesa, l'aggiornamento alla versione 1.5.17 è stato rilasciato.

Via con gli upgrade!

10
Joomla! 1.5 / menu seo scomparso
« il: 27 Apr 2010, 08:44:02 »
Mi sono appena accorto che il menu SEO, in configurazione non si apre più. Spero si corregga anche questo con l'aggiornamento di oggi.

11
Gestione e-commerce / Dubbio sull'utilizzo di https
« il: 16 Apr 2010, 10:48:14 »
Salve a tutti,

mi è venuto un dubbio circa l'utilizzo di https in Virtuemart.
Ho visto che c'è una sezione nella configurazione di Virtuemart, in cui si possono specificare quali siano le sezioni che devono essere visitate dai navigatori, che devono essere accedute tramite SSL. Ebbene, ho impostato tutto correttamente ma ho un dubbio.
Il mio hosting mi fornisce due directory, una per i contenuti http e una per i contenuti https. Io ora ho installato joomla sia nell'una che nell'altra, in modo che vi siano i sorgenti php sia per quanto riguarda la navigazione in chiaro che per quella crittografata.
Secondo voi ha senso una cosa del genere? In caso negativo, quale soluzione proponete?

Grazie

12
Salve a tutti,

ho un problema con le miniature.
Sebbene io abbia selezionato "Abilita il Ridimensionamento Dinamico delle Immagini" e abbia specificato sia una larghezza che una altezza della miniatura, le miniature non vengono ridimensionate.
Le directory risultano scrivibili, ma una volta specificato l'URL di una immagine per un certo prodotto, sia in com_virtuemart/shop_image/product che in com_virtuemart/shop_image/product/resized non c'è alcuna immagine salvata.

Quello che succede è che se visualizzo (nel frontend) la lista dei prodotti uno per riga, vedo le immagini a dimensione naturale e se ci clicco sopra mi si apre un popup con l'immagine più piccola (che si ingrandisce se ci si clicca sopra).

Quale potrebbe essere il problema?
Come da titolo, non è un problema di GD, visto che la mia versione di PHP è stata compilata con tale supporto.

NOTA BENE: questo problema si verifica solo ed esclusivamente se utilizzo un URL per specificare l'immagine del prodotto. A questo punto questo sistema a che serve? Non funziona bene? Perché se io inserisco una immagine tramite il tasto sfoglia non ci sono problemi.

13
Salve a tutti,

ho un problema con le miniature dei prodotti in virtuemart 1.1.4.
Quando inserisco un prodotto, se vado in Immagini Prodotto ed inserisco sia l'URL dell'immagine, e la miniatura automatica, questa non mi viene mostrata nel frontend.
Se invece non metto nulla, nella lista dei prodotti nel frontend, al posto della miniatura ottengo il nome del prodotto.
Cliccandoci sopra, mi si apre un popup che mostra il seguente messaggio:
Citazione
Not Found

The requested URL /joomla/components/com_virtuemart/themes/default/images/add-to-cart.png was not found on this server.

Non capisco perché cerchi il file add-to-cart.png.
Per prova ho convertito il file add-to-cart.gif in png sempre nella stessa directory, ed ovviamente mi fa vedere il pulsante per l'add to cart.

Oltre a questo, ho notato che a seconda del fatto che venga visualizzata un'immagine o meno, gli articoli vengono visualizzati un po' in modo disordinato.

Qualcuno può farmi apire cosa sta succedendo?

Grazie!

EDIT: ho risolto cambiando immagine nella configurazione di virtuemart (Sito->"Immagine no foto").
Comunque ancora non capisco perché, se era selezionato add-to-cart.gif, mi andava a cercare add-to-cart.png. Mah! Mistero...

Grazie a tutti per la collaborazione.

14
Salve a tutti,

vorrei sapere come si può aumentare la distanza fra la descrizione di una categoria e un'altra, quando si è in modalità Aspetto sezione - lista categorie in modalità blog.

Chiedo questo perché  ho inserito una descrizione con una immagine sulla sinistra, per ogni categoria, e siccome appena finisce la descrizione, va a capo e mostra la descrizione della successiva categoria, ho un problema di incasinamento con le immagini che talvolta sono più alte del testo scritto.

Come posso risolvere?

15
Gestione e-commerce / Poste.it ecommerce + Virtuemart
« il: 21 Gen 2010, 08:53:32 »
Salve a tutti,

sto facendo un sito di ecommerce per la prima volta ad un amico che vorrebbe aprire un'attività commerciale online.
Sebbene abbia appreso la maggior parte delle funzioni di Virtuemart, mi rimangono ancora alcuni punti oscuri fra cui il sistema di pagamento.

Supponiamo che voglia accettare come forma di pagamento, solo la carta di credito. I miei dubbi sono i seguenti:

1) come funziona (come aggancio) tutto il motore di pagamento a Virtuemart?

2) Il mio amico vorrebbe utilizzare il servizio di ecommerce di poste.it. Il tutto per usufruire di un servizio di etichettamento dei pacchi, pagamenti, ecc. E' possibile "agganciare" virtuemart e questo servizio?

Ho cercato in giro, ma sfortunatamente ancora non sono riuscito a trovare qualcosa che mi dia una risposta. :( Molto probabilmente sono sfortunato perché di solito mi basta Google e trovo quasi tutto.

Grazie a chi mi potrà aiutare!

16
Qualcuno può dirmi se è possibile (e come) creare un articolo che abbia in cima del testo, e poi una galleria di immagini fatta con Exposé?

Grazie

17
Gestione sito multilingua / [risolto]Bandierine incasinate
« il: 28 Giu 2009, 10:22:31 »
Messaggio eliminato.

Grazie per il vs. supporto.

18
Salve, ho impostato Phoca guestbook in modo che ad ogni messaggio inserito venga recapitata un'email ad un certo utente, solo che le email non arrivano. Perché?
Succede anche a voi?

19
Gallerie di immagini / Expose 4: caratteri illeggibili
« il: 04 Gen 2009, 14:59:38 »
Quando apro la mia Galleria, le scritte "Select an album" e "Photo Gallery" si leggono malissimo. Già se provo con Firefox 3 da Linux riesco ancora a leggere quelle scritte, ma da windows è praticamente illeggibile per non parlare del software proprietario IE.

20
Joomla! 1.5 / [RISOLTO]Posizione footer non disponibile
« il: 29 Dic 2008, 23:48:19 »
Salve,

non capisco perché non mi viene più visualizzata la posizione footer quando voglio decidere dove posizionare un modulo. Compaiono solamente: banner, breadcrumb, left, right, user1, user2, user3 e user4.

Eppure non ho modificato nulla nel template. Perché accade questo?

Ecco come dovrebbe apparire:

Ecco invece come appare:



RISOLTO: il problema era dovuto ad un casino creato dallo script di migrazione. Aaahhrg.. dannati script!
In pratica, nella tabella jos_templates_menu, era rimasto il nome del vecchio template utilizzato nella versione 1.0.15 di Joomla, e quindi ovviamente non tornavano le cose. Spero sia utile a qualcun altro.

Pagine: [1] 2 3
Host

Torna su