Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - parsifaltheking

Pagine: [1]
1
Premetto che nella 3.6.5 funzionava tutto correttamente.
Le associazioni le ho controllate anche nella nuova voce multilingual associations e mi dice che l'articolo italiano è associato al corrispondente inglese e viceversa.
Il problema è che se sono nell'articolo italiano www.dominio.it/it/gruppiantincendio/gruppien1284 quando clicco sulla bandiera inglese mi viene generato il relativo indirizzo per la parte inglese però con la lingua sbagliata ovvero :  /it/Fire-Fighting/FireEn-12845-Standard.html invece di  /en/Fire-Fighting/Fire-Fighting-12845-Standard.html.

Nel sito ho anche il plugin sf404sef installato... ho provato a disattivarlo e cosi funziona ovvero cambia correttamente la lingua...
a questo punto provo a lasciarlo disattivato e chiedo supporto nel sito dello sviluppatore.

Grazie

2
Salve a tutti,
ho un problema con Joomla 3.7.0 in merito ad un sito multilingua. IT/ENG
Quando vado sulla prima pagina in IT carica correttamente, quando uso il modulo language switcher per cambiare la lingua se vado sulla bandierina inglese il percorso è sempre dominio/IT/Home.html e ricarca la pagina in italiano.
Premetto che ho provato a disabilitare il plugin Page Cache, ho disabilitato la cache nella configurazione globale, ho sostiuito il file file.php nella gestione cache, ho cancellato la cache e disabilitato il plugin language Code ma non è cambiato nulla.
Se accedo a www.dominio.it/it/home.html funziona tutto il sito in italiano, se accedo a www.dominio.it/en/home.html funziona tutto il sito in inglese, se cambio da una lingua all'altra non lo fa...
Ah ho provato a cambiare anche da php 5.6.30 a 7 ma non cambia nulla.

Ho letto tutti i post collegati che segnalano il problema risolto ma per me non è cosi...

Cosa posso fare? Tornare alla 3.6.5 ?

Grazie

3
Joomla! 3 / problema multilingua dopo aggiornamento 3.7.0
« il: 27 Apr 2017, 12:49:23 »
Salve,
mi ritrovo anch'io con la versione 3.7 aggiornata dalla 3.6.5 nella quale però non riesco ad utilizzare il cambio lingua.
Il sito ha la lingua italiana e inglese con i prefissi it ed en.. ho visto qui  https://issues.joomla.org/tracker/joomla-cms/15579   
il problema del redirect e ho il plugin disabilitato. In pratica anche se clicco non passa all'altra lingua ma resta sempre li.
Inoltre se lo faccio da dentro un articolo ottengo questo errore:

jos-Warning[/size]: exception 'RuntimeException' with message 'Error decoding JSON data: Syntax error' in /var/www/vhosts/fourgroup.it/httpdocs/libraries/vendor/joomla/registry/src/Format/Json.php:72 Stack trace: #0 /var/www/vhosts/fourgroup.it/httpdocs/libraries/vendor/joomla/registry/src/Registry.php(366): Joomla\Registry\Format\Json->stringToObject('{"menu_image":"...', Array) #1 /var/www/vhosts/fourgroup.it/httpdocs/libraries/vendor/joomla/registry/src/Registry.php(72): Joomla\Registry\Registry->loadString('{"menu_image":"...') #2 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/models/article.php(162): Joomla\Registry\Registry->__construct('{"menu_image":"...') #3 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/view/legacy.php(422): ContentModelArticle->getItem() #4 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/views/article/view.html.php(42): JViewLegacy->get('Item') #5 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/controller/legacy.php(671): ContentViewArticle->display() #6 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/controller.php(113): JControllerLegacy->display(true, Array) #7 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/controller/legacy.php(709): ContentController->display() #8 /var/www/vhosts/fourgroup.it/httpdocs/administrator/components/com_sh404sef/helpers/error.php(235): JControllerLegacy->execute(NULL) #9 /var/www/vhosts/fourgroup.it/httpdocs/administrator/components/com_sh404sef/helpers/error.php(63): Sh404sefHelperError::render(Object(JException), 'The page you re...') #10 /var/www/vhosts/fourgroup.it/httpdocs/administrator/components/com_sh404sef/classes/router.php(1806): Sh404sefHelperError::render404ErrorDocument(Object(JException)) #11 [internal function]: Sh404sefClassRouterInternal->sh404sefErrorPage(Object(JException)) #12 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/error/error.php(780): call_user_func(Array, Object(JException)) #13 [internal function]: JError::handleCallback(Object(JException), Array) #14 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/error/error.php(241): call_user_func_array(Array, Array) #15 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/error/error.php(202): JError::throwError(Object(JException)) #16 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/error/error.php(277): JError::raise(1, 404, 'Articolo non tr...', NULL, true) #17 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/models/article.php(152): JError::raiseError(404, 'Articolo non tr...') #18 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/view/legacy.php(422): ContentModelArticle->getItem() #19 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/views/article/view.html.php(42): JViewLegacy->get('Item') #20 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/controller/legacy.php(671): ContentViewArticle->display() #21 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/controller.php(113): JControllerLegacy->display(true, Array) #22 /var/www/vhosts/fourgroup.it/httpdocs/libraries/legacy/controller/legacy.php(709): ContentController->display() #23 /var/www/vhosts/fourgroup.it/httpdocs/components/com_content/content.php(39): JControllerLegacy->execute(NULL) #24 /var/www/vhosts/fourgroup.it/httpdocs/libraries/cms/component/helper.php(394): require_once('/var/www/vhosts...') #25 /var/www/vhosts/fourgroup.it/httpdocs/libraries/cms/component/helper.php(369): JComponentHelper::executeComponent('/var/www/vhosts...') #26 /var/www/vhosts/fourgroup.it/httpdocs/libraries/cms/application/site.php(191): JComponentHelper::renderComponent('com_content') #27 /var/www/vhosts/fourgroup.it/httpdocs/libraries/cms/application/site.php(230): JApplicationSite->dispatch() #28 /var/www/vhosts/fourgroup.it/httpdocs/libraries/cms/application/cms.php(265): JApplicationSite->doExecute() #29 /var/www/vhosts/fourgroup.it/httpdocs/index.php(49): JApplicationCms->execute() #30 {main}


Mi conviene ripristinare il backup pre-aggiornamento 3.6.5 e aspettare la correzzione o entro qualche giorno potrebbe arrivare l'aggiornamento che risolve il problema?

Grazie

[/color]

4
Salve a tutti e complomenti per la galleria.
Ho solo un problema di allineamento delle prime due righe della pagina "lista album" in quanto sono spostate a sinistra e non riesco a capire il motivo".
La pagina dove potete verificare il problema è questa:

http://www.dunebuggy.it/i-raduni.html

Grazie

5
Grazie adesso funziona.. magari aggiungilo nella guida perchè non avevo trovato questo passo.


6
Buongiorno, ho seguito la tua guida su joomla 2.5.6 e ho impostato l'editor a None oppure a Codemirror.
In entrambi i casi quando incollo il codice esso viene modificato e non funziona:

codice addthis sito

<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_facebook_like" fb:like:layout="button_count">[/url]
<a class="addthis_button_tweet">[/url]
<a class="addthis_button_google_plusone" g:plusone:size="medium">[/url]
<a class="addthis_counter addthis_pill_style">[/url]
</div>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4fe8242c3590843e"></script>
<!-- AddThis Button END -->

codice salvato da joomla

<div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_facebook_like" fb:like:layout="button_count">[/url]
<a class="addthis_button_tweet">[/url]
<a class="addthis_button_google_plusone" g:plusone:size="medium">[/url]
<a class="addthis_counter addthis_pill_style">[/url]
</div>
var addthis_config = {"data_track_addressbar":true};

praticamente rimuove tutta la parte degli script.
Come posso risolvere?

Grazie
Andrea

7
Complimenti per il componente, veramente ben fatto.. non so se scrivo nella sezione giusta ma volevo esporti un problema: nel modulo contatti ho la necessità di aggiungere la normativa della privacy e la casella per la spunta prima di inviare la richiesta.
Il testo da inserire è il seguente:

Con l'invio del presente modulo acconsento al trattamento dei dati unicamente per la richiesta in oggetto. Consenso esplicito secondo il D.Lgs 196/2003. (Spunta per conferma)

Se lo aggiungo però il campo non viene accettato per la presenza del . e della /

Ora ho ovviato inserendo la seguente dicitura:

Inviando il presente modulo acconsento al trattamento dei dati unicamente per la richiesta in oggetto secondo il decreto Legislativo 196 del 2003

Ti volevo chiedere se era possibile permettere quei caratteri; inoltre non so se è possibile includere anche una casella che permetta di inviare una copia della mail anche alla persona che scrive come fa il modulo standard di joomla e se è possibile scegliere la risposta che viene inviata al ricevente: nel mio caso il ricevente riceve i dati del form e nella checkbox di prima

Inviando il presente modulo acconsento al trattamento dei dati unicamente per la richiesta in oggetto secondo il decreto Legislativo 196 del 2003: 1

ottiene un 1.
Non so se è possibile cambiarlo in un SI.

Grazie ancora per il lavoro e se ho scritto nella sezione sbagliata scusatemi ma questo componente mi piace proprio e lo voglio utilizzare quotidianamente nel mio lavoro perchè è proprio utile e semplice.



Pagine: [1]
Host

Torna su