Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - Fabri64

Pagine: [1] 2 3 4 ... 8
1
Gestione Form / Calcolo età
« il: 10 Mag 2017, 15:18:57 »
Buongiorno
Sto gestendo dei dati anagrafici con Chronoform5.
Volendo mostrare sul mio sito i nominativi dei ragazzi che compiono gli anni, ho costruito una
connessione con ChronoConnectivity5. Quindi come condizione ho
<?php
$today = date('%-m-d');
return array('visualizza.eliminare' => '1' ,'visualizza.data LIKE' => "%$today%");
?>

In frontlist ho scritto

 <td ><?php
$alfa="{visualizza.immagine}";
$beta='<img class="img-thumbnail"  WIDTH="150" src="' ;
$gamma = 'http://' . $_SERVER['HTTP_HOST'] . "/" . basename(dirname($_SERVER['PHP_SELF']));
$delta="/images/per_database/upload/foto/";
$teta='" />';
echo $beta.$bet.$gamma.$delta.$alfa.$teta ;
?></td>
      </tr>
      <tr>
<td><font face="Verdana" size="4" >{visualizza.cognome} </font></td>

       
      </tr>
<td><font face="Verdana" size="3" >{visualizza.nome} </font></td>
       
      <tr>
        <td><font face="Verdana" size="2" >{visualizza.data}</td>
      </tr>
       
Il risultato finale mi compare la foto con il nome, cognome e data di nascita.

Ora volevo che al posto della data di nascita mi compare la scritta.... "Che oggi compie XX anni!"
Ho cercato e provato varie formule ma niete...non riesco proprio a calcolare gli anni dalla data di nascita.

Come posso fare?
Grazie

2
Gestione utenti e community / Integrazione cb 2.0.14 con K2
« il: 27 Lug 2016, 16:33:20 »
Salve
 Ho aggiornato il componente K2 alla versione 2.7.0  ma ho notato che non c'è piu la possibilità di  Integrazione con Community Builder per avatar, nomi utenti e pagine utente. Almeno non lo piu trovato nelle opzioni da poterlo configurare. E' proprio così?

3
Gestione Form / Re:Submit e stampa
« il: 15 Feb 2016, 16:19:56 »
Si lo vedevo....ma cmq il codice lo inserito in un custom code come seconda pagina e funziona alla perfezione. Stampo e poi salvo i dati.

4
Gestione Form / Re:Submit e stampa
« il: 15 Feb 2016, 12:27:52 »
No...il percorso é giusto perché in custom code funziona!!

5
Gestione Form / Re:Submit e stampa
« il: 14 Feb 2016, 18:21:16 »
Se tolgo l'action connection appare il messaggio (non in popup) però non funziona il pulsanta stampa. Non esce l'icona stampa solo la scritta e non è cliccabile.
In teoria ho risolto tornando a visualizzare la pagina con il tuo codice in custom code e un pulsante submit. Quindi in teoria posso stampare....dopo stampato clicco su submit e ritorno in chronoconnectivity con i dati salvati. Certo l'ideale sarebbe che dopo la stampa si salvi automaticamente ma forse non si puo fare....credo

6
Gestione Form / Re:Submit e stampa
« il: 14 Feb 2016, 14:21:17 »
Fatto Vales ma il messaggio non appare.
Ovviamente l'action Display Messagge va inserita in on submit?
Lo inserito sia prima che dopo  connection action ma non funziona

7
Gestione Form / Re:Submit e stampa
« il: 13 Feb 2016, 13:33:41 »
Dpo la stampa dovrei per forza chiudere la pagina e salvare i dati in modo di che sono sicuro che i dati sono stati salvati. In modo che se un altro utente aggiunga lui i dati ho la sicurezza che si aggiornano. Si una soluzione sarebbe quella di rimanere sulla stessa pagina ma se poi, per qualche motivo,  non clikka su submit non mi salva i dati

8
Gestione Form / [Risolto]Submit e stampa
« il: 13 Feb 2016, 12:14:30 »
Salve
Avrei la necessita di stampare una ricevuta.
Con Chronoconnectivity5 ho creato a una connessione con un form mutipage. Nella prima pagina inserisco i dati...invio e passo alla seconda pagina nella quale ho creato con custom code la mia ricevuta con tutti i dati aggiornati.
Ora ho due possibilità:
La prima tasto submit e ritorno alla pagina di chronoconnectivity con i dati aggiornati.
La seconda, ho inserito un codice che mi stampa la ricevuta solo che una volta aperta la pagina di stampa il form si chiude...ritorna alla pagina di chronoconnectivity ma i dati ovviamente non si aggiornano. Allora ho aggiunto al codice "event" in questo modo:

<div style="float: right; clear:left;" id="PSR_print"><a href="<?php echo JURI::base()."iscritti/quote?option=com_chronoconnectivity5&cont=lists&act=index&ccname=Iscritti_gestione_quote&act=edit&gcb={iscritti.cf_id}&event=submit"?>"onclick="printDiv('foo02')"><img src="<?php echo JURI::base().'images/printButton.png';?>" alt="Stampa"/>
[/url]</div>
Pensavo di aver risolto il problema...infatti ho stampato sono tornato alla  pagina di chronoconnectivity con tanto di scritta in alto Saved Successfully ma i dati non sono stati salvati.
Sicuramente sbaglio qualcosa...ma non so come fare o ci sarà un'altra soluzione la mia esigenza.
Spero di essere stato chiaro
Grazie

9
Gestione Form / Re:limite di pagine in Chronoconnectivity 5
« il: 09 Ago 2015, 12:18:42 »
Non so  per quale inspiegabile motivo....almeno per me....ora che ho invertito i modelli di una connessione che non funzionava, si comporta nella maniera giusta!! Ora provo su le altre connessioni. Puoi darmi una spiegazione?

10
Gestione Form / Re:limite di pagine in Chronoconnectivity 5
« il: 08 Ago 2015, 19:00:34 »
Poi cancelo i cookie e funziona ma poi faccio il login e niente....di nuovo due righe.Non riesco proprio a capire

11
Gestione Form / Re:limite di pagine in Chronoconnectivity 5
« il: 08 Ago 2015, 18:54:41 »
restituisce le 50 riche...e tutte le altre connessioni funzionano. Poi esco....rifaccio il login ed ecco che compaiono solo due righe.Ma qualche connessione invece funziona!!! che casino, non ci caèpisco piu nulla.

12
Gestione Form / Re:limite di pagine in Chronoconnectivity 5
« il: 08 Ago 2015, 15:05:59 »
Si diciamo che funziona cosi.
solo che non mi serve poter selezionare i numeri di righe. In effetti sono pagine di elenchi di giocatori da visualizzare e avere il _PAGINATOR_LIST_non serve. Lo messo per prova su un elenco....Ma la cosa strana, ma forse è normale, che se metto 20 come numero anche gli altri elenchi compaiono 20 righe. Se metto ALL anchele altre pagine si adeguono. Però io vorrei che comparissero tutti i nomi anche perchè massimo che arrivano sono una ventina.
Inoltre sull'eleco in cui ho iserito il _PAGINATOR_LIST_ quando cambio il numero non si aggiorna sulla stessa pagina ma penso sulla homepage.

13
Gestione Form / Re:limite di pagine in Chronoconnectivity 5
« il: 08 Ago 2015, 13:46:32 »
l'impostazione dei 50 lo fatta da backend. il problema è che la pagina la visualizzo correttamente. Ma quando faccio il login mio o di un altro utente si vedono solo due righe. cancello i cookie e tutto ritorna a posto. Ho anche individuato il cookie che provaca questo ma non so come fare....sto impazzendo

14
Gestione Form / Re:limite di pagine in Chronoconnectivity 5
« il: 08 Ago 2015, 08:55:53 »
ok .... si tratta di un problema di cookie. Ho eliminato i cookie ed è tornato tutto normale.  Il problema è che se si verifica lo stesso problema, devo di nuovo cancellare i cookie...rimane un pò assurdo. Ma  non capisco come posso fare

15
Gestione Form / limite di pagine in Chronoconnectivity 5
« il: 06 Ago 2015, 12:21:15 »
Buongiorno.
Ho una connesione in Chronoconnectivity 5 nella quale ho messo come limite di pagine impostato a 50, ma sulla mia pagina web vengono visualizzate solo due per volta. Non riesco a capire il motivo.Se però chiudo il browser ed elimino i cookie ritorno a vedere 50 record come impostato.

16
Gestione Form / ChronoConnectivity5 plugin
« il: 22 Lug 2015, 19:00:02 »
salve
Ho usato il plugin ChronoConnectivity5 in un articolo e pubblicato in una categoria. Funziona perfettamente. Ma se pubblico un secondo articolo sempre con il plugin la pagina non si carica e rimane bianca e mi da i seguenti errori
Strict Standards: Declaration of JParameter::loadSetupFile() should be compatible with JRegistry::loadSetupFile() in /web/htdocs/www.olimpicsaluzzo.it/home/libraries/joomla/html/parameter.php on line 512
Strict Standards: Only variables should be assigned by reference in /web/htdocs/www.olimpicsaluzzo.it/home/plugins/content/chronoforms/chronoforms.php on line 5
Strict Standards: Only variables should be assigned by reference in /web/htdocs/www.olimpicsaluzzo.it/home/plugins/content/chronoforms/chronoforms.php on line 16
Strict Standards: Only variables should be assigned by reference in /web/htdocs/www.olimpicsaluzzo.it/home/plugins/content/chronoforms/chronoforms.php on line 16
Strict Standards: Only variables should be assigned by reference in /web/htdocs/www.olimpicsaluzzo.it/home/plugins/content/chronoforms/chronoforms.php on line 16
Strict Standards: Only variables should be assigned by reference in /web/htdocs/www.olimpicsaluzzo.it/home/plugins/content/chronoforms/chronoforms.php on line 16
Fatal error: Cannot redeclare class GCore\Models\visualizza in /web/htdocs/www.olimpicsaluzzo.it/home/libraries/cegcore/libs/model.php(142) : eval()'d code on line 4
Grazie per l'aiuto

17
Gestione Form / Re:Connection action con chronoconnectivity 5
« il: 17 Giu 2015, 18:10:12 »
Se invece imposto su NO  in  "Edit action settings" di "HTLM (render form )" Funziona ma si apre nella pagina index.

18
Gestione Form / Re:Connection action con CC5
« il: 17 Giu 2015, 17:09:27 »
Sì scusa hai ragione. La tabella si chiama scuolacalcio

19
Gestione Form / Re:Connection action con CC5
« il: 17 Giu 2015, 17:07:33 »
Sì scusa hai ragione. La tabella si chiama scuolacalcio

20
Gestione Form / Connection action con chronoconnectivity 5
« il: 17 Giu 2015, 09:40:53 »
Salve...
Non rieco a risolvere un problema con CC5. Ho creato più connessioni tra CC5 e dei form con CF5 usado l'azione EDIT per modificare dei recor e funzionano tutti tranne una nella quale salvando mi viene una pagina bianca e non riesce a caricare la pagina di partenza. Premetto che in  "Edit action settings" di "HTLM (render form )" ho messo Yes in quanto voglio rimanere sulla stessa pagina, ma con questa connessione non si ricarica e rimane bianca e sulla barra degli indirizzi visualizzo

http://www.olimpicsaluzzo.it/iscritti/elenco_iscritti.html?cont=lists&ccname=Iscritti_Tutti&act=edit&gcb=2&chronoform=Iscritti_Iscrizioni&event=submit.
Credo si un problema di connessione ma non riesco a trovare il problema, anche perchè altre connessioni funzionano perfettamente. Ma questa no.


Pagine: [1] 2 3 4 ... 8
Host

Torna su