Autore Topic: "Moduli notizie" che NON si dispongono in modo "ordinato" in prima pagina  (Letto 3033 volte)

Offline alfaeomega

  • Esploratore
  • **
  • Post: 53
    • Mostra profilo
Ciao a tutti, ho questo problema,
ho scaricato un modulo notizie e l'ho "duplicato" in modo da averne 4 copie, ad ogni modulo ho abbinato una specifica categoria in modo che permetta di visualizzare solo gli articoli di quella categoria.
A questo punto volevo ordinare questi 4 moduli nella home page in modo che si dispongano su 2 colonne, 2 moduli posti in alto affiancati, e 2 moduli posto sotto, sempre vicini tra loro, invece accade che i 4 moduli si dispongono su 2 colonne, ma non in modo ordinato, ovvero "slittano" tra loro lasciando spazi "vuoti". Sapete dirmi perchè e come risolvere il problema?
il sito su cui vedere la problematica (se non posso postarlo avvisatemi) è:
http://www.turismoevacanze.it/
Grazie mille per l'aiuto

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
ciao controlla il modulo  che hai pubblicato
 quello viaggi  di avere il settaggio uguali agli altri .
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline alfaeomega

  • Esploratore
  • **
  • Post: 53
    • Mostra profilo
il modulo con le notizie "viaggi" è settato esattamente come gli altri, anche prechè da 1 modulo, con la funzione "duplica", ho generato gli altri 3. li ho semplicemente diversificati nel tipo di news che devono far apparire perchè ogni modulo è abbinato ad 1 specifica categoria di notizie, ma i settaggi sono identici per tutti e 4, eppure non so perchè, sul mio sito www.turismoevacanze.it invece  che comparire ordinati su 2 colonne, 2 moduli posti in alto affiancati, e 2 moduli posto sotto, sempre vicini tra loro, accade che i 4 moduli si dispongono su 2 colonne, ma non in modo ordinato, ovvero "slittano" tra loro lasciando spazi "vuoti"....sapete dirmi perchè e come risolvere il problema?

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18158
  • Sesso: Femmina
    • Mostra profilo
Ciao alfaeomega,
hai messo un finto testo troppo lungo, senza spazi. Lo interpreta come un'unica parola e lo fa slittare sotto la foto. Quindi spinge l'altro modulo. Metti un testo vero o almeno fai degli spazi.  ;)

Offline alfaeomega

  • Esploratore
  • **
  • Post: 53
    • Mostra profilo
ciao, grazie del consiglio ma putroppo non funziona....come vedi ho spezzato quel finto testo come se fossero piu parole, ma alla fine i moduli non si incolonnano, rimangono sempre spazi vuoti, anche piuttosto estesi ed evidenti, tra un modulo e l'altro, e comunque non credevo e non penso quanto il testo "interno" possa influire...perchè i 4 moduli non si incolonnano a 2 a 2 in modo limpido, visto che il template è anche fluido? non c'è verso di farli disporre su 2 colonne, uno sotto l'altro?....

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
mmm
ci dici che modulo  o componete  e quello  che lo provo sul mio mito di prove x vedere e  il modulo che ha casini .
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline alfaeomega

  • Esploratore
  • **
  • Post: 53
    • Mostra profilo
il modulo è quello di "AiDaNews 2", come dicevo l'ho clonato 4 volte per avere 4 moduli uguali (pensavo di avere meno problemi nella disposizione lato front se fossero stati uguali) e ho solo abbinato ogni modulo ad una categoria di notizie diverse, ma non so a questo punto se è un problema del template o se è perchè una volta messi nella stessa "position" si dispongono male boh....la position è "content-mass-bot"
se ci capite qualcosa mi date un grande aiuto....

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18158
  • Sesso: Femmina
    • Mostra profilo
ciao, grazie del consiglio ma putroppo non funziona....come vedi ho spezzato quel finto testo come se fossero piu parole, ma alla fine i moduli non si incolonnano, rimangono sempre spazi vuoti, anche piuttosto estesi ed evidenti, tra un modulo e l'altro, e comunque non credevo e non penso quanto il testo "interno" possa influire...

Secondo me se fai i moduli tutti uguali (come testo e figure) il problema non si presenta. Infatti ieri aggiustando il testo andava a posto e se adesso elimino la parte in eccesso nel primo modulo, il problema non si verifica. Sembra che il modulo di sinistra non si incastri sotto al primo ma rimanga allineato sotto l'ultimo di destra.
Poi magari è possibile sistemarlo con i css, e qui conti1 saprà come fare...  :)

[allegato vecchio più di un anno eliminato da un amministratore]

Offline conti1

  • Global Moderator
  • Instancabile
  • ********
  • Post: 9052
  • Sesso: Maschio
    • Mostra profilo
il modulo funziona 
http://www.contiwebsolution.com/demo1.7/
probabilmente hai qualcosa che da fastidio  nel template.
fai una prova  usa solo un modulo  e metti  i tuoi  articoli  con la stessa categoria e  sensa duplicare il tutto  ,
almeno vediamo   se sono gli articoli che fan danno oppure c'è altro.
se possibile postare il link  x risolvere al meglio il problema grazie
evitare nomi commerciali grazie

Offline alfaeomega

  • Esploratore
  • **
  • Post: 53
    • Mostra profilo
ciao!! ho fatto come avete proposto, ho abbinato a tutti e 4 i moduli la stessa categoria di notizie e si dispongono come volevo io, però il  problema resta nel senso che ovviamente ogni articolo di ogni categoria avra una lunghezza diversa e un testo diverso, quindi devo immaginare che se riabbino i 4 moduli a 4 categorie diverse , con i relativi articoli, i moduli si dispongono nuovamente in modo sballato?
non ho capito cosa devo fare per ordinarli in modo corretto, fermo restando che ogni modulo dovrà far visualizzare gli articoli della specifica categoria a cui è abbinato...
che faccio? :-)

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18158
  • Sesso: Femmina
    • Mostra profilo
non ho capito cosa devo fare per ordinarli in modo corretto, fermo restando che ogni modulo dovrà far visualizzare gli articoli della specifica categoria a cui è abbinato...
che faccio? :-)

Li fai uguali. E cioè scegli, ad esempio, lo stesso numero di caratteri e non di parole, lo stesso numero di articoli da visualizzare, ecc. Così i vari moduli saranno alti uguali, anche se abbinati a categorie diverse, e il problema non si porrà.

però il  problema resta nel senso che ovviamente ogni articolo di ogni categoria avra una lunghezza diversa e un testo diverso

Testo diverso sì, ma se il numero di caratteri è uguale...
Prova e ci dici.

Offline alfaeomega

  • Esploratore
  • **
  • Post: 53
    • Mostra profilo
appena provato, e funziona, MA a patto che i 4 moduli contengano o stesso "numero" di notizie, tipo 2 per ciascuna, ecc, se invece per es. 1 modulo ne mostra 3, 1 altro 2, un altro 4 ecc, immaginavo che anche se non fossero "appaiati" perchè ovviamente il numero di notizie visualizzate è diverso, fossero almeno incolonnato uno sotto l'altro, proprio come nell'esempio sul sito che avete postato, invece rimangono sempre slittati e con spazi vuoti e non so perchè....

Offline adottauncane

  • Team Joomla.it
  • Fuori controllo
  • *******
  • Post: 18158
  • Sesso: Femmina
    • Mostra profilo
Non è che slittano, si dispongono sotto quello più lungo. E mi sembra anche abbastanza logico. Probabilmente se tu avessi delle posizione su colonne diverse, cioè tre posizioni dentro un div e tre posizioni dentro un div affiancato, non succederebbe. Non vedo come sono le posizioni nel template, ma credo che il template sia commerciale, perciò, se lo è, non si dà supporto sul forum.

 

Host

Torna su