Autore Topic: Problemi con l'administrator...!  (Letto 3060 volte)

Offline Roby73

  • Nuovo arrivato
  • *
  • Post: 23
    • Mostra profilo
Problemi con l'administrator...!
« il: 11 Mar 2006, 18:59:08 »
Innanzitutto salve a tutti xchè sono nuovo nel forum e faccio i miei più sinceri complimenti allo staff e cmq a tutto il mondo joomla...!

Da circa un mesetto, con l'aiuto di un mio amico, ho deciso di rifare il mio sito in php tramite joomla con la gestione online.
Ho ancora il template di base xchè sto imparando e sto capendo i vari comandi ecc..., poco fa faccio x entrare nell'administrator e mi compare questo messaggio:

Fatal error: main(): Failed opening required '../includes/joomla.php' (include_path='.;c:\php\includes') in D:\Inetpub\webs\meteocasalecom\administrator\Index.php on line 23

L'host è con aruba e per ora è su win ma presto passerà a linux ma cmq sono sempre entrato nell'admin; una cosa che vorrei segnalare è che guardando l'elenco cartelle remote tramite programma ftp ho notato che vi è una "aruba-staff" dal 10/03..., non è che mi hanno scombussolato qualcosa......?
A dire il vero la cartella contiene un .rar e mi sembra strano mi abbiamo scombussolato qualcosa e senza avviso, dite che possa essere un problema temporaneo da parte dell'host?

Grazie in anticipo e mi scuso con i moderatori x eventuale pubblicità ma era necessaria x far capire...!

Roby

Offline giak

  • Team Joomla.it
  • Abituale
  • *******
  • Post: 1259
  • Sesso: Maschio
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #1 il: 11 Mar 2006, 19:10:39 »
l'errore e' chiaro: non trova il file joomla.php. Quindi sei entrato comunque in amministrator...? Per quello che riguarda il file .rar sull'host non so che dirti, non conosco nulla di quel provider quindi non so cosa sia o che probelami possa portare. Prova a chidere all'assistenza del provider e senti che ti dicono
webmaster
www.egiakweb.net
 Developer pgDesigner - Datamodel designer for PostgreSQL pgdesigner.sourceforge.net  I belive! Free as in Freedom www.gnu.org

Offline Roby73

  • Nuovo arrivato
  • *
  • Post: 23
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #2 il: 11 Mar 2006, 19:41:00 »
l'errore e' chiaro: non trova il file joomla.php. Quindi sei entrato comunque in amministrator...? Per quello che riguarda il file .rar sull'host non so che dirti, non conosco nulla di quel provider quindi non so cosa sia o che probelami possa portare. Prova a chidere all'assistenza del provider e senti che ti dicono

Certamente, nell'administrator online sono sempre entrato...!

Per il file .rar in effetti credo proprio che sia ininfluente; per quanto riguarda il Provider ho il dominio con loro dal 2002 e finchè facevo girare il sito con normale index.html ed il tutto fatto semplicemente con Frontpage a dire il vero il servizio non è mai stato interrotto, forse lasciano un pò a desiderare con il php anche xchè a quanto pare molti altri sembrano lamentarsi...!

Grazie comunque.
Roby

Offline Roby73

  • Nuovo arrivato
  • *
  • Post: 23
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #3 il: 11 Mar 2006, 22:45:31 »
Ho scoperto cosa è successo ma siceramente non so ancora il xchè...!

Via ftp ho guardato tutte le cartelle ed ho scoperto che incredibilmente era scomparsa la cartella "includes", inoltre in data 10/03/06 è comparsa una cartella "aruba-staff" contenente un file .rar nel quale vi era appunto la cartella "includes".....boh.......!!

Che ci sia un'impostazione da qualche parte dove in una tale data viene fatto una specie di backup?

A me sembra una cosa strana quanto incredibile!

Ora ho messo tutto a posto e funziona tutto correttamente ed anche il contenuto non è stato toccato però che mi venga tolta tale cartella....boh...!

Roby

Offline giak

  • Team Joomla.it
  • Abituale
  • *******
  • Post: 1259
  • Sesso: Maschio
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #4 il: 11 Mar 2006, 23:04:03 »
questa e' bella...non e' che nel file .rar ci sta il backup della cartella? La butto li cosi...
webmaster
www.egiakweb.net
 Developer pgDesigner - Datamodel designer for PostgreSQL pgdesigner.sourceforge.net  I belive! Free as in Freedom www.gnu.org

Offline Roby73

  • Nuovo arrivato
  • *
  • Post: 23
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #5 il: 12 Mar 2006, 00:33:48 »
questa e' bella...non e' che nel file .rar ci sta il backup della cartella? La butto li cosi...

Il file .rar infatti si chiamava includes.rar ed una volta entrati vi era una sola cartella chiamata appunto "inetpub", poi una sottocartella "webs", poi un'altra con il nome del mio dominio con estensione, e quindi la cartella ufficiale "includes".

Che sia pure un backup, ma dove sta impostato che in una tal cadenza di calendario si debba creare sto file di backup ma soprattutto xchè viene tolta dalla radice del sito mandando così in blocco il sito...?

Va beh, vedrò di scoprirlo...!

Quando lo scoprirò continuerò il post nel caso possa servire a qualche altro utente incappatosi nello stesso problema...!

Saluti
Roberto
« Ultima modifica: 12 Mar 2006, 11:00:42 da roberto »

Offline giak

  • Team Joomla.it
  • Abituale
  • *******
  • Post: 1259
  • Sesso: Maschio
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #6 il: 12 Mar 2006, 19:43:24 »
ok...attendiamo nuove notizie in merito. La cosa e' quanto meno curiosa
webmaster
www.egiakweb.net
 Developer pgDesigner - Datamodel designer for PostgreSQL pgdesigner.sourceforge.net  I belive! Free as in Freedom www.gnu.org

Offline Roby73

  • Nuovo arrivato
  • *
  • Post: 23
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #7 il: 18 Mar 2006, 16:14:58 »
ok...attendiamo nuove notizie in merito. La cosa e' quanto meno curiosa

Ho scoperto cosa è successo; in data 10/03 primo blocco e proprio oggi (18/03) altro blocco da parte dello staff di aruba con tanto di mail spiegando che è stata rilevata nella mia cartella "includes" la funzione mambo.php la quale rientra tra quelle ritenute pericolose per la stabilità del sistema server.

In poche parole devo provare a migrare il tutto su server Linux.

Va beh....!
Roby

Offline giak

  • Team Joomla.it
  • Abituale
  • *******
  • Post: 1259
  • Sesso: Maschio
    • Mostra profilo
Re: Problemi con l'administrator...!
« Risposta #8 il: 19 Mar 2006, 01:05:27 »
.......
webmaster
www.egiakweb.net
 Developer pgDesigner - Datamodel designer for PostgreSQL pgdesigner.sourceforge.net  I belive! Free as in Freedom www.gnu.org

 

Host

Torna su